probleme de déployement de dataverse

85 views
Skip to first unread message

mboundor diouf

unread,
Jun 27, 2019, 5:34:53 AM6/27/19
to Dataverse Users Community

Bonjour tout le monde,
Je suis stagiaire au CERDI/CNRS dans le but d'installer l'application dataverse pour CERDI. Mais je rencontre des problèmes pendant l'installation au niveau du deployment de dataverse.
J'ai vraiment besoin de votre secours merci bcp!
server.log

Philip Durbin

unread,
Jun 27, 2019, 6:29:03 AM6/27/19
to dataverse...@googlegroups.com
Thanks for attaching server.log.

Next can you please also attach a file that looks something like scripts/api/setup-all.sh1234? (The number is random so it won't be "1234".)

Thanks,

Phil

--
You received this message because you are subscribed to the Google Groups "Dataverse Users Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-commu...@googlegroups.com.
To post to this group, send email to dataverse...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/dataverse-community/6b25823a-0acf-47fc-b379-e467f5bbfcbb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


--

mboundor diouf

unread,
Jun 28, 2019, 4:05:01 AM6/28/19
to Dataverse Users Community
Hi Philip Durbin !
this is my server.log and the setup-all.sh.
thanks!
server.log
setup-all.sh

mboundor diouf

unread,
Jun 28, 2019, 4:35:05 AM6/28/19
to Dataverse Users Community

Maintenant j'ai reinstallé dataverse et le deployment à marcher mais j'ai un probléme au niveau de POST-DEPLOYMENT  setup script. Je mets en piéce jointe une capture de l'erreur.

Le jeudi 27 juin 2019 11:34:53 UTC+2, mboundor diouf a écrit :
VirtualBox_centos_28_06_2019_10_19_19.png

Philip Durbin

unread,
Jun 28, 2019, 6:33:13 AM6/28/19
to dataverse...@googlegroups.com
Is setup-all.sh executable?

If you run the following command...

ls -l scripts/api/setup-all.sh

... does it show...

-rwxr-xr-x

? This is how it looks for me:

$ ls -l scripts/api/setup-all.sh
-rwxr-xr-x  1 pdurbin  staff  4148 Jan 15 18:38 scripts/api/setup-all.sh

Also, in your screenshot I see the file that I would like you to send. Can you please attach setup-all.sh.8075.log either here or in an email to sup...@dataverse.org?

It might be easier to troubleshoot in real time at http://chat.dataverse.org if you would like to join there.

Phil

--
You received this message because you are subscribed to the Google Groups "Dataverse Users Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-commu...@googlegroups.com.
To post to this group, send email to dataverse...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

mboundor diouf

unread,
Jun 28, 2019, 9:11:47 AM6/28/19
to dataverse...@googlegroups.com
bonjour philip,
Merci encore de votre aide, mais je n'arrive pas à trouver le document :scripts / api / setup-all.sh dans l'ordinateur (centos7). Il n y a même pas  le chemin d' accès scripts / api . Je pense que je dois installer queleque chose d'abord mais je ne sais pas.
aide svp

mboundor diouf

unread,
Jun 28, 2019, 9:54:11 AM6/28/19
to dataverse...@googlegroups.com
le dossier   ./scripts/api/ nexite pas chez moi . Comment dois je faire maintenant ?

Philip Durbin

unread,
Jun 28, 2019, 10:07:32 AM6/28/19
to dataverse...@googlegroups.com
Does anyone who's reading this speak French? And has successfully installed Dataverse? I don't speak French.


For more options, visit https://groups.google.com/d/optout.

mboundor diouf

unread,
Jun 28, 2019, 10:20:33 AM6/28/19
to Dataverse Users Community
Ok I am sorry!
Thank you again for your help,
 but I can not find the document: scripts / api / setup-all.sh
in my computer (centos7). There is not even the script / api/.
I think I must do to install something first but I do not know how to do it.

Le jeudi 27 juin 2019 11:34:53 UTC+2, mboundor diouf a écrit :

Philip Durbin

unread,
Jun 28, 2019, 10:37:56 AM6/28/19
to dataverse...@googlegroups.com
If you are using CentOS 7, that's great. Just this week I added a "quickstart" section to the dataverse-ansible README:


Please give this a try on a fresh installation of CentOS 7.

Thanks!

--
You received this message because you are subscribed to the Google Groups "Dataverse Users Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-commu...@googlegroups.com.
To post to this group, send email to dataverse...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Philip Durbin

unread,
Jul 2, 2019, 7:50:14 AM7/2/19
to dataverse...@googlegroups.com
Just bring closure to this issue, yesterday at http://irclog.iq.harvard.edu/dataverse/2019-07-01#i_99595 Michel Bamouni from INRA let me know that Mboundor was able to successfully install Dataverse after they went back in forth in French. Thanks, Michel and I'm glad you got it working Mboundor! For my reference, the details are in this ticket: https://help.hmdc.harvard.edu/Ticket/Display.html?id=278041

Phil


For more options, visit https://groups.google.com/d/optout.

mboundor diouf

unread,
Jul 2, 2019, 8:00:44 AM7/2/19
to dataverse...@googlegroups.com
Effectivement comme vous l'avez dit, j'ai  ben installer dataverse
avec votre aide et Michel.
Je suis trés satisfait de l'accompagnement!
merci bcp!
trés cordialement,
Diouf Mboundor!

Reply all
Reply to author
Forward
0 new messages