Failure to upgrade to version 6.12 on RHEL

27 views
Skip to first unread message

Pedro Luis

unread,
Sep 22, 2026, 10:27:36 AM (23 hours ago) Sep 22
to Dataverse Users Community
Dear all,
I am having trouble updating my Dataverse environment to version 6.12. I read the note regarding Dataverse installation errors on RHEL, but it did not specify that the issue would also occur during upgrades—if that is indeed the case.

The incident differs from what is described in the note: "We are investigating an issue (#12724) where we suspect that new installations on Red Hat servers may fail. Upgrades on Red Hat should not be affected and neither neither new installations nor upgrades seem to be affected on Debian/Ubuntu. We will update this note when we know more."

The error I receive is:
/usr/local/payara7/bin/asadmin deploy dataverse-6.12.war
remote failure: Error occurred during deployment: Exception [EclipseLink-4002] (Eclipse Persistence Services - 5.0.0.payara-p1.v202603270942-bedcae92a73681614099387d0927edd7c22c00eb): org.eclipse.persistence.exceptions.DatabaseException
Internal Exception: java.sql.SQLException: Error in allocating a connection. Cause: Connection could not be allocated because: FATAL: role "dataverse" does not exist
Error Code: 0. Please see server.log for more details.
Command deploy failed.

Is this one of the issues that occur in installations running on RHEL?

William Hahn

unread,
Sep 22, 2026, 11:04:44 AM (22 hours ago) Sep 22
to dataverse...@googlegroups.com
Hi Pedro,

I recently had issues installing from scratch using dataverse-ansible, and was able to get it to run successfully by bumping postgres to version 17.

Even so, I was able to upgrade on a test server (Rocky 9.8, running postgres 16.15)  without any apparent issues. We were ultimately able to trace the EclipseLink issue to https://github.com/payara/Payara/issues/8250

Best,
William

--
You received this message because you are subscribed to the Google Groups "Dataverse Users Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-commu...@googlegroups.com.
To view this discussion visit https://groups.google.com/d/msgid/dataverse-community/22cb0949-5dc3-4d06-bfc3-e892c42f751cn%40googlegroups.com.

Philip Durbin

unread,
Sep 22, 2026, 12:00:25 PM (21 hours ago) Sep 22
to dataverse...@googlegroups.com
Hi Pedro,

Like William says, we think upgrades to 6.12 should be ok. I also tested this.

Can you please say any more about this error: "FATAL: role "dataverse" does not exist"? Is there a mismatch between the roles in your database and what role Dataverse is configured to connect with?

Thanks,

Phil

p.s. We did update that warning at the top of the 6.12 release note this morning. It's still about new installations but we think it has to do with PostgreSQL 16 vs 17 rather than Red Hat vs Ubuntu. Here's the latest message:

"Please note: We are investigating an issue (#12724) where we suspect that new installations on PostgreSQL 16 will fail but it works fine on PostgreSQL 17. (Upgrading an existing Dataverse installation that's using PostgreSQL 16 seems to work fine.) We will update this note when we know more."




--
Reply all
Reply to author
Forward
0 new messages