Hi Pedro,
Like William says, we think upgrades to 6.12 should be ok. I also tested this.
Can you please say any more about this error: "FATAL: role "dataverse" does not exist"? Is there a mismatch between the roles in your database and what role Dataverse is configured to connect with?
Thanks,
Phil
p.s. We did update that warning at the top of the 6.12 release note this morning. It's still about new installations but we think it has to do with PostgreSQL 16 vs 17 rather than Red Hat vs Ubuntu. Here's the latest message:
"Please note: We are investigating an issue (#12724) where we suspect that new installations on PostgreSQL 16 will fail but it works fine on PostgreSQL 17. (Upgrading an existing Dataverse installation that's using PostgreSQL 16 seems to work fine.) We will update this note when we know more."