Upgrading from Dataverse 4.8.6 to 4.9.2 and the field "shoulder" in db table "setting"

29 views
Skip to first unread message

ofu...@gmail.com

unread,
Sep 15, 2018, 9:07:33 AM9/15/18
to Dataverse Users Community
Hi,
I upgraded our production Dataverse from Dataverse 4.8.6 to 4.9.2.  When I look at the db table "setting" , I could see a new field called "shoulder" and it  is assigned the same DOI-prefix value as in "Authority".  I have read Dataverse guides and can't figure out if I should remove "shoulder"or not.  I need help to understand what to do.

Cheers
Obi

Jim Myers

unread,
Sep 15, 2018, 9:17:33 AM9/15/18
to Dataverse Users Community
Obi,
4.9.2 separates what was previously in the authority setting into authority and shoulder settings. So in 4.8.6 a test setup would have had authority = 10.5072/FK2 and, after upgrading, including running the DB upgrade script, it should have authority = 10.5072 and Shoulder = FK2.  (The database entries for datasets are adjusted as well, with the shoulder moving from the authority to identifier fields.) The overall effect should be that there's no change in existing DOIs or to new ones you mint. However, the change does allow you to have DOIs that do not have a second / character after the shoulder. (so 10.5072/FK2ABCDEF is possible in 4.9.2 but not 4.8.6).

-- Jim

ofu...@gmail.com

unread,
Sep 15, 2018, 9:35:15 AM9/15/18
to Dataverse Users Community
Jim, thanks for your quick answer. But our setting in 4.8.6 was authority = 10.5072 and not 10.5072/FK2.  What should I do here? Delete shoulder?

- Obi

Péter Király

unread,
Sep 15, 2018, 9:37:48 AM9/15/18
to dataverse...@googlegroups.com
Hi Obi,

I had a similar problem, you can check the conversation with Phil
Durbin, who helped to detect and fix the problem:

https://github.com/IQSS/dataverse/issues/4923

Best,
Péter
> --
> You received this message because you are subscribed to the Google Groups "Dataverse Users Community" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-commu...@googlegroups.com.
> To post to this group, send email to dataverse...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/dataverse-community/0fa86ced-9b6d-49ae-8d63-bea53d3d12da%40googlegroups.com.
> For more options, visit https://groups.google.com/d/optout.



--
Péter Király
software developer
GWDG, Göttingen - Europeana - eXtensible Catalog - The Code4Lib Journal
http://linkedin.com/in/peterkiraly

Jim Myers

unread,
Sep 15, 2018, 9:39:45 AM9/15/18
to Dataverse Users Community
If you do not want to have a shoulder, e.g. to have DOIs of the form 10.5072/[ABCDEF] where the six letters would be the unique random alphanumeric or sequential number Dataverse generates, you can delete the Shoulder setting. It defaults to "" if no Shoulder setting is found.

-- Jim

On Saturday, September 15, 2018 at 9:07:33 AM UTC-4, ofu...@gmail.com wrote:

Jim Myers

unread,
Sep 15, 2018, 9:42:07 AM9/15/18
to Dataverse Users Community
One more thought - you do need to have authority set as before. If I recall, the upgrade script may set it incorrectly if there is no shoulder used in 4.8.6 (moving the whole authority to shoulder instead of just finding and moving the shoulder.). I think that's a bug that could be documented or fixed...

-- Jim

On Saturday, September 15, 2018 at 9:07:33 AM UTC-4, ofu...@gmail.com wrote:

ofu...@gmail.com

unread,
Sep 15, 2018, 10:00:48 AM9/15/18
to Dataverse Users Community
Thanks again. Your correct, the value in authority was moved to shoulder after upgrading to 4.9.2,

If I understand you correctly,  do I set DOI shoulder  to be  “FK2/” , "shoulder/" or "any string/"?

Obi

Jim Myers

unread,
Sep 15, 2018, 10:18:48 AM9/15/18
to Dataverse Users Community
If you are not using a shoulder, you should just delete the :Shoulder setting.

ofu...@gmail.com

unread,
Sep 15, 2018, 10:29:51 AM9/15/18
to Dataverse Users Community
Thanks.

Jim Myers

unread,
Sep 15, 2018, 10:50:19 AM9/15/18
to Dataverse Users Community
FWIW: Just posted an issue with a proposed fix for the upgrade script that might be useful for anyone else not using a shoulder and upgrading from 4.8.6...

-- Jim


On Saturday, September 15, 2018 at 9:07:33 AM UTC-4, ofu...@gmail.com wrote:

Jim Myers

unread,
Sep 15, 2018, 10:54:32 AM9/15/18
to Dataverse Users Community
Reply all
Reply to author
Forward
0 new messages