getting through the DVN installation post GlassFish configuration.

33 views
Skip to first unread message

Jaime Pinto

unread,
Aug 22, 2014, 12:45:14 PM8/22/14
to dataverse...@googlegroups.com
I went over these instructions several times, and in several attempts could not get DVN to install after GlassFish, ...
http://thedata.harvard.edu/guides/dataverse-installer-main.html
http://thedata.harvard.edu/guides/dataverse-installer-main.html#glassfish-configuration-template


... until I replaced the original contents of /var/lib/pgsql/data/pg_hba.conf:
# TYPE  DATABASE    USER        CIDR-ADDRESS          METHOD

# "local" is for Unix domain socket connections only
local   all         all                                 ident
# IPv4 local connections:
host    all         all         127.0.0.1/32        ident
# IPv6 local connections:
host    all         all         ::1/128            ident



with:
# TYPE  DATABASE    USER        CIDR-ADDRESS          METHOD

# "local" is for Unix domain socket connections only
local   all         all                               trust
# IPv4 local connections:
host    all         all         127.0.0.1/32          password
# IPv6 local connections:
host    all         all         ::1/128               ident


The timing in which to do the switch is not clean, and the quick install script will not do that for us.
Maybe those instructions could be improved to make it more obvious for the next guy.

I wasted many hours(days!) uninstalling GlassFish, dropping dvn DB and user from postgresql and restarting the process until I got this thing going.

Maybe the install script could also be improved to detect that the user&database has already been created on a previous attempt, GlassFish has been installed, configured and is working properly, etc, and pickup the slack from where it failed or got stuck, even if some input is required from the person installing, to by-pass some of those steps.

Thanks
Jaime

Philip Durbin

unread,
Sep 7, 2014, 11:03:38 AM9/7/14
to dataverse...@googlegroups.com
You have some valid points, for sure, and they apply to the equivalent installer (and docs) for Dataverse 4.0. Would you be willing to file an issue at https://github.com/IQSS/dataverse/issues about this?

Thanks for your interest in Dataverse!

Phil

--
You received this message because you are subscribed to the Google Groups "Dataverse Users Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-commu...@googlegroups.com.
To post to this group, send email to dataverse...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/dataverse-community/3a67fae0-d110-4595-920b-eb5e13f9b13a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Reply all
Reply to author
Forward
0 new messages