Broken packages in R, and cannot load stable R or Lavaan - can anyone help?

12 views
Skip to first unread message

R McLaren

unread,
Jan 27, 2017, 4:54:32 PM1/27/17
to Dataverse Users Community
Hi I'm running a linux box with ubuntu xenial. 

I need to install R version suitable for lavaan, I believe 3.2.3. But I'm getting this error:

E: Unable to correct problems, you have held broken packages.
ubuntu@ubuntu-Satellite-L775D:~$ dpkg --get-selections | grep "^r\-"
r-base-core deinstall
r-mathlib deinstall

Would anyone have an idea of how to clean up this situation?  

Thanks in advance, Rick

Philip Durbin

unread,
Jan 27, 2017, 6:10:52 PM1/27/17
to dataverse...@googlegroups.com
The Dataverse dev team only tests on RHEL/CentOS but there are community efforts to support Ubuntu. These links might help:

- https://github.com/IQSS/dataverse-puppet
- https://github.com/IQSS/dataverse-ansible
- https://github.com/IQSS/dataverse/issues/1059

I'm sorry I can't be of more help. Maybe someone who runs Dataverse on Ubuntu can advise.

Have a good weekend,

Phil

p.s. I just took a look at https://cran.r-project.org/web/packages/lavaan/index.html but I'd never heard of it and if it's used by Dataverse, TwoRavens, or Zelig, I didn't know. :)

--
You received this message because you are subscribed to the Google Groups "Dataverse Users Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-community+unsub...@googlegroups.com.
To post to this group, send email to dataverse-community@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/dataverse-community/5ee8f4b9-70db-4437-a20e-6aed085a5475%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Reply all
Reply to author
Forward
0 new messages