Patch for Dart version as of 2012/05/24

4 views
Skip to first unread message

Rupert Key

unread,
May 24, 2012, 11:39:01 AM5/24/12
to dartbox2...@googlegroups.com
TL;DR Fix for current Dart version pushed to clone rupertkey-dartbox2d-20120524.  Pull request?

Hi,
First, great job with doing the Dart port!  I fancied prototyping a game using Dart (after attending the London hackathon a couple of weeks back) and needed Box2D.  Always nice when your prereq's are waiting for you :-D

That said, I found the existing version errored with "UnsupportedOperationException: Cannot add to a non-extendable array" in "BroadPhase.dart".  Looks like List's construction has changed and specifying capacity causes them to be fixed capacity and add() not to work!  Switching to dynamic size fixed that [for now].  Next, webkitRequestAnimationFrame() no longer takes the canvas element.  Tests fine on current Dartium that comes with Dart IDE on Linux 32-bit (in case there're differences).

I've cloned the repository and pushed 1 changeset.  Let me know if/how to issue a pull-request (if such one does with git on Google Code!).

Looking forward to getting my prototype on now :-D
Cheers, Rupert.
Reply all
Reply to author
Forward
0 new messages