Add import intention stopped working

9 views
Skip to first unread message

Denis McCarthy

unread,
Aug 25, 2022, 5:19:04 PMAug 25
to Cursive
Hi,
I have been using cursive with no problems for several months. A couple of days ago, I noticed that the auto-suggestion to add a ns :require (or Java :import) had disappeared from the editor. Not sure what I did to cause the problem, I had gone to IntelliJ low power mode shortly beforehand but maybe that had nothing to do with it. Anyhow, I can't figure out how to get them back. I have tried disabling/re-enabling cursive but that hasn't worked

I'm using IntelliJ 2022.2 build #IU-222.3345.118, cursive build 1.12.4-2022.2. There are only three intentions listed under Editor -> Intentions -> Clojure (Convert #() to fn, Resolution and Indentation -? Indentation) and all are set to 'yes'. 

Any help greatly appreciated as this is like a stone in my shoe.
Thanks in advance
Denis

Denis McCarthy

unread,
Aug 25, 2022, 5:28:29 PMAug 25
to Cursive
The 'problem disappearing immediately after asking a  question' gods have struck again. Just tried again there after disabling/reenabling the intentions and my import suggestions are back.
Reply all
Reply to author
Forward
0 new messages