Outdated versions of Clojure and Leiningen

29 views
Skip to first unread message

Dennis Schridde

unread,
Aug 21, 2022, 10:42:20 AMAug 21
to cur...@googlegroups.com
Hi!

When I create a new project (File > New > Project > Bare Project) Cursive says
"Project library Clojure-1.9.0 will be created". When I click "Configure",
1.9.0 is the latest version of Clojure I can select. Current is 1.11.1.

When I open the Leiningen settings (File > Settings > Build, Execution,
Deployment > Build Tools > Leiningen) the latest "Leiningen version" I can
select is 2.9.3. Current is 2.9.10.

I would have expected to see the current versions of Clojure and Leiningen in
the drop down selection lists.

Cursive version (File > Settings > Plugins > Installed > Cursive) is
1.12.4-2022.2.

Am I using an outdated version of Cursive that is not shown correctly in the
plugin settings? Or is there an "update" button that I missed to click?

--Dennis


Colin Fleming

unread,
Aug 24, 2022, 4:17:38 AMAug 24
to Cursive Group
No, you're not missing anything, currently I update those versions by hand in the code and I've obviously neglected to update them. I'm also planning to have Cursive check for newer versions periodically. I'll try to do that in this EAP series.

Cheers,
Colin
> --
> You received this message because you are subscribed to the Google
> Groups "Cursive" group.
> To unsubscribe from this group and stop receiving emails from it, send
> an email to cursive+u...@googlegroups.com.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/cursive/4358176.oanFPnh2Ml%40ernie.
Reply all
Reply to author
Forward
0 new messages