Cursive 1.12.5-eap2

41 views
Skip to first unread message

Cursive

unread,
Sep 25, 2022, 6:51:13 PMSep 25
to cur...@googlegroups.com

Hi everyone,

Cursive 1.12.5-eap2 is out. It contains a couple of fixes to the arity checking, but it mostly adds support for the new 2022.3 EAP, which is out now. The Package Search APIs have changed a lot in this release (they drive the Dependencies toolwindow and the inspections recommending package upgrades for lein/deps), so some of that is still broken. I’m getting some help from JetBrains in sorting it out, so hopefully it’ll be fixed soon.

Here are the issues:

Added
  • Add support for IntelliJ 2022.3 EAP #2733
Fixed
  • Deftype method implementations show false errors in CLJC files when method arity over 1 #2346
  • Invalid arity detection for protocol implementation #1431

Cheers,
Colin

Reply all
Reply to author
Forward
0 new messages