Unable to type with cursive enabled

21 views
Skip to first unread message

Matthew Francis-Landau

unread,
Jul 31, 2021, 10:41:20 PMJul 31
to Cursive
Hello,

I am experiencing an issue when trying to use cursive in intellij, and I am wondering if there is some strange mode/setting that I am getting myself into without being aware.

Currently I am experiencing an issue where I am unable to type anything.  Anytime that I enter a character, it will be deleted almost immediately afterwards.  Characters which would normally be inserted in pairs (such as () or "") do not even show up when I attempt to type them.  So far the only way I have figured out how to get out of this "mode" is to just restart Intellij.  I have tried disabling all other plugins, and this is only happening when cursive is enabled.

I have taken a short screen capture to demonstrate this issue.  In this video I am only pressing keys on my keyboard and not hitting backspace or delete at all.

Thanks,
Matthew

Colin Fleming

unread,
Aug 1, 2021, 11:06:24 PMAug 1
to Cursive Group
Hi Matthew,

That is very strange. Unfortunately, I can't think of anything good to suggest, since you've already tried disabling all other plugins. I really can't think of anything in Cursive that would provoke that behaviour. Whatever is happening must be happening at a fairly low level in Cursive/IntelliJ, and I can't think of a good way to diagnose it. Perhaps you could try the Presentation Assistant plugin to see if there are some other actions being invoked somehow? https://plugins.jetbrains.com/plugin/7345-presentation-assistant/

Sorry I can't be more help,
Colin
--
You received this message because you are subscribed to the Google Groups "Cursive" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cursive+u...@googlegroups.com.

Reply all
Reply to author
Forward
0 new messages