Cursive 1.12.6

37 views
Skip to first unread message

Cursive

unread,
Dec 14, 2022, 3:59:44 PM12/14/22
to cur...@googlegroups.com

Hi everyone,

Cursive 1.12.6 is out. It fixes one issue with error submission to the exception tracker, but the main thing it fixes is an incompatibility with the latest version of deps. In version 1.11.1.1208, the Clojure CLI tools switched from using tools.deps.alpha to tools.deps, with the corresponding namespace changes. Since Cursive contains code calling into deps directly, this caused some breakage. This release fixes that.

Here are the issues:

Fixed

  • "Could not create shim" error when using deps 1.11.1.1208 #2754
  • 422 Unprocessable Entity error when submitting errors to tracker #2747

Cheers,
Colin

Reply all
Reply to author
Forward
0 new messages