misleading installation (no errors, but not working)

9 views
Skip to first unread message

Ivar Vasara

unread,
Apr 13, 2009, 3:05:13 AM4/13/09
to Curb - Ruby libcurl Bindings
I'm very confused. On my local (OS X) machine, I've install Curb and
when I run irb, "require 'Curl'" fails. (curl libs were installed
using macports) If I run the rails console (ie: script/console),
"require 'Curl'" works and I can access the lib. So the first thing
that is confusing is the discrepancy between the two interactive
environments.

Next, on a ubuntu server, I've installed (what I believe to be) the
dependencies (libcurl3, libcurl4-openssl-dev, and libcurl3-gnutls)
then used gem to install curb. No error msgs during install, and
everything looks good. gem list --local shows that curb is installed,
but I can't run "require 'Curl'" in either irb or the rails console.

If it weren't for the fact that I've already got my curb-reliant code
working in Rails on my osX machine, I'd give up, but as it is, I'm
hoping to fix this. I've tried building the gem from the source at
github, but there's no love there. (Also note that curb.gemspec at
github says version 2.8.0) Note that this issue might be the same or
similar to the problem the first poster in this forum had on windows.

Any clues as to how to proceed ?


Ivar Vasara

unread,
Apr 13, 2009, 3:06:15 AM4/13/09
to Curb - Ruby libcurl Bindings
also note that all the tests passed during installation.

Todd Fisher

unread,
Apr 13, 2009, 6:54:42 AM4/13/09
to curb---ruby-li...@googlegroups.com
try either:

require 'rubygems'
require 'curb'

Instead of

require 'Curl'
Reply all
Reply to author
Forward
0 new messages