Re: [CUL] Promlem: USBtoSerial installieren

1390 views
Skip to first unread message
Message has been deleted

Olaf Droegehorn

unread,
May 10, 2011, 5:18:23 PM5/10/11
to cul-...@googlegroups.com
Hallo,

Ger�te-Treiber Installation fehlschlagen lassen, und dann �ber den
Ger�te Manager Treiber-Software aktualisieren. Dann auf dem Rechner nach
nem Treiber suchen lassen und entsprechend installieren.

X64 funzt mit myusb_usbtoserial.inf nicht. Dazu von Busware die CUL.inf
runterladen, die geht auch f�r 64Bit Systeme.

Gru�,
Olaf

Am 10.05.2011 23:15, schrieb Kabs:
> Erstmal Hallo zusammen, ich bin neu hier im Forum.
>
> Ich habe mir einen CUL 3.2 gekauft und w�rde diesen gerne mit der
> Firmware culfw flashen. Leider scheitere ich an der Installation von
> USBtoSerial. Wenn ich versuche, MyUSB_USBtoSerial.inf �ber das
> Kontextmen� zu installieren, bekomme ich die Fehlermeldung �Diese
> Installationsmethode wird von der ausgew�hlten INF-Datei nicht
> unterst�tzt.�
>
> Im FLIP bekomme ich die Meldung �AtLibUsbDfu.dll not found�.
>
> Ich habe die Installation an zwei Systemen versucht, Win7 x64 und Win7
> x86.
> Mit cmd: "bcdedit /set testsigning no" habe ich die Sperre f�r
> unsignierte Treiber deaktiviert, daran liegt es anscheinend nicht.
>
> Wer wei� Rat?
>

--
------------------------------------------------------------------------
Prof. Dr. Olaf Droegehorn
General Manager Tel. : +49-561-82020-410
DHS - Computertechnik GmbH Fax. : +49-561-82020-399
Carlsdorfer Stra�e 3 E-Mail: O.Droegehorn@dhs-
computertechnik.de
D-34128 Kassel WEB: www.dhs-computertechnik.de
------------------------------------------------------------------------

Kabs

unread,
May 10, 2011, 5:38:27 PM5/10/11
to CUL fans
hier nocheinmal die ursprüngliche Frage, hatte sie gelöscht als Sie
schon geantwortet haben:

Erstmal Hallo zusammen, ich bin neu hier im Forum.

Ich habe mir einen CUL 3.2 gekauft und würde diesen gerne mit der
Firmware culfw flashen. Leider scheitere ich an der Installation von
USBtoSerial. Wenn ich versuche, MyUSB_USBtoSerial.inf über das
Kontextmenü zu installieren, bekomme ich die Fehlermeldung „Diese
Installationsmethode wird von der ausgewählten INF-Datei nicht
unterstützt.“

Im FLIP bekomme ich die Meldung „AtLibUsbDfu.dll not found“.

Ich habe die Installation an zwei Systemen versucht, Win7 x64 und Win7
x86.
Mit cmd: "bcdedit /set testsigning no" habe ich die Sperre für
unsignierte Treiber deaktiviert, daran liegt es anscheinend nicht.

Wer weiß Rat?

Kabs

unread,
May 10, 2011, 6:07:22 PM5/10/11
to CUL fans
Auf meinem Notebook mit Win7 32 Bit kann ich myusb_usbtoserial.inf
ebenfalls nicht installieren, es kommt hier die gleiche Fehlermeldung.

Nachdem ich nun den CUL.inf Treiber im Gerätemanager manuell
installiert habe, wird der Stick als "unknown device" unter USB Geräte
gelistet. Beim erneuten Versuch, den Treiber zu installieren, meldet
Windows, es sei bereits der optimale Treiber installiert.

Im FLIP bekomme ich nach wie vor die Meldung „AtLibUsbDfu.dll not
found“.

Olaf Droegehorn

unread,
May 10, 2011, 6:17:12 PM5/10/11
to cul-...@googlegroups.com
Hi,

zum programmieren mit FLIP mu�t Du den Taster des CUL (R�ckseite) BEIM
Einstecken in den USB-Port dr�cken.

Danach wird der CUL als LIB32 Device erkannt.

Gru�,
Olaf

Am 11.05.2011 00:07, schrieb Kabs:
> Auf meinem Notebook mit Win7 32 Bit kann ich myusb_usbtoserial.inf
> ebenfalls nicht installieren, es kommt hier die gleiche Fehlermeldung.
>

> Nachdem ich nun den CUL.inf Treiber im Ger�temanager manuell
> installiert habe, wird der Stick als "unknown device" unter USB Ger�te


> gelistet. Beim erneuten Versuch, den Treiber zu installieren, meldet
> Windows, es sei bereits der optimale Treiber installiert.
>

> Im FLIP bekomme ich nach wie vor die Meldung �AtLibUsbDfu.dll not
> found�.
>

--

Kabs

unread,
May 10, 2011, 6:24:13 PM5/10/11
to CUL fans
Hab ich gemacht, während dem Reinschieben Taster mit Stiftspitze
gedrückt, habe Schalter gespürt, gedrückt gehalten, nichts hat sich
geändert. Mehrmals versucht.

Olaf Droegehorn

unread,
May 10, 2011, 6:33:07 PM5/10/11
to cul-...@googlegroups.com
Hi,

ok, dann ist aber CUL.inf falsch. Dann im FLIP-Verzeichnis unter USB
schauen. Da liegen die Treiber f�r den Programmier-Modus.

Sorry f�r die Verwirrung. CUL.inf ist f�r den Fall, dass CUL bereits
programmiert ist.

Also Treiber nochmals aktualisieren und den ATMEL Treiber im
Flip-Verzeichnis w�hlen.

gru�

Am 11.05.2011 00:24, schrieb Kabs:
> Hab ich gemacht, w�hrend dem Reinschieben Taster mit Stiftspitze
> gedr�ckt, habe Schalter gesp�rt, gedr�ckt gehalten, nichts hat sich
> ge�ndert. Mehrmals versucht.
>

--
------------------------------------------------------------------------
Prof. Dr. Olaf Droegehorn
General Manager Tel. : +49-561-82020-410
DHS - Computertechnik GmbH Fax. : +49-561-82020-399

Carlsdorfer Stra�e 3 E-Mail: O.Droegehorn@dhs-

Kabs

unread,
May 10, 2011, 6:51:09 PM5/10/11
to CUL fans
Habs versucht, da kommt wieder die Meldung, Treiber seien auf dem
neuesten Stand.

Olaf Droegehorn

unread,
May 11, 2011, 1:08:45 AM5/11/11
to cul-...@googlegroups.com
Hallo,

das ist doch klar.
Daher entweder das Treiberupdate erzwingen, oder Device deinstallieren
und erneut den richtigen von vorn installieren.

Gru�

Am 11.05.2011 00:51, schrieb Kabs:
> Habs versucht, da kommt wieder die Meldung, Treiber seien auf dem
> neuesten Stand.
>

--

Kabs

unread,
May 11, 2011, 6:43:07 AM5/11/11
to CUL fans
Hallo Olaf,

danke für die Mühe. Leider komme ich nicht weiter. Habe das Device
natürlich deinstalliert, dann verschwindes es aus dem Geräte-Manager.
Stecke ich den Stick aus und erneut ein, erscheint es wieder als
unknown device und ich bekomme die gleiche Meldung wie zuvor. Wie ich
das Treiberupdate erzwingen kann, ist mir nicht klar.
Was mir aufgefallen ist: Bei Treiberanbieter steht Microsoft (im
Gerätemanager).

Ich hänge mal einen Screenshot an. Schritt 1 zeigt manuell nach
Treiber suchen, Schritt 2
zeigt Treiber aus der Liste suchen. Die jeweiligen Meldungen habe ich
Ergebnis 1 bzw 2 genannt.

[URL=http://www.imgbox.de/show/img/Eijguhjyf3.png]http://www.imgbox.de/
show/img/Eijguhjyf3.png[/URL]

Kabs

unread,
May 11, 2011, 6:46:01 AM5/11/11
to CUL fans

Kabs

unread,
Jun 15, 2011, 6:43:55 PM6/15/11
to CUL fans
Hab nun die culfw drauf, habe aber nachwievor das Problem, dass er mir
unter Windows den CUL als "unknown device" deklariert. Sowohl unter
Win 7 als auch Win XP. Bei XP aktualisiert sich der Geräte Manager
alle paar Sekunden, solange der CUL eingesteckt ist.

CUL.inf kann ich unter Win7 x64 nicht installieren, ich bekomme eine
Fehlermeldung. Bei XP bekomme ich keine Fehlermeldung, es passiert
einfach nichts. Der Stick bleibt trotzdem als "unknown device" im
Geräte Manager. Unter Linux bekomme ich mit "/dev/ttyACM0" die
richtige Firmwareversion angezeigt, daran kann es nicht liegen.

Möglicherweise liegt es am virtuellen COM Port. Muss ich den
einrichten, bevor ich CUL.inf installiere? Habe unter Win7 einen COM
Port bei Anschlüsse, bei XP habe ich keine Ahnung, wie ich ihn
erstellen kann. Oder geschieht das erst nach erfolgreicher Ausführung
der CUL.inf bzw. myUSBtoSerial?

Thorsten Oelgart

unread,
Mar 17, 2013, 4:57:26 AM3/17/13
to cul-...@googlegroups.com
Hallo,

also bis gestern stand ich auch genau vor dem Problem. Nachdem ich aber Flip 3.4.7 (das Atmel-Flash-Tool) heruntergeladen habe (http://www.atmel.com/tools/flip.aspx ) und dann unter Windows 7  im Gerätemanager "Teibersoftware aktualisieren" --> "Auf Computer suchen" --> Flip Installationsverzeichnis auswählen, hat er den CUL als Atmel USB Device ATmega32U4 erkannt. Ich kann seit dem mit Flip auch die Kommunikation herstellen und den CUL flashen.

Jetzt stehe ich aber vor dem Problem, wie ich dem USB Gerät einen COMx Port zuweise, damit ich die CULFW Commands testen kann. Kann da jemand helfen?

Vielen Dank!

Swen

unread,
Mar 17, 2013, 11:22:13 AM3/17/13
to cul-...@googlegroups.com
Also ich hatte ende letzten Jahres ein ähnliches Problem unter Windows 7 x64.
Culfw war drauf aber mein Windows wollte keinen Treiber für den Virtuellen COM installieren. Nach etwas Recherche konnte ich mir eine eigene INI erstellen.

Angehängte TXT in INI umbenennen -  rechtsklicken und auf "Installieren". ERST DANN wieder das CUL einstecken.
Sollte dann den nächsten freien COM bekommen. Kann man im Gerätemanager nachschauen.

Hoffe ihr kommt weiter.

Gruß Swen
BUSWARE-CULx64.inf.txt

Thorsten Oelgart

unread,
Mar 17, 2013, 12:12:26 PM3/17/13
to cul-...@googlegroups.com
Hallo uns supervielen Dank für Deine so praktische Hilfe!

Leider kommt bei mir dann immer noch die Fehlermeldung "Diese Installationsmethode wird von der ausgewählten INF-Datei nicht unterstützt.". Gibt es noch eine andere Installationsmethode (außer Rechtsklick --> Installieren)?

Viele Grüße

swifty

unread,
Oct 10, 2013, 9:37:48 AM10/10/13
to cul-...@googlegroups.com
Hallo,

habe nun das gleiche Problem. Unter XP hatte ich den CUL am Laufen, firmware ist schon drauf. Allerdings meldet der Gerätemanger immer "unbekanntes Gerät".
Bei LUFA (ehemals myUSB) gab es eine .inf die sich auch unter Win7 64 installieren lässt leider hilft das auch nicht. Wenn manuell der Treiber ausgwählt wird ist der angeblich schon aktuell.

Hat jemand unter Windows 7 einen CUL zum laufen bekommen? Wie?


swifty

unread,
Oct 10, 2013, 10:25:28 AM10/10/13
to cul-...@googlegroups.com
und schon gelöst.

für Win 7 muss auf dem CUL auch die aktuellste fw. nun gehts.


Sebastian Schulte

unread,
Dec 5, 2014, 8:30:33 AM12/5/14
to cul-...@googlegroups.com
Hallo zusammen,

bin ganz neu hier und mache gerade meine ersten Schritte mit dem CUL um meine Heizung über FHEM zu automatisieren. Ich beschreibe kurz den bisherigen Ablauf.

- CUL gemäß Anleitung eingesteckt (mit gedrücktem Schalter). Erkannte Hardware dann über die bei FLIP beiliegeden Treiber installiert. Läuft.
- Mit FLIP die CUL V3 aufgeflasht, klappt nicht. Nach Lektüre des Boards hier und swiftys Beitrag die V4 aufgeflasht. Flashen geht ohne Probleme.
- Dann versucht diverse Treiber für den virtuellen COM-Port zu installieren. MyUSB[...].inf, CUL.inf von busware.de und der Treiber von Swen. Bei allen bekomme ich dieselbe Fehlermeldung, dass am angegebenen Speicherort keine für das Gerät kompatiblen Treiber gefunden werden konnten
- Deinstallation des Gerätes bringt auch nichts, es installiert sich direkt wieder mit den Treibern von zuvor.

Was mir auffällt ist, dass der CUL nur als Gerät erkannt wird (auch nach flashen mit FW), wenn ich den Schalter drücke. Stecke ich den Stick ohne gedrückten Schalter ein, passiert nichts. Ist das normal?Hat jemand eine Idee, wo mein Fehler liegen könnte und was ich noch anders machen könnte?

OS: Win 7 x64

Liebe Grüße

Sebb

Reply all
Reply to author
Forward
0 new messages