word spacing not working

158 views
Skip to first unread message

Jon

unread,
May 8, 2012, 12:24:42 PM5/8/12
to cufón
Hi
I have converted a font "Bebas" into a cufon font installed the JS etc
but when I view the html in Firefox (havnt tested any other browser)
all the text is lumped together i.e. no spaces between words. Any
ideas?
Thanks
Jon

Simo Kinnunen

unread,
May 8, 2012, 1:16:08 PM5/8/12
to cu...@googlegroups.com
Hi,

Did you perhaps make a custom glyph selection? I have to say I'm not 100% sure if it has been fixed in the current version or only in the long overdue development version, but if you only select, say, lowercase letters, you won't get the space at all. Try generating the font again with Basic Latin to see if it works. If it does, try generating once more with the original options, but this time also add a space character to the "and also these single characters" text box.

Let me know if it works.

Simo
> --
> You received this message because you are subscribed to the Google Groups "cufón" group.
> To post to this group, send email to cu...@googlegroups.com.
> To unsubscribe from this group, send email to cufon+un...@googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/cufon?hl=en.
>

Jon

unread,
May 9, 2012, 3:04:54 PM5/9/12
to cufón
Simo
Nope still doesn't work.
Jon

Simo Kinnunen

unread,
May 9, 2012, 8:09:57 PM5/9/12
to cu...@googlegroups.com
Hi,

Link?

Simo

iPhoneから送信

Jon

unread,
May 10, 2012, 5:50:16 AM5/10/12
to cufón
here is the link:

http://www.jhurleydesign.com/azltd.co.uk/

as you can see in the navigation at the top - COMPANYPROFILE and
SALESNETWORK have no spacing between the words.

kind regards

Jon

Jon

unread,
May 15, 2012, 5:08:15 AM5/15/12
to cufón
Hi Simon

could you take a look at this for me. The word spacing does not seem
to work for this font - any ideas?
Jon

regards

Jon

unread,
May 17, 2012, 4:29:15 AM5/17/12
to cufón
Simon

When you have got a minute I would really appreciate you looking into
this. I need to get this font working fairly soon

thanks

Jon

Simo Kinnunen

unread,
May 17, 2012, 4:58:19 AM5/17/12
to cu...@googlegroups.com
Hi,

I am busy too.

I took a quick peek and the reason seems to be that the width of the space is wrong in the font file. This may be a problem with the generator, or maybe with the original font file itself. You canfix the problem by opening the font.js in a text editor, and replacing the value of "w" in " " (it's the first glyph in there) with something more reasonable (it's set to 130 now). I'm assuming something went wrong with scaling, so (1408/360)*130 -> 508 is a good guess, however you might have to tweak the value as needed.

Simo

iPhoneから送信

Jon

unread,
May 17, 2012, 8:36:44 AM5/17/12
to cufón
Thanks that's fab. I increased the value to 400 and it works
beautifully.

Glad you are busy too - sorry if I sounded impatient.

keep up the good work

regards

jon
Reply all
Reply to author
Forward
0 new messages