cryptopp-5.6.1 build failed with gcc-4.7.0

904 views
Skip to first unread message

alekcey

unread,
Jan 3, 2012, 4:29:14 PM1/3/12
to Crypto++ Users
Hi,

I have a problem with rebuilding cryptopp-5.6.1 for Fedora 17 where
gcc-4.7.0 was just added:

secblock.h:91:3: error: 'CheckSize' was not declared in this scope,
and no declarations were found by argument-dependent lookup at the
point of instantiation [-fpermissive]

See full build log here http://nucleo.fedorapeople.org/cryptopp.log

alekcey

unread,
Jan 4, 2012, 9:18:47 PM1/4/12
to Crypto++ Users
This fixes build with gcc-4.7.0 http://nucleo.fedorapeople.org/cryptopp-5.6.1-gcc-4.7.0.patch
It adds this-> in all places where build failed.

Jeffrey Walton

unread,
Jan 17, 2012, 8:38:35 PM1/17/12
to Crypto++ Users
GCC's C++11 is experimental (http://gcc.gnu.org/gcc-4.7/
cxx0x_status.html).

Jeff

alekcey

unread,
Jan 17, 2012, 10:11:36 PM1/17/12
to Crypto++ Users
On Jan 18, 3:38 am, Jeffrey Walton <noloa...@gmail.com> wrote:
> GCC's C++11 is experimental (http://gcc.gnu.org/gcc-4.7/
> cxx0x_status.html).
>
> Jeff

Probably the status of C++11 will be changed after GCC 4.7 release.
GCC 4.7 is not released yet but it is common practice to have pre-
releases in Fedora development branch, so we need to fix GCC 4.7
related issues now.

Pierre-Paul Jeunechamps

unread,
Mar 3, 2016, 6:03:42 AM3/3/16
to Crypto++ Users, alek...@googlemail.com
Thanks a lot!
Reply all
Reply to author
Forward
0 new messages