fasta database not found in tide-search

8 views
Skip to first unread message

Peppe

unread,
Jun 6, 2021, 11:55:27 AMJun 6
to crux-users
Hi,

I'm running tide-search but I'm running into an issue where the process fails with an error:

```
INFO: Database not provided; will use empty database.
WARNING: empty protein id string in tab delimited file. searching database to find proteins to match peptide sequence
ERROR: Failed to open fasta file
FATAL: Failed to parse database, cannot create iterator
```

I use a script to run the search:

```
./man-search/narrow/tide-search-narrow.sh /data/small.mgf  /data/test.fasta
```

Fasta database, mgf file, script and tide-search logs can be found here: https://drive.google.com/drive/folders/10vyEMUlU4OoEnpWB-S3yRG_MaZuJABop?usp=sharing

 I have tried both `crux-4.0.Linux.x86_64` and `crux-4.0.6818dcc.Linux.x86_64`

I have also tried to run tide-index first but I still get the same error.

Please let me know if you can help.

Best,

Giuseppe 

William S Noble

unread,
Jun 7, 2021, 6:47:50 PMJun 7
to Peppe, crux-users
I also answered this on the issue tracker, where this issue was also raised:


The issue is related to the use of the --brief-output flag, which was introduced recently. The tide-search output files get re-parsed at the end of the search in order to produce the PIN output, and this parsing step is broken when the output is in brief format. The solution is to remove the --brief-output option.

--
You received this message because you are subscribed to the Google Groups "crux-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to crux-users+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/crux-users/55553aca-d6c8-4a37-942d-ac3f265bc67dn%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages