causes of "drive not ready"

216 views
Skip to first unread message

billdeg

unread,
Apr 9, 2010, 12:44:18 AM4/9/10
to Cromemco
Ok, let's try this one last time, I posted before with more detail,
but here are the basics:

I have a system one, and I can use either a 4FDC or a 16FDC, the
results are the same.

I have two Tandon 100-2a's, but work.

If I plug either of these drives into the system alone, both boot as
drive A just fine, format disks, RPM's 300, DS0 jumper only.

If I plug both drives into the system and set one of them as drive B,
I can still boot to A, but I get a "drive not ready" error when I try
to run a dir command using CDOS. a: DIR B: --> drive not ready.

I have swapped the Terminator around, I have tried a 2nd terminator,
no change. The Tandon 100-2a and 4/16 FDC manuals state that the
terminator should be at the end.

I have swapped out the 64K RAM and ZPU cards, no change.

What could be causing the drive not ready?

NOTE That the 16FDC works just fine in another cromemco system using
8" drives, it can boot to B.

I am stumped.

Bill

MikeS

unread,
Apr 9, 2010, 2:25:46 AM4/9/10
to Cromemco

My first guess would be that that CDOS is configured for and expects
an 8" drive "B". What does the 16FDC RDOS T command have to say about
each drive if you select the small floppy?

Marcus Bennett

unread,
Apr 9, 2010, 7:08:06 AM4/9/10
to crom...@googlegroups.com
Bill,

Mike's comment sounds very plausible.  I would also suggest ....


connect both drives.  Start computer and stay in RDOS ...

Using a diskette that you have booted from previoulsy ...


a;;;                      # select a disk 5.25 size

check that the a: disk select light comes on ONLY i.e. at no point B: comes on.  If it does then some problem with drive selection


s10                     # does the seek work okay?
You hear hear diskette seeking and then the prompt comes back

rd1000 2000 1     # read into hex 1000-2000 starting at sector 1 from current track

Now since I have a RDOS 3.12 ROM I have the TZ command.  Here is the output.  (At RDOS level 2.5 for you I cant recall what commands exist.  Try all of T TZ TX commands)

a;;;
A;;;s10
A;;;rd1000 2000 1
 0 10 01  0 10 09
A;;;tz

Bank 0 > 0 1 2 3 4 5 6 7 8 9 A B C D E F
         ^ ^ ^ ^ ^ ^ ^ ^ X X X X X X X X
Type (F, H) F
Drive (A-D) A
Size (L, S) S
Speed (F, S) S

Seek Tests
1 OK 2 OK 3 OK 4 OK 5 OK
6 OK 7 OK 8 OK 9 OK 0 OK
27H OK 10H OK 20H OK 0 OK 1 OK
 Restore OK
27H OK
Read/Write Tests
 Data Read OK
Write Test MAY DESTROY Data
CR=Proceed ESC=Abort ^[
A;;;


As Mike says you need to have CDOS generated for the correct diskette sizes.  CDOSGEN came out with CDOS 2.x. It is somewhat risky but if you have a CDOS where the B: is currenly configured for an 8" diskette you will need to boot to A, then run CDOSGEN and regenerate a new CDOS with 2x5.25 inch A drives.  This will overwrite your current disk, but I don't see a choice for you!

Here is a sample session with CDOS 2.54

CDOSGEN version 02.54
Cromemco Disk Operating System Generator
Copyright (c) 1978, 1982 Cromemco Inc.

Memory size (3FFF through FFFF or 16K through 64K) <FFFF or 64K> ?

Drive A type (S = Small, L = Large) ?  s
    Seek speed (1 = 6ms, 2 = 12ms, 3 = 20ms, 4 = 30ms) <1> ? 1
    Single or Double sided <D>   ?  d
    Single or Dual density <D>   ?  d
Drive B type (S = Small, L = Large, H = Hard, N = None, E = End) ?  s
    Seek speed (1 = 6ms, 2 = 12ms, 3 = 20ms, 4 = 30ms) <1> ? 1
    Single or Double sided <D>   ?  d
    Single or Dual density <D>   ?  d
Drive C type (S = Small, L = Large, H = Hard, N = None, E = End) ?  e

Function key decoding
     (S = Standard, N = None, U = User, F = File) <S> ?  n

CDOS addresses:
  Starting address of CDOS (top of User Area)   C700
  Starting address of I/O device drivers        F944
  Last address used by CDOS                     FF41
  Top of memory for this CDOS                   FFFF
  Size of CDOS                                  38AC
  Size of boot loader (maximum = 1A00)          190B

Enter command file name <A:CDOS> -



--
marcus bennett    amo...@gmail.com majzel.blogspot.com

billdeg

unread,
Apr 9, 2010, 8:45:59 AM4/9/10
to Cromemco
Interesting. I did not know that the CDOS could be set to expect an
8" drive in B, if it's booting A at 5 1/4" I only have the disk you
sent me, I guess it's possible that because you were mostly making me
8" disks that you gen'd the CDOS for 5 1/4" format from an 8"
original?

I did some of these same tests from RDOS (above) and they worked
earlier, adding to my confusion because it seemed like I could access
the drive at the lower level.

Thanks very very much, when you work on something for a week you can
start to get crazy about it!

I will let you know how it goes.

Bill

billdeg

unread,
Apr 9, 2010, 9:29:26 AM4/9/10
to Cromemco
[Irish Accent]Saints be praised![/Irish Accent]

It worked. And now I know what the markings on my original boot disk
mean
A=5, B=8 C=D

Darmuk his eyes open.

So, just for anyone who reads this post in the future, I first made a
backup of the original disk and created a new boot disk that expects 5
1/4" for both A and B.

After booting to RDOS and at the ; prompt:

(assume Return at the end of every line)

A;;;
S0 (that's s0 "zero" not sO)
RD100 S7E00 1
[INSERT BLANK FORMATTED DISK "BACKUP DISK"]
S0
WD100 S7E00 1
[INSERT ORIG DISK]
SE
RD100 S7E00 1
[INSERT BACKUP DISK]
SE
WD100 S7E00 1
[INSERT ORIG DISK]
S1C
RD100 S6C00 1
[INSERT BACKUP DISK]
S1C
WD100 S6C00 1
S0
B (to boot CDOS to new disk)

then I ran CDOSGEN.

Bill

Reply all
Reply to author
Forward
0 new messages