Running Z80 Cromix under Linux

27 views
Skip to first unread message

cro memcos

unread,
Jun 11, 2021, 9:53:45 AM6/11/21
to crom...@googlegroups.com
I have been ruminating about Nigel Williams' question as to running Z80 Cromix under Linux.   He suggested yaze-ag and I have another easier idea ...

It is to use the already excellent and lofty work of Udo Monk and use his Z80 pack


---

He has decent instructions for CPM but not for running cromemcosim which enables you to run CDOS or Z80 cromix under Linux.

So I have just got it all working, Cromix 11.27, 3 terminals, under x64 Linux on Ubuntu 20 ...

image.png

The big picture is this

- you download his latest Z80 pack which is at level 1.37

- you will need to compile up the frontpanel and also the simulator

- I found a couple of packages missing from my Ubuntu 20 Linux system.  Well Virtual Machine.  My notes are

sudo apt-get install libpthread-stubs0-dev
sudo apt-get install libjpeg-dev
sudo apt install mesa-common-dev
sudo apt-get install libglu1-mesa-dev
sudo apt-get install -y mesa-utils
sudo apt-get install -y x11-utils


cd ~/z80pack-1.37/frontpanel
make -f Makefile.linux clean
make -f Makefile.linux clean

cd ~/z80pack-1.37/cromemcosim/srcsim
edit Makefile.linux and change LFLAGS to
FLAGS = -L../../frontpanel -lfrontpanel -ljpeg -lGL -lGLU \
         -lX11 -lm -lpthread
make -f Makefile.linux clean
make -f Makefile.linux

sudo cp libfrontpanel.so /usr/local/lib


cd ~/z80pack-1.37/cromemcosim

edit cromix script and insert this line before call to cromemcosiim

export LD_LIBRARY_PATH=/lib:/usr/lib:/usr/local/lib

./cromix



- It's necessary to interact with the Graphical Z1 front panel like this
toggle switch 12 up (to simulate C, aka C000 hex)
press right edge power switch up to switch on
press run toggle up to jump to your selected xc000
cromemcosim script loads RDOS and so then it tries to boot, load from diskette fda

I will make 100% foolproof and longer instructions to follow, just thought I would post this as a solution to the Linux issue
and will of course also try it out on a Raspberry Pi in fullness of time.  Should that work [on the pi, running PiOS i.e. Raspbain not Ubuntu preferably]  I can generate a system that is live to the internet, all you would have to do is telnet into it  (and I would have it auto regenerate itself every say 24 hours in case somebody logs in and trashes it etc).


These are my thoughts so far.   Comments and suggestions welcome.

m

Richard Deane

unread,
Jun 11, 2021, 11:12:51 AM6/11/21
to crom...@googlegroups.com
Yes, I was running that with Cromix today on my rpi, love the switch front panel.  Love to have it HD booting, at the moment it defaults to floppy.

Do you know of any compatible HD images?

Richard 

--
You received this message because you are subscribed to the Google Groups "Cromemco" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cromemco+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/cromemco/CABdvdmy%3DnL6z5nboCNx%3DtoLD6kJmn5Njb-5%2BiwBb90Sov9Qi_A%40mail.gmail.com.

Richard Deane

unread,
Jun 11, 2021, 11:16:14 AM6/11/21
to crom...@googlegroups.com
The z80pack build for cromemco sim and front panel worked fine for me with default settings on my rpi.

I already had the dependencies correct from previous work with imsaisim
Richard.

On Fri, 11 Jun 2021, 14:53 cro memcos, <crom...@gmail.com> wrote:

cro memcos

unread,
Jun 11, 2021, 2:10:11 PM6/11/21
to Cromemco
Richard,

Very interesting that z80pack is running successfully  on the rpi.   Can I ask are you running a 32bit or 64bit kernel and what OS level etc.

This means I can place an order for another rpi to become a resident Cromix 11.27 emulation.  'cheaply' !!

---

In terms of HD support I cannot see this every being possible ...  Well the current z80 emulators ZEMU and z80pck are able to emulate the 4FDC and 16FDC floppy controllers,  but I have never seen any emulation of the IMI disk controller or the STDC Hard Disk controller.   In the CPM world there is a modified CBIOS that allows for a new floppy with an artificial e.g. hundreds or thousands of tracks,  to emulate a huge floppy diskette.    But for CDOS / CROMIX where only the character but not block drivers are easily replaceable I don't see this happening.

Again I would love to be proved wrong on this as 4 x 1.2MB floppies only gets you so far.

regards m

Richard Deane

unread,
Jun 11, 2021, 6:21:47 PM6/11/21
to crom...@googlegroups.com
I compiled z80pack 1.37 release with make (cromemcosim & frontpanel) and ran cromemcosim on my rpi 4B 8 GB memory using 32 bit Raspbian OS; I bought the pi for 64-bit but there has only been 1 rough 64-bit beta OS soI don't use that. I just use the latest raspbian 32 and I always do an apt update and apt upgrade before an app install,so I was using 11 Jun 2021 level.

There is no benefit to buying the 8GB version of PI4B at present due to the lack of a 64-bit release.

You could get the neat pi400 with a keyboard, very similar but slightly faster :). Being retired and on a small budget, I have not indulged that desire yet, perhaps next birthday, hopefully after another bigger, faster, better rpi release.
 
I have built and run z80pack on a pi zero but the frontpanel had to be tweaked to drop refresh frequency as it took all cpu without that.

I run my pi4Bs with bootup from the 120GB Integral SSD USB3 from Amazon, faster and more robust (I hope)  than microSD.

I am playing with Cromemco word processors at present, getting to know wps, writemaster and screen; but nothing has made me drop MagicWand / Peachtext 5000 (v2.02) as my favourite word processor on CP/M.. Magic Wand could be tweaked for Cromemco, but the Kaypro version from www.durgadas.com might work fine with generic control keys .I believe Cromemco terminals are VT52 compatible but have not checked that yet.

I have a variety of linux running under VMware on my desktop PC, for those occasions where I need an Intel-ish processor, such as Mint, Centos, and I run a win7-32  VM for MyZ80 emulator. I often have MSDOS, PCDOS and DRDOS on VM or old hardware as needed.

What I lack is a good old epson compatible printer  (or OKIDATA laser with Epson or IBM Proprinter Emulation) so if I need to print to EPSON Matrix I have to do it through DOSPRN under WinXP to convert Epson FX to PCL. I can also use the Kaypro java emulator with Diablo to Postscript support (also www.durgadas.com).

I am learning Cromemco from time to time, but my main machine for CP/M is a Steve Cousins SC131 (Z180 running RomWBW where I use zsdos or cpm3 ,and a variety of other RC2014 and/or romwbw systems.

I use Joyce (PCW), CPC6128 or SIM Coupe emulators for disk manipulation to get at cp/m apps

Really, if it has CP/M I am interested in giving it a go. Hence Runcpm and the esp32 systems with FABGL cp/m emulation, or my Arduino Due with Altairduino - Yes! I am addicted.

Cheers 
Richard






Reply all
Reply to author
Forward
0 new messages