Experiences upgrading OS and ODR software

55 views
Skip to first unread message

Michael Davison

unread,
Aug 8, 2020, 10:06:06 AM8/8/20
to mmbtools
This may help some people. For about a year I have had a workable setup using two HP PC's and a HackRF-One but as Debian Jessie is now obsolete, I thought it time to upgrade to Debian 10.04(Buster). I first upgraded the PC(quad-core) running odr-dabmod and the HackRF. The Debian.sh script bombed, not finding UHD which somehow I managed to get around but I'll leave the detail of that to the story of the other machine. As I needed a machine at home to produce the mux stream I set about adding the other tools to my recently updated AMD64 running Ubuntu20.04. I had all the scripts from my earlier setup and trimmed them to match the new test setup as I saw it - failure. The mux was appearing to send down the LAN to the modulator but the modulator said it wasn't receiving. This problem never occurred with Debian Jessie. OK back to ZMQ protocol from EDI. Still failure. The port was not open on one or both of the new OS's. Judicious use of 'ufw' to open the port and success, communication and DAB signal produced. I was still using ZMQ for sending encoded audio to odr-dabmux so time to try EDI there - failure - the encoder would not run. Failure to access the leap-second lists reported although odr-dabmux seemed to do this successfully. I then tried to run odr-encoder on the new Debian 10 install using EDI and it worked perfectly. I now needed to test Debian 10 running the encoding, PAD and mux functions and as I set it up on a spare hard drive in the AMD64 PC. This PC needed firmware loading to match the Radeon graphics card so its repo was added to the sources list and that was my starting point to run 'debian.sh' - bombed not finding 'uhd'. Googling I found the solution was that for every source 'deb' there has to be a matching 'deb-src' entry so this was added to 'sources.list'. The script then ran fine and the software installed. I'm sorry if many of you think -"typical newbie"- fine but it's useful to have these possible pitfalls documented. The tests continue.

Matthias Brändli

unread,
Aug 9, 2020, 12:04:30 PM8/9/20
to crc-mm...@googlegroups.com
Hi Michael,

interesting observation about debian not setting up the deb-src
repositories. That would indeed break the debian.sh install script.

Is this the default now?

mpb
> --
> You received this message because you are subscribed to the Google
> Groups "mmbtools" group.
> To unsubscribe from this group and stop receiving emails from it, send
> an email to crc-mmbtools...@googlegroups.com
> <mailto:crc-mmbtools...@googlegroups.com>.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/crc-mmbtools/85e24f85-9b87-43ee-a043-d198691b18feo%40googlegroups.com
> <https://groups.google.com/d/msgid/crc-mmbtools/85e24f85-9b87-43ee-a043-d198691b18feo%40googlegroups.com?utm_medium=email&utm_source=footer>.

Michael Davison

unread,
Aug 10, 2020, 5:39:26 AM8/10/20
to mmbtools
Hi Matthias
I'm not sure how the Debian techies think but it may have been something to do with me not setting up a network connection during the install. I was using a WiFi dongle that I knew would not be supported until I'd setup it's driver from an off-line stored zip and needing an install of the relevant Linux headers so I declined network support during the install. I was not aware of  the rule that a 'deb' must have a matching 'deb-src' - just one of those important rules that is only picked up by experience. Also, I think Ubuntu was to blame for the closed port not Debian 10 as I didn't have to run 'ufw' to open the port between Debian PC's and only the Ubuntu 20.04 strangely fails odr-audioenc, set for EDI, failing to open the leap-second sites.
MD

Michael Davison

unread,
Aug 10, 2020, 6:02:22 AM8/10/20
to mmbtools
Just to add that I had to add the recommended 'deb' line to sources.list for the Radeon firmware according to a Debian Wiki for Buster which never mentioned a 'deb-src' was also a good idea.
Reply all
Reply to author
Forward
0 new messages