Parallel cp2k installation trouble

564 views
Skip to first unread message

Jana

unread,
Jan 17, 2013, 9:24:13 AM1/17/13
to cp...@googlegroups.com
 Hi,
I am trying to install parallel cp2k but I am having troubles with the libraries needed

According to the install instructions getting atlas with lapack and scalapac should be enough to compile cp2k.
So I have installed it but I got the atlas libraries

libatlas.a
libcblas.a
libf77blas.a
libf77refblas.a
liblapack.a
libptf77blas.a
libptlapack.a
libstalas.so
libtatlas.so
libstatlas.a


but Linux-x86-64-intel.popt apparently requires another libs

ifort: error #10236: File not found:  '/libblacs_init.a'
ifort: error #10236: File not found:  '/libblacs.a'
ifort: error #10236: File not found:  '/libacml.a'
ifort: error #10236: File not found:  '/libacml_mv.a'
ifort: error #10236: File not found:  '/libfftw3.a'

I am confused now,
please could anybody help me?

Sorry for a stupid question I have virtually no experience in this field...



Urban Borštnik

unread,
Jan 17, 2013, 9:42:50 AM1/17/13
to cp...@googlegroups.com
Hi,

You should edit your ARCH file to either explicitly include the paths to
these libraries (i.e., -l/path/to/lib/libatlas.a) or set the variable to
that path (whatever that variable is in the ARCH file you are using).

Best regards,
Urban.
> --
> You received this message because you are subscribed to the Google
> Groups "cp2k" group.
> To view this discussion on the web visit
> https://groups.google.com/d/msg/cp2k/-/gHHGGLXjsKsJ.
> To post to this group, send email to cp...@googlegroups.com.
> To unsubscribe from this group, send email to cp2k
> +unsub...@googlegroups.com.
> For more options, visit this group at
> http://groups.google.com/group/cp2k?hl=en.


Jana

unread,
Jan 17, 2013, 10:00:02 AM1/17/13
to cp...@googlegroups.com
Hi,

Ok, thanks. I have ended up eith an error again though
ifort: error #10236: File not found:  '/home/mathausj/cp2k-2.3/makefiles/../exe/Linux-x86-64-intel/cp2k.popt'

Jana

unread,
Jan 21, 2013, 11:06:48 AM1/21/13
to cp...@googlegroups.com
Please, could you help me someone? I am still stuck with this last weeks error, tho i tried to get different versions of libraries and mpi and all links in ARCH seem to be fine, also no complaints in the output as far as I could notice, except the one that executable wasnt created (so there must be something wrong). The dflags and addresses i provided in arch should be in the right order and correct, i used atlas instead of blas+lapack (I listed all the libs in the lib directory)

In order to determine what's wrong I tried to compile serial version only with blas and lapack library but I got whole lot of stuff like that

TL_lauumU.c:(.text+0x124): undefined reference to `cblas_ztrmm'
/home/mathausj/atl_jm/lib/liblapack.a(ATL_clauumCL.o): In function `ATL_clauumCL':
ATL_lauumL.c:(.text+0xe1): undefined reference to `cblas_cherk'
ATL_lauumL.c:(.text+0x123): undefined reference to `cblas_ctrmm'
/home/mathausj/atl_jm/lib/liblapack.a(ATL_clauumCU.o): In function `ATL_clauumCU':
ATL_lauumU.c:(.text+0xe1): undefined reference to `cblas_cherk'
ATL_lauumU.c:(.text+0x123): undefined reference to `cblas_ctrmm'
/home/mathausj/atl_jm/lib/liblapack.a(ATL_clauumRL.o): In function `ATL_clauumRL':
ATL_lauumL.c:(.text+0xe1): undefined reference to `cblas_cherk'
ATL_lauumL.c:(.text+0x123): undefined reference to `cblas_ctrmm'
/home/mathausj/atl_jm/lib/liblapack.a(ATL_clauumRU.o): In function `ATL_clauumRU':
ATL_lauumU.c:(.text+0xe1): undefined reference to `cblas_cherk'
ATL_lauumU.c:(.text+0x123): undefined reference to `cblas_ctrmm'
/home/mathausj/atl_jm/lib/liblapack.a(dorm2l.o): In function `dorm2l_':
dorm2l.f:(.text+0x89): undefined reference to `lsame_'
dorm2l.f:(.text+0xab): undefined reference to `lsame_'
dorm2l.f:(.text+0xec): undefined reference to `lsame_'
dorm2l.f:(.text+0x124): undefined reference to `lsame_'
dorm2l.f:(.text+0x1e3): undefined reference to `xerbla_'



Please, I will be really grateful for anything, because I really don't have a clue what to do and it's been like that since last week. I am really sorry to bother you but I have no experience with this sort of work and neither does my superviser or anyone around at the department but i desperatly need paralellized software because gaussian is not able to perform the calculations i need for my thesis.

Alin M Elena

unread,
Jan 21, 2013, 11:13:42 AM1/21/13
to cp...@googlegroups.com

Hi Jana,

 

Can you please post the arch file you are using.. and the compiler versions...

also the commands you use are to generate the error.

 

Alin




--
You received this message because you are subscribed to the Google Groups "cp2k" group.

To view this discussion on the web visit https://groups.google.com/d/msg/cp2k/-/8hh2CrH5lDYJ.


To post to this group, send email to cp...@googlegroups.com.

To unsubscribe from this group, send email to cp2k+uns...@googlegroups.com.


For more options, visit this group at http://groups.google.com/group/cp2k?hl=en.



--

Without Questions there are no Answers!

______________________________________________________________________

Alin Marin ELENA

Advanced Molecular Simulation Research Laboratory

School of Physics, University College Dublin

----

Ardionsamblú Móilíneach Saotharlann Taighde

Scoil na Fisice, An Coláiste Ollscoile, Baile Átha Cliath

 

-----------------------------------------------------------------------------------

http://alin.elenaworld.net

______________________________________________________________________

Jana

unread,
Jan 21, 2013, 11:32:03 AM1/21/13
to cp...@googlegroups.com, alinm...@gmail.com
Hi Alin,

I've loaded modules gcc-4.5.2, mpich2-intel and intelcdk-12 (for ifort).
I used the arch file according to uname:
Linux 2.6.26-2-xen-amd64 #1 SMP Thu Apr 26 19:04:13 CEST 2012 x86_64 x86_64 x86_64 GNU/Linux


For the compilation from the makefiles directory I go just
$ make -j 20 ARCH=Linux-x86-64-intel VERSION=popt

Here's the arch file

CC       = cc
CPP      =
FC       = ifort
LD       = ifort
AR       = ar -r
DFLAGS   = -D__INTEL -D__FFTSG -D__parallel -D__SCALAPACK -D__BLACS  -D__LAPACK -D__BLAS -D__FFTW3 -D__LIBINT
CPPFLAGS =
FCFLAGS  = $(DFLAGS) -I$(INTEL_INC) -O3 -xW -heap-arrays 64 -funroll-loops -fpp -free
# FCFLAGS2 = $(DFLAGS) -I$(INTEL_INC) -O1 -xW -heap-arrays 64 -fpp -free
LDFLAGS  = $(FCFLAGS) -I$(INTEL_INC)
LIBS =  -l/home/mathausj/lib_sc/libscalapack.a \
-l/home/mathausj/BLACS/LIB/blacsF77init_MPI-LINUX-1.a \
-l/home/mathausj/BLACS/LIB/blacs_MPI-LINUX-1.a \
-l/home/mathausj/atl_jm/lib/liblapack.a \
-l/home/mathausj/atl_jm/lib/libptlapack.a \
-l/home/mathausj/atl_jm/lib/libatlas.a \
-l/home/mathausj/atl_jm/lib/libcblas.a \
-l/home/mathausj/atl_jm/lib/libf77blas.a \
-l/home/mathausj/atl_jm/lib/libf77refblas.a \
-l/home/mathausj/atl_jm/lib/libptf77blas.a \
-l/home/mathausj/atl_jm/lib/libsatlas.so \
-l/home/mathausj/atl_jm/lib/libtatlas.so \
-l/home/mathausj/atl_jm/lib/libtstatlas.a \
-l/home/mathausj/fftw/lib/libfftw3.a \
-l/home/mathausj/libint/adep/lib/libint2.a \

OBJECTS_ARCHITECTURE = machine_intel.o

graphcon.o: graphcon.F
    $(FC) -c $(FCFLAGS2) $<

Jörg Saßmannshausen

unread,
Jan 21, 2013, 12:12:05 PM1/21/13
to cp...@googlegroups.com
Dear Jana,

unless I am mistaken you forgot to link with the libcblas.a as well (or
libcblas.so so you got it).
With the more recent ATLAS installations, you can get one fat library which
contains all you need: libsatlas.so
I am using that way as it appears to be more forward.

I hope that helps a bit.

Regards

Jörg
*************************************************************
Jörg Saßmannshausen
University College London
Department of Chemistry
Gordon Street
London
WC1H 0AJ

email: j.sassma...@ucl.ac.uk
web: http://sassy.formativ.net

Please avoid sending me Word or PowerPoint attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html

Jana

unread,
Jan 22, 2013, 4:10:57 AM1/22/13
to cp...@googlegroups.com, Jörg Saßmannshausen
Hi Jörg,

libcblas.a is on the list, and I don't have .so version. What version of ATLAS are you using? I have 3.10.1 which was listed as the newest release.

Alin M Elena

unread,
Jan 22, 2013, 5:30:25 AM1/22/13
to Jana Mathauserová, cp...@googlegroups.com

OK Jana,

 

let us try with the parallel version...

you still did not answer me about the need for libint library? do you need that option in cp2k? what functional do you plan to use?

 

there is no need for 8) and depending on the configuration of the machine may be no need for 7 either....

 

please let me know the output of the following commands...

mpif90 -show (execut this with both mpich2-intel loaded and unloaded)

icc

echo $MKLROOT

which ifort

 

regards,

 

Alin

 

 

 

 

On Tue 22 Jan 2013 11:23:40 you wrote:

I need the parallel version, I have only tried to do the serial because I thought I could gradually add the libs so I could determine what am I doing wrong, but it's not working anyway, so I am hopeless now.
It is a supercomputer...I wanted to use intel compiler, there's loads of modules available, I chose mpich2-intel.

Currently Loaded Modulefiles:
          1) modules         3) opensuse        5) metabase        7) mpich2-intel
          2) ics.muni.cz     4) torque          6) intelcdk-12     8) gcc-4.5.2

(6,7 and 8 are not there until I add them)


On 21 January 2013 17:36, Alin M Elena <alinm...@gmail.com> wrote:

Ok... I see...

 

What are you trying to do? compile a parallel or serial version?

do you need the libint library?

what compilers are you trying to use?

is this on a supercomputer?

please do a module av

and a on fresh login

module list

 

regards,

 

Alin




--

---
S pozdravem
Jana Mathauserová

+420 606 301 164
+44 079 79 217 846

Jörg Saßmannshausen

unread,
Jan 22, 2013, 5:20:52 PM1/22/13
to cp...@googlegroups.com
Hi Jana,

I was using atlas3.9.74.

Check the order of the ATLAS related library files. It could be that the order
is wrong. Unfortunately, I don't remember on the top of my head wheather the
libcblas needs to be before or after the liblapack. I think it needs to be
after. That is one of the reasons why I switched to the 'fat' lib: it is all
in there so no more worries about which order you need.

All the best

Jörg
> > email: j.sassma...@ucl.ac.uk <javascript:>

Calvin47

unread,
Apr 10, 2014, 11:38:22 AM4/10/14
to cp...@googlegroups.com
acml library is needed for AMD based CPU, you can download it free from AMDdevelopers
fftw3 library does Fast Fourier Transform in the West
as for blacs is a comunication subprogram for Basic Liner Algebra
Don't forget to compile everything with the same fortran. (gfortran or ifort)

I got a better experience with ifortran which is not for free. From Intel you can download MKL math kernel libraries
Isn´t that cute?
Reply all
Reply to author
Forward
0 new messages