Getting Coulda

0 views
Skip to first unread message

Scott LaBounty

unread,
Nov 20, 2009, 4:05:12 PM11/20/09
to cou...@googlegroups.com
I've upgraded my system to Ubuntu 9.10 and now trying to get Coulda I get a "requires jeremymcnally-pending" error. If I try getting that, it says it can't find it in the repository. Any idea what I need here?

--
Scott
http://steamcode.blogspot.com/

Evan Light

unread,
Nov 20, 2009, 4:13:04 PM11/20/09
to cou...@googlegroups.com

Yep.  Add gems.github.com to your ~/.gemrc

Scott LaBounty

unread,
Nov 20, 2009, 4:16:07 PM11/20/09
to cou...@googlegroups.com
Better, but now it's requiring "little-plugger (>=1.1.1, runtime). Should I just install that too?

Scott
--
Scott
http://steamcode.blogspot.com/

Scott LaBounty

unread,
Nov 20, 2009, 5:22:04 PM11/20/09
to cou...@googlegroups.com
OK, I answered my own question. You need both little-plugger and loquacious so ...

Add gems.github.com to the ~/.gemrc file

then do a :

sudo gem install little-plugger loquacious coulda

and you should be good to go.

Actually, I haven't really run anything yet, but I'll let everyone know after that how things go.

Scott
--
Scott
http://steamcode.blogspot.com/

Evan Light

unread,
Nov 20, 2009, 6:00:05 PM11/20/09
to cou...@googlegroups.com
little-plugger and loquacious?? What gems require those??? Coulda doesn't.  This is new to me.  Hrm....
--
Evan Light
http://evan.tiggerpalace.com
@elight

Evan Light

unread,
Nov 20, 2009, 6:00:36 PM11/20/09
to cou...@googlegroups.com
Oh, FYI, Rails support isn't baked in yet.  My rewrite of Coulda allows for it easily enough.  Just haven't implemented it yet.

Scott LaBounty

unread,
Nov 20, 2009, 6:34:45 PM11/20/09
to cou...@googlegroups.com
That's cool, I don't use Rails anyway (Ramaze for the little web development I do).

Scott
--
Scott
http://steamcode.blogspot.com/

Scott LaBounty

unread,
Nov 20, 2009, 6:35:34 PM11/20/09
to cou...@googlegroups.com
Maybe something that Coulda requires, requires them?

Scott
--
Scott
http://steamcode.blogspot.com/

Evan Light

unread,
Nov 20, 2009, 6:45:57 PM11/20/09
to cou...@googlegroups.com

That would have to be "pending" and that gem file hasn't changed in months.  Odd...

On Nov 20, 2009 6:35 PM, "Scott LaBounty" <slab...@gmail.com> wrote:

Maybe something that Coulda requires, requires them?

Scott

On Fri, Nov 20, 2009 at 3:00 PM, Evan Light <slei...@gmail.com> wrote: > > little-plugger and lo...

Reply all
Reply to author
Forward
0 new messages