Recent problems with launching Conzilla

13 views
Skip to first unread message

Hannes Ebner

unread,
Oct 8, 2008, 6:20:48 AM10/8/08
to Conzilla
I got several emails these days from people who were not able to launch
Conzilla anymore. The reason was an exception
("java.net.MalformedURLException: no !/ in spec") during start up.

I investigated the problem (which is caused by a regression bug of Sun's
most recent Java 5.0, i.e. 1.5.0_16) and tried to work around it, but
came to the conclusion - as many other developers who tried to solve the
very same problem - that it is best to wait for a fix from Sun.

The reason is that it would require too many changes in the code and
even some major refactoring. Apart from that, even third-party libraries
as e.g. log4j are affected. Conzilla is not the only application which
has been broken, basically all applications making use of Java Web Start
are affected.

Bugs have been reported to Sun:

http://bugs.sun.com/view_bug.do?bug_id=6746185
http://bugs.sun.com/view_bug.do?bug_id=6753651

Let's hope that Sun fixes this bug very soon, until then my
recommendation is: Do not use JRE/JDK 1.5.0_16, and if you happen to use
it, downgrade to an earlier release, or upgrade to 6.0/1.6.

I will keep you informed regarding this issue.

Best regards,
Hannes

Reply all
Reply to author
Forward
0 new messages