What do you think could be the reason for this composer error?

61 views
Skip to first unread message

D Thompson

unread,
Dec 11, 2014, 1:46:01 AM12/11/14
to compos...@googlegroups.com
All I want to do is successfully install this Amazon Product Advertising API and here's the error it's giving me (copied and pasted from that Github URL).

path:/var/www/html/apai-io$ php composer.phar install

Loading composer repositories with package information

Installing dependencies (including require-dev)

Your requirements could not be resolved to an installable set of packages.

Problem 1

   
- The requested package exeu/apai-io 1.0.0 could not be found.



Potential causes:





Read http://getcomposer.org/doc/articles/troubleshooting.md for further common problems.


Now, this is what my composer.json file looks like.


{

   
"name": "exeu/apai-io",

   
"type": "library",

   
"description": "Amazon Product Advertising PHP Library",

   
"keywords": ["Amazon", "ECS", "Product Advertising", "SOAP", "REST", "Products"],

   
"homepage": "https://github.com/Exeu/apai-io",

   
"license": "Apache-2.0",

   
"authors": [

       
{

           
"name": "Jan Eichhorn",

           
"email": "e-mail removed for this post",

           
"role": "Maintainer"

       
},

       
{

           
"name": "Dejan Spasic",

           
"email": "e-mail removed for this post.",

           
"role": "Developer"

       
}

   
],

   
"support": {

       
"issues": "https://github.com/Exeu/apai-io/issues"

   
},

   
"minimum-stability": "dev",

   
"require": {

       
"php": ">=5.3.0",

       
"ext-curl": ""

   
},

   
"require-dev": {

       
"phpunit/phpunit": "4.3.
"

   
},

   
"autoload": {

       
"psr-0": { "ApaiIO": "lib/" }

   
},



"require": {
   
"exeu/apai-io": "dev-master"
}


}

Reply all
Reply to author
Forward
0 new messages