Compass watch no longer working

257 views
Skip to first unread message

Nick Kovacevich

unread,
Jan 11, 2015, 11:12:55 AM1/11/15
to compas...@googlegroups.com
Hi Folks, in the past few weeks I've been getting this error every time I run compass watch:

Errno::ENOTDIR on line ["60"] of /Library/Ruby/Gems/2.0.0/gems/listen-2.8.0/lib/listen/listener.rb: Not a directory - /Users/nick/.compass/extensions/readme.txt/stylesheets


It will compile the SCSS files into a CSS file once and that's it. When I run the --trace function, I get this in return:


Nicks-MacBook-Pro:v2 nick$ compass watch --trace

>>> Compass is watching for changes. Press Ctrl-C to Stop.

Errno::ENOTDIR on line ["60"] of /Library/Ruby/Gems/2.0.0/gems/listen-2.8.0/lib/listen/listener.rb: Not a directory - /Users/nick/.compass/extensions/readme.txt/stylesheets

  /Library/Ruby/Gems/2.0.0/gems/listen-2.8.0/lib/listen/listener.rb:60:in `realpath'

  /Library/Ruby/Gems/2.0.0/gems/listen-2.8.0/lib/listen/listener.rb:60:in `block in initialize'

  /Library/Ruby/Gems/2.0.0/gems/listen-2.8.0/lib/listen/listener.rb:60:in `map'

  /Library/Ruby/Gems/2.0.0/gems/listen-2.8.0/lib/listen/listener.rb:60:in `initialize'

  /Library/Ruby/Gems/2.0.0/gems/listen-2.8.0/lib/listen.rb:71:in `new'

  /Library/Ruby/Gems/2.0.0/gems/listen-2.8.0/lib/listen.rb:71:in `_add_listener'

  /Library/Ruby/Gems/2.0.0/gems/listen-2.8.0/lib/listen.rb:28:in `to'

  /Library/Ruby/Gems/2.0.0/gems/sass-3.4.9/lib/sass/plugin/compiler.rb:393:in `block in create_listener'

  /Library/Ruby/Gems/2.0.0/gems/sass-3.4.9/lib/sass/plugin/compiler.rb:392:in `map'

  /Library/Ruby/Gems/2.0.0/gems/sass-3.4.9/lib/sass/plugin/compiler.rb:392:in `create_listener'

  /Library/Ruby/Gems/2.0.0/gems/sass-3.4.9/lib/sass/plugin/compiler.rb:327:in `watch'

  /Library/Ruby/Gems/2.0.0/gems/compass-1.0.1/lib/compass/sass_compiler.rb:46:in `watch!'

  /Library/Ruby/Gems/2.0.0/gems/compass-1.0.1/lib/compass/commands/watch_project.rb:41:in `perform'

  /Library/Ruby/Gems/2.0.0/gems/compass-1.0.1/lib/compass/commands/base.rb:18:in `execute'

  /Library/Ruby/Gems/2.0.0/gems/compass-1.0.1/lib/compass/commands/project_base.rb:19:in `execute'

  /Library/Ruby/Gems/2.0.0/gems/compass-1.0.1/lib/compass/exec/sub_command_ui.rb:43:in `perform!'

  /Library/Ruby/Gems/2.0.0/gems/compass-1.0.1/lib/compass/exec/sub_command_ui.rb:15:in `run!'

  /Library/Ruby/Gems/2.0.0/gems/compass-1.0.1/bin/compass:30:in `block in <top (required)>'

  /Library/Ruby/Gems/2.0.0/gems/compass-1.0.1/bin/compass:44:in `call'

  /Library/Ruby/Gems/2.0.0/gems/compass-1.0.1/bin/compass:44:in `<top (required)>'

  /usr/bin/compass:23:in `load'

  /usr/bin/compass:23:in `<main>'

Does anyone have an idea about what's causing this?

Reply all
Reply to author
Forward
0 new messages