http_images_path doesn't seem to be working with Compass 1.0.0.rc.1

144 views
Skip to first unread message

Ian

unread,
Oct 5, 2014, 8:06:11 AM10/5/14
to compas...@googlegroups.com
I have Compass 1.0.0.rc.1 installed:

compass (1.0.0.rc.1)
compass
-core (1.0.0.rc.1)
compass
-import-once (1.0.5)

With have the following in my config.rb file:

http_path        = "/"
http_images_path
= "https://d2a7mhio2y2ok4.cloudfront.net"

relative_assets  
= (environment == :production) ? :false : :true
sass_dir        
= "src/assets/sass"
css_dir          
= "src/assets/css"
images_dir      
= "src/assets/img"
javascripts_dir  
= "src/assets/js"

I reference my images in my stylesheet using image-url():

background: image-url("background.png") no-repeat;

If I set the environment from the command line and compile my stylesheets:

compass compile -e production --force

My image URLs are still output as:

background:url('../img/background.png') no-repeat;

Any ideas why the remote image paths wouldn't be working?

Ian

Gray Ghost Visuals

unread,
Oct 5, 2014, 4:13:02 PM10/5/14
to compas...@googlegroups.com

Ian

unread,
Oct 5, 2014, 4:23:08 PM10/5/14
to compas...@googlegroups.com

That's actually the post I was reading along with Chris' original when setting that up. Unless I've missed something it should be exactly the same as that. http_path and http_images_path are set along with relative_assets (which I've tried hard-coded as both `true` and `false` to test with. No matter what I do I can never get the fully qualified URL to display on compilation.

Is there something you can see in my code which stands out as wrong in comparison with your post?

Thanks,

Ian

Dennis Gaebel

unread,
Oct 6, 2014, 8:53:11 AM10/6/14
to compas...@googlegroups.com
--
You received this message because you are subscribed to a topic in the Google Groups "Compass" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/compass-users/Ro7etGUKBs4/unsubscribe.
To unsubscribe from this group and all its topics, send an email to compass-user...@googlegroups.com.
To post to this group, send email to compas...@googlegroups.com.
Visit this group at http://groups.google.com/group/compass-users.
For more options, visit https://groups.google.com/d/optout.

Hey Ian,

Try removing the colons in front of your boolean values

(environment == :production) ? :false : :true


try this instead and tell me what your results are
(true for local paths, false for production paths)

relative_assets  = false


-- 
Sincerely,
Dennis Gaebel Jr.
Gray Ghost Visuals
585.944.9406
http://grayghostvisuals.com
gray...@grayghostvisuals.com
Reply all
Reply to author
Forward
0 new messages