WTB: XVR-100 or higher (at a resonable price)

24 views
Skip to first unread message

Bruno S. Delbono

unread,
Sep 3, 2005, 10:29:28 PM9/3/05
to
Hi all,

I'm looking to add a video card to my SunFire V250. I need basic
connectivity to my LCD monitory and want to spend as little as I can.

If anyone is selling a used/working XVR-100 or higher at a resonable
price, please email me privately. It would be shipped to Vancouver,
British Columbia, Canada.

Warm Regards,

-Bruno

--
int main(){int O=0,s[]={0x84,0xe4,0xea,0xdc,0xde,0100,0xa6,'\\'\
,0100,0x88,0xca,0xd8,0xc4,0xde,0xdc,0xde,0100,0xf8,0100,0170,0x\
c4,0xe4,0xea,0xdc,0xde,'\\',0xe6,'\\',0xc8,0xca,0xd8,0xc4,0xde,\
0xdc,0xde,0x80,0xda,0xc2,0xd2,0xd8,'\\',0xc2,0xc6,0174,0100,0xf\
8,0100,0xd0,0xe8,0xe8,0xe0,0164,0136,0136,0xee,0xee,0xee,'\\',0\
xda,0xc2,0xd2,0xd8,'\\',0xc2,0xc6,0x0};while(O<66){(s[O]==0)?pr\
intf("%c\n",(47<<2)>>2):printf("%c",s[O]>>1);++O;}return s[--O]\
;}

Robert Pouliot

unread,
Sep 3, 2005, 11:57:03 PM9/3/05
to
On 2005-09-04, Bruno S. Delbono <bruno.s...@mail.ac> wrote:
> Hi all,
>
> I'm looking to add a video card to my SunFire V250. I need basic
> connectivity to my LCD monitory and want to spend as little as I can.
>
You are aware that the DVI connector is not supported at OBP and in text
mode? Just when Xsun is started. There is an unofficial fcode that should
support it (I've flashed it, but I've never tryed to make the DVI work
with my XVR-100.)

> If anyone is selling a used/working XVR-100 or higher at a resonable
> price, please email me privately. It would be shipped to Vancouver,
> British Columbia, Canada.


--
"We live in the interface between radioactive molten rock and hard
vacuum and we worry about safety." -- Chris Hunt
http://www.krynos.org/ - ICQ UIN: 2295979 / MSN: kry...@iname.com

Bruno Delbono

unread,
Sep 4, 2005, 12:16:08 AM9/4/05
to
Robert Pouliot wrote:
> On 2005-09-04, Bruno S. Delbono <bruno.s...@mail.ac> wrote:
>
>>Hi all,
>>
>>I'm looking to add a video card to my SunFire V250. I need basic
>>connectivity to my LCD monitory and want to spend as little as I can.
>>
>
> You are aware that the DVI connector is not supported at OBP and in text
> mode? Just when Xsun is started. There is an unofficial fcode that should
> support it (I've flashed it, but I've never tryed to make the DVI work
> with my XVR-100.)

Yea, I read about that earlier on a thread that was here (or
c.s.s.hardware). Sad actually, as I really want to have OBP and console
output on a DVI port.

Can I stick the VGA and the DVI cable both into the XVR-100 and have the
VGA work for console and Xsun on DVI, both connected at the same time
(If I just doggle the switch the VGA/DVI switch)?

PS - Anyone selling a XVR-100, please contact me off list.

Martin Paul

unread,
Sep 5, 2005, 8:39:40 AM9/5/05
to
Bruno Delbono <bruno.s...@mail.ac> wrote:

> Robert Pouliot wrote:
>> You are aware that the DVI connector is not supported at OBP and in text
>> mode? Just when Xsun is started. There is an unofficial fcode that should
>> support it (I've flashed it, but I've never tryed to make the DVI work
>> with my XVR-100.)

Do you have a source for that alternative fcode ?

> Can I stick the VGA and the DVI cable both into the XVR-100 and have the
> VGA work for console and Xsun on DVI, both connected at the same time
> (If I just doggle the switch the VGA/DVI switch)?

Yes, that's what I do on most of my XVR-100 machines.

mp.
--
Systems Administrator | Institute of Scientific Computing | Univ. of Vienna

Stefan Jankowski

unread,
Sep 5, 2005, 9:07:46 AM9/5/05
to
>>>>> Bruno Delbono <bruno.s...@mail.ac> writes:

> Robert Pouliot wrote:

[...]

>> You are aware that the DVI connector is not supported at OBP
>> and in text mode? Just when Xsun is started. There is an
>> unofficial fcode that should support it (I've flashed it, but
>> I've never tryed to make the DVI work with my XVR-100.)
>
> Yea, I read about that earlier on a thread that was here (or
> c.s.s.hardware). Sad actually, as I really want to have OBP and
> console output on a DVI port.
>
> Can I stick the VGA and the DVI cable both into the XVR-100 and
> have the VGA work for console and Xsun on DVI, both connected
> at the same time (If I just doggle the switch the VGA/DVI
> switch)?

That did work for me, but I had to hack the Xservers file to use the
DVI-output for X. The DVI-output is actually served by a second
framebuffer device which one must make the X server recongnise as it's
1st screen (:0.0), so that dtlogin will be started there rather than
on the screen which serves the VGA-output. (I /think/ I used something
like '-dev /dev/fbs/pfb0b -dev /dev/fbs/pfb0a' but just a few weeks
ago I moved to a new office and a new workstation and I don't have my
backups at hand right now...)

Regards,
Stefan

--
Stefan Jankowski
Sysadmin, University of Freiburg, CS Dpt.
s/spambucket//
s/dave\.null/${FORENAME}.${LASTNAME}/

Robert Pouliot

unread,
Sep 5, 2005, 10:25:50 AM9/5/05
to
On 2005-09-05, Martin Paul <m...@par.univie.ac.at> wrote:
> Bruno Delbono <bruno.s...@mail.ac> wrote:
>> Robert Pouliot wrote:
>>> You are aware that the DVI connector is not supported at OBP and in text
>>> mode? Just when Xsun is started. There is an unofficial fcode that should
>>> support it (I've flashed it, but I've never tryed to make the DVI work
>>> with my XVR-100.)
>
> Do you have a source for that alternative fcode ?
>
Search google for xvr-100 dvi console and you should find it.
The fcode is for the 32MB version of the card.

Martin Paul

unread,
Sep 6, 2005, 3:53:44 AM9/6/05
to
Robert Pouliot <kry...@huxley.krynos.dyn.saturnus.com> wrote:
> On 2005-09-05, Martin Paul <m...@par.univie.ac.at> wrote:
>> Bruno Delbono <bruno.s...@mail.ac> wrote:
>>> Robert Pouliot wrote:
>>>> You are aware that the DVI connector is not supported at OBP and in text
>>>> mode? Just when Xsun is started. There is an unofficial fcode that should
>>>> support it (I've flashed it, but I've never tryed to make the DVI work
>>>> with my XVR-100.)
>>
>> Do you have a source for that alternative fcode ?
>>
> Search google for xvr-100 dvi console and you should find it.

Ok, got it, from: http://chs2.gdc4s.com/sw_supt.htm

> The fcode is for the 32MB version of the card.

I don't know whether I have the 32MB version, but it seems that the
fcode patch comes with version 1.61 of the PROM firmware, while I
have version 2.3. The update script tells me that therefore my PROM
doesn't need to be updated (and I wouldn't want to force it, without
the possibility to go back to the original PROM version).

The PROM patch seems to come from Sun (there's a copyright in the
PROM update shell script). This and the fact that it's obviously
not a hardware limit makes me think about why there is no official
PROM update for all XVR-100s from Sun ?

Reply all
Reply to author
Forward
0 new messages