Info-IBMPC Digest V95 #172

1 view
Skip to first unread message

Info-IBMPC Digest

unread,
Nov 27, 1995, 3:00:00 AM11/27/95
to
Info-IBMPC Digest Mon, 27 Nov 95 Volume 95 : Issue 172

Today's Editor:
Gregory Hicks - San Jose, CA <GHI...@arl.mil>

Today's Topics:
Problems with 3COM Etherlink III PCI Board
Re: OS2CDROM.DMD will not install!!
Re: problems installing OS/2 connect
Re: SCSI on a Asus PCI/I-486SP3
Re: Shut Down
Slow Printing and Memory Leaks (2 msgs)
Re: Solution: [COMW] waring - only wrote xxx of xxxx bytes
Re: SOLVED: Windows Programs Stopped
Re: Soundblaster16 Bit
The bootp problems
Threads ? (2 msgs)
Time Change utility
Trivia: TESTCFG.SYS missing (Warp Connect)
trouble with 'create another'!
UltiMail Slowdown (2 msgs)
Re: Unable to boot C: (2 msgs)

Send replies or notes for publication to: <INFO-...@arl.mil>

For readers in the .MIL domain: Send requests of an administrative
nature (addition to, deletion from the distribution list, et al) to:
<INFO-IBMP...@arl.mil>. For all others, please send
requests to join, or signoff from, the list to an IBMPC-L BITNET
LISTSERV.

Currently these LISTSERV's are at hosts vmd.cso.uiuc.edu,
hearn.nic.surfnet.nl, taunivm.tau.ac.il and uga.cc.uga.edu. There are
others...

----------------------------------------------------------------------

Date: Thu, 9 Nov 1995 18:28:41 +0100
From: Tom Rowe <TR...@ae.agecon.wisc.edu>
Subject: Problems with 3COM Etherlink III PCI Board

Nicolas Wagrez <n...@OCEGR.FR> writes:

>does anybody know whether there is a driver for the new 3COM Etherlink III
>PCI Bus master Ethernet board?

The PCI card 3c590-tpo does have drivers for OS/2. I'm using one in a
Warp web server. However, you are limited by the number of base
addresses you can choose from. This was a problem for me on my
workstation with sound card and Buslogic SCSI controller. I ended up
going with the ISA 3c509 (more address choices).

3com's site is at http://www.3com.com
Their ftp site is ftp.3com.com (I think)

Send a message to: Bob_D...@3mail.3Com.COM to get the names and
locations of the files you need.

I'm considering a Kingston PCI card for my workstation. Does anyone
have experience with them? They are quite a bit cheaper than 3com.

Tom Rowe
UW-Madison Center for Dairy Research
608-265-6194, Fax:608-262-1578
tr...@ae.agecon.wisc.edu

Four wheel drive allows you to get
stuck in places even more inaccessible.

------------------------------

Date: Sat, 11 Nov 1995 13:04:25 -0500
From: "J. Eric Josephson" <j...@ftp.com>
Subject: Re: OS2CDROM.DMD will not install!!

->We are trying to install Warp Connect fullpack at work and are getting the
->message
->that OS2CDROM.DMD can't be found when processing the config.sys file.
->The HD was formatted before we started to ensure no parts and pieces of
->WIN95 were left. The first part of the install runs fine but when it reboots
->to continue the process it can no longer find the CDROM drive and
->initialization
->can't continue. We have a 16mb 486DX2, adaptec 1520 external SCSI and
->an IBM quad speed drive. We are slightly panicky as we have several systems
->to get ready in short order.

I had a similar problem when installing WARP for the first time. I had
an Adaptec 1522 SCSI card and 4 HDD. The First Drive had a "Primary"
and a "Logical" partition. This was fine under DOS because the drive
odrer was as follows:

Target 0 1 2 3 7
Drive C: Drive D: Drive F: Drive G: SCSI Card
Primary Primary ASPI Driver ASPI Driver

Drive E:
Logical

Under DOS, the First 2 "Primary" volumes get the drive letters C: and
D: *then* starting with the target 0 the first Logical gets the next
drive letter "E:" All driver letters after the fact are either logical
on Targets 0 or 1 -or- are handled by a driver such as the ones that
come with EZ SCSI from Adaptec.

That was under DOS. During the first stages of an install the SCSI
drives target 2 and up can't be seen as drive letters until the SCSI
driver loads properly.

Blah, Blah, Blah.... So what does all of this mean?

Under OS/2, as soon as the SCSI driver loads and AHA152x.SYS loads the
order of drive letter assignments **CHANGES** right in the middle of
the boot! So, in my example above Target 2 became Drive E: then 3 was
F: then target 0 logical became G:, where it WAS E:... The boot
failed complaining about not being able to control the HDD ( I had
installed WARP on E: ).

The problem was that all of the drives from target 2 to 6 were now
getting letter assignments before the logical partitions on traget "0".

To Solve this I used OS/2's FDISK and made all of the drives after
target 1 logical to preserve the drive letter orders.

While this might not be your exact problem, you might want to look into
this as a contributor.

J. Eric Josephson
Technical Support Engineer

| FTP Software, Inc. | | ,---' `-+ +-' | +-+ | | 800-382-4387 Tech |
| 2 High Street | | '-, | | | `-' | | 508-685-3600 Tech |
| N. Andover MA 01845 | | ,-' | | | +---' | 508-794-4484 Fax |
| USA | | | | | | | | 508-659-6240 BBS |
| | `-' `-' `-'Software | |

------------------------------

Date: Sat, 11 Nov 1995 13:05:31 -0500
From: "J. Eric Josephson" <j...@ftp.com>
Subject: Re: problems installing OS/2 connect

->:>I'm currently running OS/2 Warp on a DX-486 100 Mhz. The configuration
->:>consist of a Diamond Stealth SE PCI, 850 Mb IDE HD, 8 Mb RAM and a AT/LANTIC
->:>NSC NE2000 Compatible Ethernetcard.

->:>When I tried to install the CONNECT part of OS/2, that is the IBM OS/2 Peer
->:>services, I receive the following message :

->:> Error during transferring files.
->:> MPTS return code 1608.

->:>I cannot find this return code in the documentation.
->:>I tried to change IRQ's and IOBASE addresses, but nothing works.
->:>Could someone help me out ?

->I have no idea what the error code is, but I do know that Connect does not
->directly support the NE2000 compatible ethernet card. Too many variations on
->the implementation of 'compatible'.

->There are many .zip files on the net that claim to have a driver solution for
->those who care to try for the NE2000 cards, and they have been known to work.

->You may wish to browse Warp's list of directly-supported cards, and then pick
->one. I did, and install was easy.

I see problems with "NE2000" clones all of the time. We at FTP
software also have the same "No Clones" policy with NE2000. While it's
NOT at all supported, I have found an "NE2000.OS2" driver that seems to
work in most situations. I have put it on my own "Anonymous" FTP site
at "jej-2.ftp.com" in the OS/2 Directory. The name of the file is
"NE2000.ZIP"

It includes a sample PROTOCOL.INI (it includes FTP's [SOCKET] section
but the [NE2000] section is correct) and the actual NE2000.OS2 file.
All are welcome to it.

Leave me a note if it helps.

J. Eric Josephson
Technical Support Engineer

------------------------------

Date: Wed, 8 Nov 1995 08:21:57 GMT
From: nhbi...@mbox.iqo.uni-hannover.de
Subject: Re: SCSI on a Asus PCI/I-486SP3

ign...@ccwf.cc.utexas.edu (Ignacio Garcia) writes:
>Many people told me I should have problems using the NCR SCSI controller
>built-in the board, so I have decided to purchase a PCI SCSI controller board.
I
>was thinking about getting the Adaptec 2940 series or the BusLogic KT946C.
>Anyone using these or other controllers who can advise me?

I'm using the same board for 1 or 2 years with the build in
SCSI-Controller, no problems. I only have to use the newest bios
(V0207+ with NCR SDMS 3.06.00) and the newest drivers (found on
http://www.asus.com.tw). And switch of the PCI-to-Memory-Burst, but
this you will have to do with any SCSI-Controller.

Hans-Georg

------------------------------

Date: Sat, 11 Nov 1995 20:08:12 +0100
From: Joe Dougherty <jdo...@gate.net>
Subject: Re: Shut Down

"J. Eric Josephson" <j...@FTP.COM> said:

>In hopes that I can also get an answer, I'm joining this
>thread. I have also seen this in my system, and customers
>at times.

>My feeling is that some some prosesses cet corrupted and
>will not allow them self to be killed any more... OH, no!
>"HAL"!!! Any way, I'd love to know what you find.

>I have also found that Ctrl-Alt-Del works, but does not leave
>the drives "dirty"

I've seen this happen from time to time. I have a file manager named
FM/2 (great shareware) which has a process killing utility that is very
halpful for looking at a lit of active processes. Generally, if I can't
shutdown, I pull this app up, pick something from the list, and kit "kill".
That usually "wakes up" the shutdown process enough to get a clean
shutdown.

I've also noticed that if you're running Warp Connect on a network, it
takes a bit longer to complete the shutdown, especially if you have any peer
connections active.

Joe Dougherty
jdo...@gate.net

------------------------------

Date: Tue, 31 Oct 1995 10:05:25 PST
From: Charlie Schwartz <dem...@directnet.com>
Subject: Slow Printing and Memory Leaks

I have been having two problems lately - slow printing and an apparent
memory leak somewhere.

Printing anything brings my system to its knees. Even on a Pentium
120, things slow to an absolute crawl until the print job goes to the
printer. This happens whether I print from an application or even just
copy a file to lpt1. Almost as bad as printing from Windoze. I am
using the laserjet driver and printing to a Laserjet II clone. I did
not have this problem with OS/2 2.1.

As to the memory leak, after the machine runs for some time, swapping
activity increases, and the swap file begins to grow. Sometimes
shutting down all my applications solves the problem (as it should),
but most of the time it doesn't help. The system starts thrashing and
continues to thrash even if only one application is running. The
system has 16mb of memory. Only rebooting solves the problem in these
cases.

I have installed Fixpack 10 and the new laserjet printer drivers, none
of which seems to help. Does anyone have any clues?

Charlie Schwartz
dem...@directnet.com

------------------------------

Date: Tue, 31 Oct 1995 13:14:08 EST
From: Bob Babcock <pep...@cfa0.harvard.edu>
Subject: Re: Slow Printing and Memory Leaks
Schwartz on Tue, 31 Oct 1995 10:05:25 -0800 (PST))

> Printing anything brings my system to its knees. Even on a Pentium 120,
> things slow to an absolute crawl until the print job goes to the printer...
> I did not have this problem with OS/2 2.1.

Try adding /IRQ to the printo1.sys line in config.sys (or if already there,
try removing it). Warp defaults to polled printer operation; 2.11 used
interrupts.

> an apparent memory leak somewhere.

Are you using WebExplorer 1.03? The developers have acknowledged a memory
leak there which can cause huge swap files.

------------------------------

Date: Thu, 16 Nov 1995 00:01:48 GMT
From: jam...@buffnet.net
Subject: Re: Solution: [COMW] waring - only wrote xxx of xxxx bytes

en...@interlog.com (Enzo Franzese) writes:
> hg...@technet.sg writes:
>>
>>If you are facing "[COMW] Warning - only wrote xxx of xxxx bytes" error with
>>IBM Dial-up for TCP/IP and you have already applied the Fix Pack #10. The
>>problem may be from the new COM.SYS!
>>
>>I recovered the previous COM.SYS by "UNPACK COM.SY_" which is located in the
>>Achives to replace the new one.
>
>What version (ie. date, filesize) of COM.SYS are you using ? From fixpak 5?

Hello,

I am using warp connect (fullpack), tcpip 3.0, USR Sportster 28.8
internal modem, and the sio 1.53 com driver. I am not connected to a
lan, and only use warp for accessing a ppp dynamically assigned ip
internet account.

I get the [COMW] error, whenever I try to upload data and then my
connection hangs. I have no problems with any other internet apps,
only when uploading using ftp. I haven't applied any fixpacks that
have been released. I have tried replacing the com.sys driver that
comes with connect with a com driver (Comfix.zip) that is on hobbes in
the OS2/patches directory. I have disabled all compression, and error
checking on my modem. I have lowered the baud of my modem from 115200
to 57600 and then to 38400.

I have run a command file that changes the mtu from 1500 (the value in
the dialer) to 1450 before uploading (as recommended by a post in
comp.os.os2.networking tcpip):

ifconfig ppp0 mtu 1450

Everything I have tried doesn't fix the [COMW] errors. I have spoken
to my ISP about the problem, and they claim that the AT&F1 init string
that I use with the dialer is fine (My ISP uses USR Couriers). They
blame the problem on OS/2.

I have spoken with USR, and the claim my modem is fine, and that it
must be OS/2 that is causing the problems. I can upload to my shell
acount without any problems using halite.

I really am inpressed with warp's robustness, and I think it is a
truly mature OS, as compared to win95, but if I can't have stabilty in
my internet connection, then I have no choice but to try win95. I hope
someone has anything that may help me get OS/2 working correctly.

------------------------------

Date: Thu, 16 Nov 1995 08:52:50 +0100
From: "P.C. van der Post" <STA...@telefication.nl>
Subject: Re: SOLVED: Windows Programs Stopped

> I found the problem with starting my windows programs. The path
>statement in my dos session autoexec did not include c:\windows. Some
>how or other, during the install of the new mouse driver this got
>changed (or it previously worked without that in the path).

I found out (the hard way), that when you do a Selective Install, you
should ALWAYS check the WIN-OS2 Drive letter, even if you are not
reinstalling any WIN-OS2 components. The drive letter gets changed into
the OS/2 boot drive in AUTOEXEC.BAT.

My WIN-OS2 is on G:\OS2\MDOS\WINOS2, OS/2 is on D:. After doing a
Selective Install, I couldn't launch WIN-OS2 anymore. That was because
my WIN-OS2 directory in AUTOEXEC.BAT was changed into
D:\OS2\MDOS\WINOS2.

Greetings, Peter Team OS/2 Holland

Peter van der Post
Telefication B.V.
Arnhem
The Netherlands

------------------------------

Date: Fri, 27 Oct 1995 09:32:33 -0400
From: Robert Jesus Marcano Varela <92-2...@usb.ve>
Subject: Re: Soundblaster16 Bit

> I tried to install OS/2 Warp into a friend's machine with SoundBlaster
> CD-Rom Creative (The card is SoundBlaster 16bit) but the system tell me
> that no CD-Rom is present into machine. I tried also a driver SB_OS2.ZIP
> (SB16D2.SYS) but no new.

If you have an IDE CD-ROM, you will need to put your SB16 as an
IDE port 2, an put the jumper on the CD-ROM as a Master(single), see
your SB16 Documentation. I only have a problem that I can't resolve:
When I use Audio CDs it doesn't work, all data CDs work correctly.

Robert Marcano
Electronic Engineering Student.
Universidad Simon Bolivar, Caracas, Venezuela.
e-mail: 92-2...@usb.ve

------------------------------

Date: Mon, 6 Nov 1995 17:36:28 -0600
From: Richard Hinton <ged...@uxa.ecn.bgu.edu>
Subject: The bootp problems

From: R. Hinton <ged...@uxa.ecn.bgu.edu>

X-To: OS-2 listers...

I have an Internet provider that uses System V release four Unix
through a multi-plexor (Ethernet) to a Sun 670p dual processor mini
main frame box. My provider has made a special version of Trumpet
Winsock (PC and MAC) available to various users. I want to convert OS-2
IAK scripts to that they will work on this system. The problem seems to
revolve around the fact that OS-2 IAK uses a binary "bootp" file, while
the Unix box has its own bootp sequence which is initiated by each
micro which is dialing up. Any constructive suggestions would be
appreciated.

In the OS-2 IAK kit there are two binary files, one is called
'bootp' and the other is called 'bootpd'; both of these files dealing
directly with dynamic IP connections to the Internet. I have been using
a specially modified (by my provider) Windows based version of Trumpet
Winsock fairly regularly now for several months to call up my Internet
provider. My provider will NOT support an OS-2 version of an Internet
dialer.

My version of Trumpet Winsock has several scripts, two of which
are directly responsible for making a connection to the Internet. The
first script (login.cmd) dials the modem, sends the username, password,
and then issues the SLIP command. After this operation the login script
terminates. The host computer sends an initial IP address, a reference
to the MTU size, and a note about "header compression" matching my
system.

Then a second script consistently essentially of one ASCII word
(bootp) starts. Since there is no binary file in the Trumpet directory
on my micro, this ASCII word must activate a bootp binary file that is
present on the host Unix (Sun 670p) mini-computer. The bootp is
initiated and the three dynamic IP addresses are sent to the micro, and
a connection is established.

This is not the way it works in the OS-2 Annex.cmd script which is
often modified to suit many different systems. My Annex.cmd dials the
modem, sends the username, password, and then issues the SLIP command.
The host computer sends a single initial IP address, a message about
the MTU, and another reference to the header compression matching. At
that point the Annex.cmd scripts stops and then just sits there.

I assume I must send the word "BOOTP" to the host system without
activating the binary bootp.exe file that is present in the /TCPIP/BIN
directory. But I am not sure. I would like to use the Windows Trumpet
Winsock program under Win-OS-2, but it only succeeds in crashing the
system. By the way my version of Trumpet Winsock came directly from my
service provider and seems to be an individualized copy of the socket
program. Any ideas of how to make IAK work with my provider?

Thanks,

Richard N. Hinton < ged...@uxa.ecn.bgu.edu >

------------------------------

Date: Sun, 29 Oct 1995 03:29:51 GMT
From: jpg <j...@epix.net>
Subject: Threads ?

Can anyone explain what threads are? My OS/2 (v2.1) server has DB2/2
loaded and will have about 50 windows clients attached. Assuming that
threads has a default setting, should I be worried about changing it?

Thanks much for any info.
Regards,
J...@EPIX.NET

------------------------------

Date: Mon, 30 Oct 1995 09:50:32 +0100
From: Nicolas Wagrez <n...@ocegr.fr>
Subject: Re: Threads ?

Threads are basically path of execution. You can have several
concurrent path of executions within an app, like executing several
program's functions concurrently (save file and redraw screen for
example)

Your product's manual should state if it needs the config.sys thread
statement to be modified. Actually, it is most likely that its install
program already did it.

Nicolas.
Team OS/2 France

------------------------------

Date: Thu, 26 Oct 1995 12:12:41 EDT
From: HAL...@comp12.unos.org
Subject: Time Change utility

I was wondering if any one has any suggestions on who to automatically
change the time on a OS/2 pc. With the time change coming this
weekkend "falling back" from 2am to 1am, I have several OS/2 Warp
systems acting as Lotus Notes servers.

Does anyone know of any cmd files,macros,etc that will help with this.

If there a sharewar Chronos type program for OS/2? (I am not an OS/2
person, just a Notes Administrator so I am not too familiar with the
inner workings,features,etc of Warp.

Any ideas,etc would be appreciated.

EDWARD HALD
SR OPERATIONS ANALYST
UNITED NETWORK FOR ORGAN SHARING
RICHMOND, VA 23225
804-330-8648
HAL...@COMP12.UNOS.ORG

[I solved this problem by grabbing the utility NISTIME.ZIP. It does an
FTP with the US NBS, grabbs the current time, compares it with system
time, reports the difference and if told to do so, it sets the system
clock. I run the thing from the end of my <host>.CMD script for SLIP.
gph]

------------------------------

Date: Mon, 13 Nov 1995 22:48:33 +0100
From: Turgut Kalfaoglu <TURGUT%TREARN...@hearn.nic.surfnet.nl>
Subject: Trivia: TESTCFG.SYS missing (Warp Connect)

Here is a bit of humor: If you want to put the desktop in a loop, put a
REM in front of TESTCFG.SYS like I did, then some time later, select
Selective Install (which requires TESTCFG.SYS). It will soon complain
about it, but will not give you an option to quit. So, you open a
command prompt, remove the REM from TESTCFG, and now you try to
SHUTDOWN..

Desktop and the Selective Install go into a loop, desktop closing
Install's window, and Install re-openining it with a BEEP..
Beep..beep..beep.. forever :) -turgut

------------------------------

Date: Fri, 27 Oct 1995 19:51:46 EDT
From: Felmon Davis <dav...@gar.union.edu>
Subject: trouble with 'create another'!

Hello.

For a long time now I've had an unusual menu pop up when I click
'create another' on a folder; I've been getting:

default
folder
folder

Only the second 'folder' however does anything.

Now, today I've noticed I have:

default
folder
assigns
folder

'Assigns' is the name of a directory I think I recently created on a
floppy. Clicking on it brings up the 'folder create' menu but it
doesn't create a folder or seem to do anything.

Being smart, I thought I'd power down and run chkdsk /f:2. Now I've
got:

default
folder
assigns
folder
students

'Students' is the name of a directory I created today, again on one of
my floppies.

How can I correct this? Please?
What's the explanation?

Felmon

Felmon John Davis
dav...@gar.union.edu
dav...@unvax.union.edu
Union College
Schenectady, NY
meine meinung ist mir

------------------------------

Date: Fri, 27 Oct 1995 12:14:48 +0500
From: Rich Jacox <rja...@exis.net>
Subject: UltiMail Slowdown

Anyone else notice a slowdown when using UltiMail Lite? After using it
on-line for awhile it seems to slowdown the whole system. I'm using
Connect with TCP/IP and the latest upgrades from "Retrieve Software
Updates."

TIA,
Rich

\ Computer System Analyst, NSWC PHD ECO
/ Adjunct Faculty, Tidewater Community College
\ Team OS/2 Chesapeake, VA
/ * all opinions expressed are mine alone

------------------------------

Date: Fri, 27 Oct 1995 16:27:43 GMT
From: Andrew Woodhouse <awoo...@mpc-uk.com>
Subject: Re: UltiMail Slowdown

Ultimail Lite is, from my recent experiences, a *very* large and
resource hungry piece of software.

Quite why I don't know, but it includes support for things people -
thank god - don't use (.gif sigs, for instance)...

But it *does* handle MIME and Attachments very well, and that's why I
use it.

Is there really a way to speed it up?

Andrew

------------------------------

Date: Wed, 15 Nov 1995 18:21:44 -0500
From: Bob Babcock <pep...@mars.harvard.edu>
Subject: Re: Unable to boot C:

> for Dos/Win i have a utility tvga.crtc which fixes the centering of
>Windows on the screen i.e. without it Windows aligns itself off
>centre... Does anyone know of an OS2 utility equivalent to tvga.ctrc to
>fix this?

The way OS/2 is supposed to handle this is you
1. open a DOS full-screen session
2. load whatever TSR is necessary to handle screen centering, refresh rate
setting, etc.
3. run SVGA ON

This creates a file OS2\SVGADATA.PMI which contains info on video
settings. If necessary, you can run SVGA under DOS, which creates
SVGADATA.DOS, and use the .DOS file to replace the .PMI file.

------------------------------

Date: Wed, 15 Nov 1995 18:49:31 GMT
From: Finlay Welsh <fi...@cix.compulink.co.uk>
Subject: Re: Unable to boot C:

I've now sorted this by running FDISK/MBR. I'm a happy man - but....
my video driver is a Trident 1M. I have the OS/2 driver for it and it
runs fine. However, for Dos/Win i have a utility tvga.crtc which fixes
the centering of Windows on the screen i.e. without it Windows aligns
itself off centre. It worked fine of course when I had dual boot set
up, but now that OS2 is in its own partition, it won't work for it. So
I have to move my OS2 screen to the left and when I run a full screen
Dos session, its leftmost edge disappears off screen. Does anyone know
of an OS2 utility equivalent to tvga.ctrc to fix this?

Finlay Welsh. Glasgow, Scotland

------------------------------

*********************************
End of Info-IBMPC Digest V95 $172

Reply all
Reply to author
Forward
0 new messages