Info-IBMPC Digest V95 #176

3 views
Skip to first unread message

Info-IBMPC Digest

unread,
Nov 30, 1995, 3:00:00 AM11/30/95
to
Info-IBMPC Digest Thu, 30 Nov 95 Volume 95 : Issue 176

Today's Editor:
Gregory Hicks - San Jose, CA <GHI...@arl.mil>

Today's Topics:
Re: A20 line and Evergreen Revto486
Checking Web Links Automatically
Re: Complete copy of OS/2 drive to New Drive
Exabyte and DOS
Re: Green PC - DPMS problems
Re: Ibm21*.Add Needed!
Cyrix 386 upgrade chips and A20 line (V95 #171)
Re: Info-IBMPC Digest V95 #169
microscribe HD-jumpers
Novell and two Network cards
OS2 2.1 with Win 3.11 ?
OS2 API: how to read and write into named shared memory
Re: Sanyo PC-AT 286 BIOS :>))
slow clock
Re: slow clock
Why only 638K conventional mem?
Windows swap file
Re: Retrieve Updates over Ethernet/LAN?

Send replies or notes for publication to: <INFO-...@arl.mil>

For readers in the .MIL domain: Send requests of an administrative
nature (addition to, deletion from the distribution list, et al) to:
<INFO-IBMP...@arl.mil>. For all others, please send
requests to join, or signoff from, the list to an IBMPC-L BITNET
LISTSERV.

Currently these LISTSERV's are at hosts vmd.cso.uiuc.edu,
hearn.nic.surfnet.nl, taunivm.tau.ac.il and uga.cc.uga.edu. There are
others...

----------------------------------------------------------------------

From: Kirby Stiening <kk...@dayhoff.med.virginia.edu>
Subject: Re: A20 line and Evergreen Revto486
Date: Fri, 01 Dec 1995 12:54:10 -0500

Turns out that Evergreeen has posted a patch program that allows reboot
from C> prompt which resets A20 line. Not 100% reliable, but 90% is
better than nothing. File is available on the Evergreen BBS as
something like RVREBOOT.ZIP

Thanks to John for his explanation and analysis. Guess there must have
been quite a few with OLD 386 systems that needed this help.

Kirby Stiening
kk...@dayhoff.med.virginia.edu

------------------------------

Date: Thu, 30 Nov 1995 13:26:07 EST
From: John DeCarlo <jdec...@mitre.org>
Subject: Checking Web Links Automatically

Does anyone know of a utility to check whether a particular URL is
still functioning?

This would be useful both for people running servers on OS/2 as well as
those with large Web Explorer hot lists.

I have heard of Unix utilities, but nothing for OS/2.

Thanks.

John DeCarlo, MITRE Corporation, McLean, VA--My views are my own
Fidonet: 1:109/131 Internet: jdec...@mitre.org

------------------------------

Date: Thu, 30 Nov 1995 22:00:18 GMT
From: i...@starnetinc.com
Subject: Re: Complete copy of OS/2 drive to New Drive

lan...@iadfw.net (Mike Langer) writes:

>Is it possible to copy an entire OS/2 drive to another physical drive
>on a IBM Model 95(i.e. 486 with Microchannel arch.)?

I have copied OS/2 to another drive (and even to other PCs),
but haven't had a "system partition" like you apparently do to worry
about. As long as you're intending the destination drive to be the
same drive letter, I would expect things to work fine.

BTW, copying SWAPPER.DAT is unnecessary since it's created at
every boot. I don't know about your other file.

Steve

------------------------------

Date: Thu, 30 Nov 1995 13:34:41 EST
From: Karl Demi <kd...@philly.nekop.ingr.com>
Subject: Exabyte and DOS

Hi Techer's,

I have an EXABYTE 8200 tape drive connected to the SCSI bus of a P/133
machine running DOS 6.22. I need to be able to use the cpio command to
backup and restore files to this device. I have a DOS cpio command but
I need a driver or another way to specify the tape drive in the cpio
command from the DOS prompt. I have searched the web and came up empty.
Can you help? I had heard of some software that would assign the tape
drive a letter so it could be accessed like a hard drive but can't
remember where.

Any response welcomed.

------------------------------

Date: Thu, 30 Nov 1995 22:02:31 GMT
From: i...@starnetinc.com
Subject: Re: Green PC - DPMS problems

<TURGUT%TREARN...@uga.cc.uga.edu> writes:
>Hi there.. My monitor and video card support the 'Green PC' so that
>the monitor suspends, and then turns itself off if unused.

>Does anyone know of any utility that supports the 'off' mode?

There is a free utility called Blackout that does this. I think
it's available at the Hobbes ftp sites.

Steve

------------------------------

Date: Fri, 1 Dec 1995 08:30:49 EST
From: "Murray M. Cooper" <mmc...@net-link.net>
Subject: Re: Ibm21*.Add Needed!

** Reply to note from Nicola Fabiano <MC8...@MCLINK.IT> 12/01/95 12:11pm CET
> URGENT! Need a driver for a o name vlb eide controller. the name of the
> driver is IBM21*.ADD. Thans for anyone posting it or pointing me out a
> site. TIA
> Nicola Fabiano

Try anonymous ftp to ftp.europe.ibm.com in the /psmemea/os2drivers
subdirectory.

DocCoop

------------------------------

Date: Thu, 30 Nov 95 11:49:42 EST
From: John Gault <ga...@doim6.monmouth.army.mil>
Subject: Cyrix 386 upgrade chips and A20 line (V95 #171)

The following question was presented in the IBMPC Digest. I
believe I have some information that may be of help. First, the
question:

From: "Kirby K. Stiening" <kk...@dayhoff.med.virginia.edu>
Date: Tue, 19 Sep 1995 19:06:39 GMT

Bought a 386 to 486 upgrade chip from Evergreen
Technology a couple of months back and it's worked fine, except for a
major inconvenience. It looks like the cache fools with the A20 line
(whatever that is). Having to reboot the PC for any reason means that I
cannot reload either HIMEM.SYS or EMM386.EXE which effectively eliminates
using Windows without a power-off reboot. Evergreen seems to have left
their BBS phone off-line for the last 3 days and all the voice mailboxes
are full. Cyrix says that Evergreen doesn't buy from them so it's not
their problem. Any hints on how to get around this A20 line lock.

Now, the response:

There are several switches controlling the operation of the
"HIMEM.SYS" of the IBM PC. One of those switches is the
A20CONTROL:ON/OFF. But first, what is the A20 line?

The A20 line is a wire that controls the upper memory area. On
most PCs, it behaves correctly, but on some older models, it interferes
with how HIMEM accesses the upper memory. This is probably the problem
with Kirby's setup.

The /A20CONTROL:ON/OFF is a parameter that defaults to ON, which
specifies that HIMEM.SYS should take control of the A20 line even if it
was on when HIMEM.SYS was loaded. Set to OFF, HIMEM.SYS will take
control of the A20 line only if it was off when HIMEM.SYS was loaded.
I suggest that Kirby change this switch setting by adding the /A20
switch to the HIMEM command. This probably will resolve his current
problem, assuming there aren't other problems with his HIMEM.SYS or his
AUTOEXEC.BAT instructions.

Hope this helps!

John Gault
US Army CECOM
Product Integrity and Production Engineering Directorate
ga...@doim6.monmouth.army.mil

------------------------------

Date: Thu, 30 Nov 1995 23:54:54 +0500
From: Rich Jacox <rja...@exis.net>
Subject: Re: Info-IBMPC Digest V95 #169

|> |Interesting article comparing Win95, OS2, and MacOS:

|> |http://www.zdnet.com/~pcweek/sr/0821/tface.html

|I cannot access this URL! Is it right?

Yes. I just pasted it into WebExplorer and it went directly to that page.

Rich

\ Computer System Analyst, NSWC PHD ECO
/ Adjunct Faculty, Tidewater Community College
\ Team OS/2 Chesapeake, VA
/ VP, Mid-Atlantic OS/2 User Group
\ Columnist, "The Umbrella": Ask Dr Warp, Warp'd Perspectives
/ * all opinions expressed are mine alone

------------------------------

Date: Fri, 1 Dec 1995 15:38:07 +0100 (MET)
From: Radovan Klier - HAGEN <Radova...@public.srce.hr>
Subject: microscribe HD-jumpers

Hi everybody!
Does enyone know anything about jumper-settings on the miniscribe-hd
(model: 8051A, HDA: 02B, PCBA: 04B, Unique: 03A)? Thanks a lot in
advance for any suggestion!

Greeting, R.Klier
radova...@public.srce.hr

------------------------------

Date: Fri, 1 Dec 1995 07:10:03 CST
From: Woody Woodwad <wood...@airmail.net>
Subject: Novell and two Network cards

This question is regarding having 2 token ring cards in a single
machine and getting Novell to see/use both of them.

I am running Warp Connect (BLUE) on a token ring network.

The connect machine is part of a laboratory ring, totally (physically)
separate from the rest of our internetwork.

What we wish to do is add a second token-ring card to the Warp Connect
machine and connect that machine to the rest of the network. We do not
really want to turn the machine into a router, because we do not wish
rest of the internet to see the laboratory token ring network. We only
want the Connect machine to communicate with both rings.

(This allows us to move trial/beta installations and software
configuration across to the production side of things.)

I am able to configure the 2nd card as an alternate (A24) and I use IRQ
7, since printing is polled, and irq 3,4,2,and 6 are used by other
devices.

In MPTS, I have set it up, and added the IBM Netbios and the IBM
requestor to the protocols to bind to the secondary.

Indeed, on boot up, you can see the two cards be recognized with their
node addresses, and netbios announces available sessions for both.

The Problem lies on the Netware side.

In reading the documentation, it will only talk through the primary
card, and ignore the second, unless routing is set up. This is what I
read through the readme. It excepts this on OS/2 boxes, as they can
route.

OK. How do I set up the os/2 box to route IPX? And, can I prevent
someone from the internetwork from seeing the lab machines?

Anyone with experience, please offer any tips as you might have.

------------------------------

Date: Fri, 1 Dec 1995 10:05:37 -0500
From: John Lowry <jlo...@bbn.com>
Subject: OS2 2.1 with Win 3.11 ?

I did something unintended by IBM ...

I installed OS2 2.1 for Windows (3.1) dual-boot on my machine running
Windows 3.11. (Mostly because I was bored and curious).

OS2 runs fine. DOS/Win 3.11 continue to operate (e.g. barely
acceptable)

OS2 cannot run Windows applications (although it catches their faults
cleanly and consistently - how nice !)

Should I assume that I have asked more of OS2 2.1 than is appropriate
and upgrade to Warp ?

OR

Should this work correctly and something else is wrong.

TIA,

John Lowry
jlo...@bbn.com

------------------------------

Date: Fri, 1 Dec 1995 12:10:23 EST5EDT
From: MOLENAAR ROBERT <MOLE...@agreng.lan.mcgill.ca>
Subject: OS2 API: how to read and write into named shared memory

I am writing programs that being compiled with IBM C/C++ 2.01 32-bit
compiler. I want to run those 32-bit programs as interacting processes
under WARP. They will share data via named shared memory, created using
DosAllocSharedMem and DosGetNamedSharedMem of OS2 APIs. However, I do
not know how to write command in 32-bit C that can read and write data
into the named shared memory. I fully appreciate for any clue to help
me in sloving that problem.

Thank you,
Robert Molenaar (mole...@agreng.lan.mcgill.ca)

------------------------------

Date: Thu, 30 Nov 1995 11:10:37 -0500
From: Jim Meagher <xl_...@shore1.intercom.net>
Subject: Re: Sanyo PC-AT 286 BIOS :>))

At 06:15 AM 11/30/95 -0800, you wrote:
> Can anyone please provide any information on a ROM BIOS version
>1.03(make is not identified),IO.sys version 1.03 being used in a
>Sanyo PC-AT 286 computer ??
>
>The model is MBC-16LX5,
>and the serial # is 19701610.
>
> I would like to know what the keyboard combination is to read/change the
>BIOS settings. Another grandfather would like to be able to E-mail. And
>YES, he bought his Sanyo new when he was just a young lad! Time to also bury
>his DOS 3.3 !!
>

Penny,

Most 286 machines used a setup diskette to access the BIOS. There is a
generic program called ATSETUP.EXE (or maybe AT-SETUP.EXE).

I __think__ that you can get it from http://www.phoenix.com. In any
case, you should be able to locate it in a CICA ftp site or by
searching YAHOO

Jim Meagher

Micro Solutions Consulting Programming, Training, Installation,
PO Box 1129 Network Administration and Service
Salisbury, MD 21802-1129 410-543-8996
xl_...@shore.intercom.net http://www.intercom.net/biz/msc/msc_home.html

------------------------------

Date: Thu, 30 Nov 1995 18:32:42 +0000
From: Andrew Funk <A5603...@attpls.net>
Subject: slow clock

Hello.

I have a Pentium 90 that doesn't keep accurate time. Once I set the
clock, its fine for a few days and then slowly loses time. Is this
problem most likely caused by a bad CMOS battery or is there another
possible cause? Is there an easy way to check this? I've only had the
computer about 8 months.

Thanks,
Andre...@attpls.net

------------------------------

Date: Thu, 30 Nov 95 13:59:21 EST
From: Gregory Hicks - San Jose Ca <ghicks@arl>
Subject: Re: slow clock

Andrew:

Length of time *you've* had the computer is no indication of how long
the battery will last. (You have no idea how long the thing has been
installed nor how old the thing is...)

Does the clock lose time when powered off? If so, it's an indication
that the battery may need changing.

Has the clock stopped running when the machine is off? If so,
Replacereplace the battery.

The clock on my 486-50 loses about a second per 12 hours when compared
to the NIST reference...

Hope this helps.

Regards,
Gregory Hicks

------------------------------

Date: Fri, 1 Dec 95 9:32:13 EST
From: Bill Jones (n3jlq) <wej...@cbdcom.apgea.army.mil>
Subject: Why only 638K conventional mem?

Recently the group I work with had an attack of Monkey virus, which
luckily was easily removed using "KILLMONK" written by Tim Martin of
the University of Alberta. This pgm easily detected the virus whether
or not it was resident in memory, and quickly removed it, whereas the
McAfee Scan program cannot detect it unless you boot from a clean
floppy.

The McAfee resident shield program did detect the virus on one computer
that had it running. Anyway, one of the indicators used by the KILLMONK
program is the amount of total conventional memory being less than
640K. After checking all the computers and disks at work, I decided to
check my home computer, a GW2K 486-33-local bus with a CDROM. When I
checked this computer, KILLMONK indicated that although it was free of
Monkey virus, that it only reported 638K of memory, and that this was
highly indicative that a virus was present.

I obtained a clean floppy with the McAfee scan program, booted from
this disk, and checked for virus', but none were detected. While still
running from the floppy boot, I re-ran KILLMONK, and got the same
result as before. I also ran the DOS mem program, and it indicated 638K
total.

My question is, why am I missing 2K? I assume that even if my hard
disk was infected by a virus that a floppy boot would give normal
results, so I think that a virus is not the problem here, but what is?

Recently, I upgraded by adding a 840MB hard drive. When I bought the
hard drive I was unsure of whether my rom bios would support drives
>500M, so I also bought a bios extender card. I first tried to install
the drive without the card, and it seemed to work, except that the
first time I tried copying files to it, the directory filled up with
cross linked files, so I inserted the bios extender card and
re-installed the disk. In the process I corrected a loose cable
connection to the disk. This time the disk worked fine (so I still
don't know if I really need the extender card). Anyway, is it possible
that this bios extender card is using up some of my conventional ram?
Unfortunately, I don't remember whether mem returned 640K or 638K when
I first bought the computer. Besides the bios extender card, the only
extra cards installed are the cdrom driver , a soundblaster card, and a
high irq com port card (I have disabled at least one of the
on-motherboard com ports.

Can anyone suggest where my 2K of ram has gone and/or some suggestion
as to how I can investigate further? I haven't noticed any significant
degradation in performance, but I get nervous when programs tell me
I've got some unknown virus.

Thanks in advance

------------------------------

Date: Fri, 01 Dec 95 09:30:07 0100
From: Victor Dias Fernandes <v...@dg13.cec.be>
Subject: Windows swap file

I'm trying to automate a full PC installation from the network.

I want to have a procedure to install all the software in the
PC's trough the network, for this I create a zip file with all the
data from drive C: of a model PC and then I unzip this file on all PC's
I want to install.

I include in this zip file the Windows swap file, but after the
unzip, Windows complains that the swap file is corrupted.

I've tried some variations on creating the zip file to try to
recreate the swap file in the same position on the disk (I suppose this
is the problem) but, no success.

Before the creation of the zip file I always defragment the
disk and after I create the Windows swap file, only then I create the
zip file.

Can somebody tell me if there is a possibility of creating in
an automated faction the Windows swap file without running Windows, and
the way to proceed.

Thanks.

Victor Fernandes (v...@dg13.cec.be)

------------------------------

Date: Thu, 30 Nov 1995 18:35:00 +0100
From: Axel Buehning <bue...@ibm.net>
Subject: Re: Retrieve Updates over Ethernet/LAN?

"Phillip E. Parker" <PPA...@TWSUVM.UC.TWSU.EDU> wrote:
>Is it possible/appropriate to use this object over a direct Internet
>connection? If so, then how should I configure the settings?

If you intend to distribute your own Software-Updates via 'Retrieve
SW-Upd.' here's what I did:

- Create ZIP-Files for the Products you want to distribute. Your files
must be PKZIP'ed and contain a REXX-Script named UPDINST.CMD which will
perform all actions to install/update the Product.


- Create a Update-Gopher server listening to port 77 (default for
UPDATE.EXE).

If you don't have gopher-server software get GOSERV.ZIP. To get it
via GOPHER try this steps (from memory - I hope the steps are correct):

Fire up the Gopher fom the IAK-Folder
Select "Useful gophers from the world of IBM"
Select "IBM Almaden Research Center"
Select "EWS - Software"
Search for "GOSERVE.ZIP" and get it.

There's also a version hobbes
(ftp://hobbes.nmsu.edu/os2/ibm/ews/goserv.zip) but I think it's way old
(over 100K smaller than the one on the IBM gopher).


- Make the files accessible via the gopher.
Sample Gopher-Menu item:
Name : "My Software [size 100000]"
The size-parameter (in bytes) will be used by UPDATE.EXE
to calculate the file-size in KB.
Host : "updates.my.domain"
Port : "77"
Path : "/updates/file1.zip"
Type : "5"

- On your clients site create a programm-object with the following settings:
Programm : "UPDATE.EXE"
Parameters : "/h updates.my.domain /t C:\UPDATES.TMP"
/h = Host on which the gopher-server resides
/t = Destination-Directory for retrieved files
This MUST exist on Target-PC.

Hope this short discription did help you.

CU
--
// --------------------------------------------------------- //
// Axel Buehning bue...@ibm.net //
// I haven't lost my mind. It's backed up on tape somewhere. //
// CPU not found: (A)bort, (R)etry, (I)gnore, (E)mulate //
// #include <std-disclaim.h> //
// --------------------------------------------------------- //

------------------------------

*********************************
End of Info-IBMPC Digest V95 #176

Reply all
Reply to author
Forward
0 new messages