Info-IBMPC Digest V95 #178

2 views
Skip to first unread message

Info-IBMPC Digest

unread,
Nov 30, 1995, 3:00:00 AM11/30/95
to
Info-IBMPC Digest Thu, 30 Nov 95 Volume 95 : Issue 178

Today's Editor:
Gregory Hicks - San Jose, CA <GHI...@arl.mil>

Today's Topics:
Re: A couple of problems... (OS/2) (V95 #167)
A plea for help with a crashed IBM PS/1
ACER ASPIRE -
Coupling 8Mb SIMMS with 4Mb SIMMS
False "Hard disk controller error"
I have seen the future of the Web...
IBM Mwave Windsurfer
problems with Ontrack DM ?
Serial Interface Boards
Re: smartdrv and modems (v95 #167)
Re: WFW network under OS/2 ?
What to do with 1080MB IBM disk.
Re: Zip Drives
Re: Boot up Security Products available?
Re: .WAV files messing up (2 msgs)
/Tm option weirdness in Visual Age C++ (2 msgs)
Re: Access lists
Apogee's New Game
Re: Cables

Send replies or notes for publication to: <INFO-...@arl.mil>

For readers in the .MIL domain: Send requests of an administrative
nature (addition to, deletion from the distribution list, et al) to:
<INFO-IBMP...@arl.mil>. For all others, please send
requests to join, or signoff from, the list to an IBMPC-L BITNET
LISTSERV.

Currently these LISTSERV's are at hosts vmd.cso.uiuc.edu,
hearn.nic.surfnet.nl, taunivm.tau.ac.il and uga.cc.uga.edu. There are
others...

----------------------------------------------------------------------

Date: Wed, 22 Nov 95 13:13:25 -0500
From: Clark Gaylord <cgay...@vt.edu>
Subject: Re: A couple of problems... (OS/2) (V95 #167)

> From: "Brian Battles, WS1O" <bbat...@nai.net>
>
> 1) It used to be that if I was in an "OS/2 Prompt" session, if I
> tried to run a DOS program from the command line, it would simply open
> up a DOS session and run the program. Now it starts to open a DOS
> "window" and then stops with the following error message...any ideas?:

Check AUTOEXEC.BAT to make sure something there isn't doing it.

> 2) All of a sudden, for no reason I can think of, about a couple of
> weeks ago I started having trouble with viewing/editing text in certain
> OS/2 programs, eg, PM Mail, ZED editor, etc. Sometimes the onscreen
> text looks fine, sometimes it's mixed with ASCII "garbage" characters,

This is a good head-scratcher. Are the changes "real" ... do they recur in
the same place on viewing the same file and with different apps, do they
print fine, etc? If not, I'd suspect video driver; if so, I'd suspect drive
system.

> 3) If you bring up the Fonts Pallette onscreen, it says you can
> change the screen font "globally" simply by holding down the Alt key,
> right-mouse-clicking the font you want, and dragging the pointer (to
> the desktop?). This works with most programs, but some applications
> seem to insist on using Time Roman Bold (or whatever that "generic"
> system font is). I can change come of these applications' screens to
> another font, but the next time they open, it's back to that same old
> "default" system font. Is this just the way OS/2 Warp works or is there
> any way to do what I want?

It is up to the individual application to either use a system font or save
its own font settings. If it uses a standard system listbox, for example,
it will get the saved system listbox font. But if the author changes the
fonts, then they are responsible for saving them (preferably in their *own*
INI file, instead of the system INI file). Bitch to the individual program
authors about this one. Now, there is one place you'll see something like
this in WPS -- if you set the font/color of a folder, for example, then
later change the system font/color (using Alt-drag), this folder will *not*
assume the new setting. To have this folder get the (new) system setting,
you have to set it to "Default" in the settings notebook.

P.S. -- I'd recommend reorganizing your CONFIG.SYS; it's a mess. :-)

--
Clark K. Gaylord
Blacksburg, Virginia USA
cgay...@vt.edu
http://gaylord.async.vt.edu/

------------------------------

Date: Fri, 24 Nov 1995 15:26:33 -0500 (EST)
From: Scott Berner <no...@bluemarble.net>
Subject: A plea for help with a crashed IBM PS/1

Hello and Greetings,

A very good friend, and computer wiz in his own right, highly recommended
that I join this "LIST" and seek your highly esteemed assistance. I am a
real novice to date, but nevertheless very glad to have started the journey.
However, I have found myself in a dilema. Please allow me to explain.

First, let me give you the pertinent data on my pc. It is a 386 IBM PS/1.
I am running DOS 6.2, and WINDOWS 3.1. Also a mouse and a vga monitor. It
has a total of 80+ MB, 16+ clear. It is running extended memory with
"memmaker".

The problem started with the system "locking up" on a program running in
windows. After ten minutes, or so, I impatiently turned the computer off.
That was the last time I saw WINDOWS. Now when the pc is turned on I get
the notice "Could not find or open ANSI.KEY". This also comes on when I
move to the TELIX.EXE in opening my internet account. I have looked and
found the ANSI.KEY file in both TELIX and DOS. The directional arrows on
my keyboard are also malfunctioning. Dos is working well enough, thank
God, to make this request for help and handle e-mail. I am sure it can do
much more than this, but I am a WINDOWS user, and not familiar with DOS.

This list has a good reputation for being helpful to others in need
(ie. friendly). I could sure use some helpful advice about now. Hope
someone is interested! Thanks!

Scott

------------------------------

Date: Wed, 22 Nov 1995 11:02:11 -0500
From: "J. Dashiell" <dash...@nadc.nadc.navy.mil>
Subject: ACER ASPIRE -

Support is available on compuserve; genie, prodigy and by internet email.
I have a short file with all their contacts info in it at home.
Go pcvenb forum i think on compuserve if you can
and enter the acer library.
You'll find alot of files and info#s.txt which has
all the support contact info in it.

jude <dash...@nadc.nadc.navy.mil>

------------------------------

From: DARANG YVON <e13...@moka.cafe.uqam.ca>
Subject: Coupling 8Mb SIMMS with 4Mb SIMMS
Date: Thu, 23 Nov 1995 00:20:41 -0500 (EST)

I have a PC (IBM PS1 486SX-33MHz) with a 72-pin 4Mb SIMMS. I would like
to upgrade my RAM to 8 or 12 MB. Can any body tell me if I can couple a
8MB SIMMS with a 4MB one to get the 12 Mb?
Thanks in advance for your help.

Yvon Darang: e13...@cafe.uqam.ca

------------------------------

Date: 25 Nov 95 21:49:00 EDT
From: "MACPHERSON, DOUGLAS" <MACPH...@alexandria-emh2.army.mil>
Subject: False "Hard disk controller error"

That's the problem, folks, but read on to see how bizzare PCs can be.

I have two old boards, a 286 and a 386sx. They have one thing in common
-- they've been on the shelf so long their on-board batteries are
totally dead and won't hold a charge.

They have a second trait in common. On bootup,if the battery is dead
they say the CMOS is bad and want me to fill it in then, if I exit,
they will access the hard disk. BUT, if I reboot with a (partially?)
charged battery I get "Hard disk controller error." Yes, I get
this sequence placing either hard disk on either MoBo.

I have tried using 3+v and 6v external batteries on the 386, which
produces an immediate HD error message and no further progress.

If I unplug the hard disk controller then the machine boots normally.

So I don't have bad hard disk controllers, I have CMOS that
thinks they are bad, but only if the CMOS battery keeps it alive.

This is beyond me.

Do you have any advice or ideas? Please send direct to me or post
here.

Doug M. aka
macph...@alexandria-emh2.army.mil

------------------------------

Date: Sat, 18 Nov 1995 23:32:09 -0500 (EST)
From: "C. W. Tazewell" <c...@exis.net>
Subject: I have seen the future of the Web...

On Fri, 17 Nov 1995, Roy Tennant wrote:

> and it's name is Java. After attending "Java Day" at Sun Microsystems
> last week, and seeing what folks are doing with this programming language
> for the Web, I am certain that it will transform our use of the Web.

Hey, Guys and Gals,
I can't resist passing this info along about the "PC Becoming
Passe." Put the two items below together and you have the future of The
Internet - and Libraries.
Bill.

The Virtual Library is *THE REASON* to have the Internet! Your
Internet WWW HOTLIST! Don't hunt the Web - It's on the Virtual Library
of Hampton Roads. Set it up as your Netscape Home Page:
http://wwwp.exis.net/~cwt/

For more about Virtual Libraries, visit the Professional Librarians'
Section. Use the Staff Entrance over by the soda machines and restrooms.
URL http://www.infi.net/~cwt/intro.html

------------------------------

Date: Tue, 21 Nov 95 21:30:17 EST
From: Jeff Stanton <STA...@uconnvm.uconn.edu>
Subject: IBM Mwave Windsurfer

Does anyone out there have an IBM WIndsurfer sound card? I am having
serious trouble getting sound from game programs to work properly.
Various game programs that supposedly work with "100% Soundblaster
compatible" sound cards create a noisy, looping audio hash with my
Windsurfer card. All other sound functions (e.g., windows system
sounds, CD playback, movies) seem to work fine.

Any Suggestions would be appreciated. TIA.
-Jeff Stanton

------------------------------

From: Itzik Lavi <izhk...@shani.net>
Date: Sat, 25 Nov 1995 10:03:02 +0200
Subject: problems with Ontrack DM ?

I will appreciate if any of you can help me with the following
questions:

1) I have installed a WD AC-2850-00F Caviar disk in my system, in
addition to the existing Seagate ST3250A drive. Both drives are
connected to the same IDE card, and I have configured the
Seagate as the Master, and the WD as the slave. I am using Ontrack
Disk Manager to get access to the WD full capacity, and the DMCFIG to

get 32-bit disk access in Windows (3.11). I have partitioned the WD
drive into 4 partitions of the following sizes: 255MB, 255MB, 255MB,
80MB. I made the necessary changes in "386 Enhanced" in Control
Panel,
and marked both File access and Disk access as 32-bit access.

After restarting windows, I get 32-bit File access only on drive C:
(the original Seagate), while all the WD partitions (D:, E:, F:, G:)
are marked as 16-bit FIle access (Disk access is 32-bit). Windows
3.11 documentation says that this means that those partitions can't
be
accessed by 32 bit file access, while the disk documentation says it
should be able to handle 32-bit file access.

How can I change File access to be 32-bit?

2) I noticed that some software products can't operate if installed
on any of the WD partitions. Such products are: VIBRA16
(Sound-Blaster 16 software) and Goblins-3. Is this because of some
incompatibility with the Ontrack DM ?

Thanks
Itzhak Lavi

------------------------------

Date: Wed, 22 Nov 1995 11:45:28 +0800 (HKT)
From: Maverick <l...@rizal.slu.edu.ph>
Subject: Serial Interface Boards

Hi Everyone,

I'm a student and we were given some topics to discuss in school. I'm
hoping I'll get some help from you guys. These are the subjects:

1. Serial Interface Boards
1.1 Serial Adapter Interface
1.2 Serial Adapter I/O Address

2. Programming Considerations
2.1 Polling
2.2 Interrupt Service Routines.

..........thanks in advance and more power to you all

Laurence

------------------------------

Date: Thu, 23 Nov 1995 17:16:49 +0200 (IST)
From: Eli Zaretskii <el...@is.elta.co.il>
Subject: Re: smartdrv and modems (v95 #167)

J. Dashiell <dash...@nadc.nadc.navy.mil> wrote:

> Has anyone figured out good switch settings for smartdrv.exe under dos
> 6.22 for file transfers by communications programs?

What's different in this case from any other file-oriented program? I
usually set smartdrv to write-back operation (/N) on any hard disk and
write-through on floppies. I never had any problems with that setting.

If what bothers you is the possibility of losing characters which come
through COM ports when smartdrv decides it's time to flush the cache, then
the solution isn't some switch to smartdrv but something which will drop
the RTS line when this happens. I have a TSR somewhere which does just
that, called RTS14.ZIP, which you could probably find with archie (or I
can mail it to you if you can't).

> In fact, can anybody explain what different settings are best for
> different kinds of computer work and why?

I have found that delayed write operation should be preferred for any
work except in two cases:

1) When your program writes huge amounts of data that will always
overflow the cache many times.

2) When you program hooks hardware interrupts that need to be
serviced ASAP.

In both of the above cases I recommend turning delayed-write feature OFF,
or even disabling the cache altogether.

------------------------------

Date: Wed, 22 Nov 95 13:04:11 -0500
From: Clark Gaylord <cgay...@vt.edu>
Subject: Re: WFW network under OS/2 ?

> From: Weimin Xiao <WXI...@ukcc.uky.edu>
>
> I use WFW 3.11 peer-to-peer network ability through NE2000 compatible
> card connecting PCs. One of the PCs has OS/2 Warp installed, and WFW
> connection does not work on the PC running OS/2. I put NET START
> command in OS/2's STARTUP folder, then OS/2 reported that IFSHLP.SYS

a) Do not try to run DOS networking products under OS/2. You are only
asking for trouble. It can be done in some circumstances (e.g., there used
to be a lot of info about running Lantastic for DOS before Lantastic for
OS/2 was released) but universally you are better using OS/2 for networking.
If you're going to bother with using such a better OS, why not use those
features it excels at particularly well?

b) There is a faq on this on the ftp site hobbes.nmsu.edu. The file is
netfaq.zip, and I think it is in /os2/network.

c) OS/2 Peer that comes with Warp Connect works fine with WFW LANs; it is a
complete NETBIOS LAN system. This is by far the best solution. There is
documentation in the box for using Peer with WFW. I use Lan Server (threw
out WFW years ago ... good riddance!), so please don't ask me for further
info on WFW<->Peer, but I've read the manual and I've seen it work. It
seems pretty much a no-brainer, though you do have to know the name of all
your LAN resources beforehand.

--
Clark K. Gaylord
Blacksburg, Virginia USA
cgay...@vt.edu
http://gaylord.async.vt.edu/

------------------------------

Date: Thu, 23 Nov 1995 23:16:59 +0200 (METDST)
From: Sebastian Krzyzowski <bas...@zeus.polsl.gliwice.pl>
Subject: What to do with 1080MB IBM disk.

> I have an IBM 1080MB disk and I was told it is an IDE disk...
> It just shows about 500+ Megs (fdisk)...
> I tried EZDisk, but this is just for Seagate...

Well, First I think it must be EIDE drive because IDE parameters
end at 1024 Cyls, 16 Heads and 63 Sectors. Maybe IBM cannot call
their disks EIDE because it is a standard invented by Western Digital.
And for example Seagate calls its disks Fast ATA.
Then I think you have three solutions:

1. Buy a motherboard which supports LBA.
2. Buy an EIDE disk controller which can 'see' your large disk using
his own driver (installed in CONFIG.SYS).
3. Try to use a program called OnTrack Manager which comes with
Western Digital disks and seems to work with every hard disk.

Bastek
student from Poland

------------------------------

Date: Tue, 21 Nov 95 16:45:26 PST
From: Dave Gomberg <gom...@wcf.com>
Subject: Re: Zip Drives

David Kirschenbaum, ZIP drives are even better than you report. A
diskette holds 100MB UNCOMPRESSED, which means more like 200MB or
so. I use a lot of PKZIP, needless to say. A terrific backup.
Dave

Dave Gomberg, Experimenta San Francisco CA USA gom...@wcf.com

------------------------------

Date: Wed, 22 Nov 1995 19:15:17 +1000
From: "Maurice H. Rich." <M.R...@ens.gu.edu.au>
Subject: Re: Boot up Security Products available?

>
> John,
>
> Even the **BEST** security setup won't stop an F5 during the boot process.
> What is he trying to protect against?
>
> Jim Meagher

if using Dos 6.2 or later add the line

switches = /f /n

to your config.sys to prevent the 2-second delay after the "Starting MS-DOS"
message and to disable F5 and F8 on startup.

then there are a variety of Dos/Windows password protection programs at
SimTel and CICA and mirrors available for anonymous access.

regards,

Maurice H. Rich mau...@gu.edu.au | M.R...@ens.gu.edu.au
Technical Officer (Computing) | Ph +61 7 875 7489
Faculty of Environmental Sciences | Fax +61 7 875 7459
Griffith University, Nathan, Brisbane, QLD, Australia. 4111

Thought for the day:
Book (n): a utensil used to pass time while waiting
for the TV repairman.

------------------------------

Date: Wed, 22 Nov 1995 11:08:18 -0600
From: Charlie Macklin <cmac...@sky.net>
Subject: Re: .WAV files messing up

On Tue, 21 Nov 1995, Solomon Peachy wrote:
> On Mon, 20 Nov 1995 11:36:53 -0600 Charlie Macklin said:
> >I have a sound blaster 16 and a while ago some of the wave files started
> >to mess up. They would seem to skip or sometimes even echo. These files
> <Snip>
> >either. Some I can play fine with the dos command line, a sound file
> >player, and Windows media player. Others will mess up on all 3.
> >I have Snappy on the second one and my printer on the first. I haven't
> >I have upgraded recently, but I tested everything after upgrading and
> >everything worked fine.
> Simple - LPT2 uses IRQ 5 by default, and that is also what the SB16 uses as
> default. Change the SB16 to IRQ 10 or something different.

I tried IRQ 10 (even though MS-diagnostic said 10 was reserved. I also
tried 2, 5, and 7. MSD says 2 is my second 8259A, 5 is LPT2, and 7 is
LPT1. I tried them all anyway and still got the messed up sound on some
wav files. The only time it worked ok was when I took the card with the
second parallel port out. I even tried changing both parallel ports to
IRQ 5 and then tried all the IRQs I could for the sound card and it still
didn't work. Also, MSD said that the LPT ports still had the 5 and 7 IRQ
when I changed them to both 5. Is that just MS Diagnostics messing up or
can you not change the IRQ for the parallel ports even if you have
jumpers to do so?

It seems like I might need to get a switch box for my parallel port 1 and
just plug the printer and snappy into that. I tried that before with a
manual switch but sometimes it didn't work right. What about the
electronic ones that doesn't have a switch to flip? Would they work??

------------------------------

Date: Wed, 22 Nov 1995 15:33:00 PST
From: Kasey Chang <Kas...@discopy.com>
Subject: Re: .WAV files messing up

From: Charlie Macklin <cmac...@SKY.NET>

>I tried IRQ 10 (even though MS-diagnostic said 10 was
>reserved. I also tried 2, 5, and 7. MSD says 2 is my
>second 8259A, 5 is LPT2, and 7 is LPT1. I tried them
>all anyway and still got the messed up sound on some
>wav files.

Don't use 2. The 8259A is your interrupt controller.

>The only time it worked ok was when I took the card
>with the second parallel port out. I even tried
>changing both parallel ports to IRQ 5 and then tried
>all the IRQs I could for the sound card and it still
>didn't work.

I'll explain my theory at the end...

>Also, MSD said that the LPT ports still had the 5 and
>7 IRQ when I changed them to both 5. Is that just MS
>Diagnostics messing up or can you not change the IRQ
>for the parallel ports even if you have jumpers to do so?

MSD only GUESSES at IRQ 5 and 7 since it cannot be sure
without trying the port.

For your information, Windows and DOS usually do NOT use
IRQs to control parallel ports. OS/2 and/or print queue
programs might, but that depends. Not sure about WfW.

Here's the "usual" IRQ assignments:

0 DOS Timer (do not use)
1 Keyboard (do not use)
2 Cascade Interrupt / 2nd 8259A (do not use)
3 COM2/4
4 COM1/3
5 LPT2
6 Floppy (do not use)
7 LPT1

The higher IRQs are not listed because some games do not
work with IRQs above 7.

Of the 8 interrupts, only four are available. And if you
have four different ports, then you don't have a free
IRQ. Ports usually cannot share IRQs without special
hardware, but there are exceptions, see below.

From your description, it sounds as if you have both
LPT1 and LPT2. As explained before, LPT ports under DOS
and Windows use "polling" technique, and does not use
IRQs. So it is usually okay to use IRQ5 for your
soundcard, UNLESS you run into problems.

Should you run into problems, it may be possible to set
your parallel port to use a different interrupt. That
depends on your I/O card.

--Kasey Chang / kas...@discopy.com

------------------------------

Date: Sat, 25 Nov 1995 14:36:54 -0500
From: Keith Bennett <kben...@cpcug.org>
Subject: /Tm option weirdness in Visual Age C++

Recently I issued a request for help for a program that was aborting
before even reaching main. I managed to make the problem go away,
but I don't know whether I've really addressed its cause or just
removed a symptom.

I'm using Visual Age C++ with the most recent fixes.

The executable used a home grown DLL. The DLL's object files were
compiled using /Tm, but the executable's were not. When I added the
/Tm option to their compile, the problem disappeared.

Then we asked ourselves what would happen if the situation were
reversed, if the DLL was compiled without the /Tm, but the EXE was
compiled with it. We tried it, and the program aborted before
main().!

I can't believe that this would be a general rule, as it is not
reasonable to expect that third party DLL's be compiled with /Tm.

So, this problem must be masking another problem. That is, there's
probably some error in our code that's causing this to happen.

Any thoughts on this? Thanks much.
- Keith

Keith Bennett Bennett Business Solutions, Inc.
Silver Spring, MD USA OS/2 & DOS Software Development
kben...@cpcug.org (301) 871-7696

------------------------------

Date: Tue, 28 Nov 1995 00:13:15 GMT
From: wko...@colos2.com
Subject: Re: /Tm option weirdness in Visual Age C++

Hello, Keith!

When you use the /Tm option with VA C++, you are actually replacing
some of the memory management modules. The new modules will add
some data to the beginning and end of each block of memory you allocate,
where they will store such information as the original size of the memory
block, the address in your program from which it was allocated, and some
additional information (such as checksums and data patterns to detect if
you overwrite memory immediately before or immediately after this
memory block's boundaries). The memory address returned to your own
program is the address at which your data block actually starts; that is,
the added header and trailer is "invisible" to your program.

So, a program compiled with /Tm+ is fundamentally incompatible with a
DLL compiled with /Tm- (and vice-versa). For example, if you call free()
from a program compiled with /Tm+, the function will "back up" from the
address you passed, to find the added header, and will add the length of
that added header plus the trailer, and delete THAT block of memory.
Obviously, if you are calling a DLL that allocated that block of memory
via the "normal" memory management functions, there IS no header or
footer for the memory block -- a recipe for trouble!

Hope this helps!

------------------------------

Date: Sat, 11 Nov 1995 17:32:00 EST
From: "Glen L. Bowes" <bo...@iaw.on.ca>
Subject: Re: Access lists

At 08:57 03/11/95 PST, Kasey Chang wrote:

>list...@listserv.net is the clearing house for all
>listserv's on BITNET, and ONLY those on BITNET. Send your
>list global command there should work just fine.
>
>The best way to keep track of mailing lists is subscribe
>to the NEW-LIST list, at in...@vm1.nodak.edu (I think).

Thanks for the help Kasey. I've subscribed to an Access list and got a whole
slew of listserv addresses. Now to find time to read my mail <G>!

Glen L. Bowes - bo...@iaw.on.ca
Bowes Computer Service
http://www.iaw.on.ca/~bowes

------------------------------

Date: Tue, 21 Nov 1995 12:29:29 +0100
From: Turgut Kalfaoglu <TURGUT%TREARN...@hearn.nic.surfnet.nl>
Subject: Apogee's New Game

I am really happy to see the new Apogee game, Realms of Chaos (available
from the finest FTP sites (!) as 1ROCA.ZIP, 1ROCB.ZIP) has an OS/2 Settings
file.. You just define a new item for it on the Desktop, go into 'DOS SETTINGS'
page, and select 'LOAD' button, and give this ROCA.OS2 file, presto - you
have all the settings loaded.. Works great under OS/2, EXCEPT, of course,
the *^&#$&%^& sound effects.

-turgut

------------------------------

Date: Thu, 23 Nov 1995 17:55:27 +0800
From: Elfredy Cadapan <e...@mudspring.uplb.edu.ph>
Subject: Re: Cables

On Wed, 22 Nov 1995, L. Chen wrote:

> I recently received a catalog from Cyberguys. Their prices seem to be
> lower than most of the other catalogs that I have seen (but their shipping
> seems to be higher). e.g. "Laplink" parallel cable is $2.89; anti-static
> wrist strap is $3.75. Could there be a difference in "quality", esp. in
> the case of the cables? What questions should I be asking before I buy?

The only differences I can think of would be quality of the moulding,
(plastic vs metal, etc) or shielded vs unshielded cables. Shielded cables
are generally more reliable, especially near sources of electromagnetic
radiation like motors or refrigerators...

> I also have some questions in general on cables:
>
> 1. What is the difference between "laplink" parallel cables
> and the printer parallel cables -- besides the different
> connector at one end?

Not sure, haven't used them personally. Maybe the same as serial cables?

> 2. The same question for "laplink" serial cables and plain
> serial cables?

Null-modem cables, or "laplink" cables have the transmit and receive
lines crossed, so they're generally used for file transfer or multiplayer
games. Plain, "straight-through" cables are generally used to extend modem
cables for connections to the serial port.

> 3. What is a null modem cable? Does it have anything to do with
> "straight through" or "cross-over"? Is this serial or parallel?

Null-modem is serial, since the crossed TX and RX lines simulate modem
communications (without the modems). I think "cross-over" cables are the
same as null-modem; straight-through cables are just modem cable extenders.

> 4. What is the difference between parallel and serial cables, except
> perhaps the connectors? (Someone give me a cable from QVS, Inc.
> The label on the package said "Serial or Parallel Cable -- Strt
> Thru DB25M/M", which I interpretate to mean that this cable can be
> used as either parallel or serial cable.)

Your cable can probably be used to extend either one - all it does is
connect 25 pins on one to 25 pins on the other. You'll probably need a
gender changer to use it for serial, since the "M/M" means male-to-male
sockets, and serial cables need female ends.

> TIA and happy holidays to all.
>
> ----------
> Lily Chen lvc...@mcimail.com am...@freenet.buffalo.edu
>

Hope that helped... :)

Elfredy Cadapan
Computer Science Instructor and Professional Nerd
Institute of Computer Science, UP at Los Banos
Home page : http://www.uplb.edu.ph/~evc/

------------------------------

*********************************
End of Info-IBMPC Digest V95 #178

Reply all
Reply to author
Forward
0 new messages