Can't activate gem because diff version already activated

321 views
Skip to first unread message

Levander Thomas

unread,
Jul 12, 2008, 6:22:10 PM7/12/08
to
I've just done a 'gem install junebug-wiki'. The 1st step to using
junebug is to create a wiki instance. Trying to do that, I get this
error:

===========================================
levander@judas:~$ junebug testwiki
/usr/local/lib/site_ruby/1.8/rubygems.rb:142:in `activate': can't
activate activesupport (= 1.4.4, runtime), already activated
activesupport-2.1.0 (Gem::Exception)
from /usr/local/lib/site_ruby/1.8/rubygems.rb:158:in `activate'
from /usr/local/lib/site_ruby/1.8/rubygems.rb:157:in `each'
from /usr/local/lib/site_ruby/1.8/rubygems.rb:157:in `activate'
from /usr/local/lib/site_ruby/1.8/rubygems.rb:158:in `activate'
from /usr/local/lib/site_ruby/1.8/rubygems.rb:157:in `each'
from /usr/local/lib/site_ruby/1.8/rubygems.rb:157:in `activate'
from /usr/local/lib/site_ruby/1.8/rubygems.rb:49:in `gem'
from /usr/bin/junebug:18
===========================================

The problem is somehow related to my having multiple versions of the
activesupport gem installed. I could just try removing the newer
versions of all the gems I have duplicates installed for, but I'd really
like to know what's going on.

Here's the output of 'gem list':

===========================================
levander@judas:~$ gem list

*** LOCAL GEMS ***

actionmailer (2.1.0)
actionpack (2.1.0)
activerecord (2.1.0, 1.15.6)
activeresource (2.1.0)
activesupport (2.1.0, 1.4.4)
builder (2.1.2)
camping (1.5)
cgi_multipart_eof_fix (2.5.0)
daemons (1.0.10)
fastthread (1.0.1)
gem_plugin (0.2.3)
hoe (1.7.0)
junebug-wiki (0.0.37)
markaby (0.5)
metaid (1.0)
mongrel (1.1.2)
passenger (2.0.1)
rack (0.3.0)
rails (2.1.0)
rake (0.8.1)
RedCloth (3.0.4)
rubyforge (1.0.0)
sqlite3-ruby (1.2.2)
cponder@judas:~$ gem list | grep activesupport
activesupport (2.1.0, 1.4.4)
===========================================
--
Posted via http://www.ruby-forum.com/.

Luke Herbert

unread,
Sep 7, 2008, 4:43:16 PM9/7/08
to
Levander Thomas wrote:
> I've just done a 'gem install junebug-wiki'. The 1st step to using
> junebug is to create a wiki instance. Trying to do that, I get this
> error:
>
> ===========================================
> levander@judas:~$ junebug testwiki
> /usr/local/lib/site_ruby/1.8/rubygems.rb:142:in `activate': can't
> activate activesupport (= 1.4.4, runtime), already activated


I've just had a similar problem with hobo - solved by
sudo gem uninstall rails -v 2.1.1
sudo gem install rails -v 2.1.0

Not tried having the 2 in parallel - not sure that would be a good idea.
I think you can freeze your version so that you have a local version of
rails just for this project.
Hope it helps - I'm pretty ignorant about this stuff!

Reply all
Reply to author
Forward
0 new messages