Error message "';' expected"

4844 views
Skip to first unread message

Markus

unread,
Aug 7, 2011, 3:10:41 AM8/7/11
to
Hi,

I have used gnuplot on my old sheevaplug to visualize some weather
information.

Before half a year my sheeva has broken and now I try to setup a new
DreamPlug with the same functionality.

But my GnuPlot script doesn't work any longer on DreamPlug. It stops
with an error:

plot "< awk '/Sensor 1/ {next} {print}' /var/log/temperatures" using 1:6
title 'Innentemperatur' smooth unique with lines 1, "< awk '/Sensor 0/
{next} {print}' /var/log/temperatures" using 1:6 title
'Aussentemperatur' smooth unique with lines 3

"tempdarstellung", line 18: ';' expected


And:

plot "/var/log/fhem/KS300-2011.log" using 1:4 title 'Aussentemperatur'
smooth unique with lines 1, "/var/log/fhem/KS300-2011.log" using 1:6
title 'Luftfeuchtigkeit' smooth unique with lines 3

^
"KS300_plot", line 19: ';' expected


It says that behind "lines 1" it expects a semicolon...

Do you have any idea?

Thanks,

Markus

Hans-Bernhard Bröker

unread,
Aug 7, 2011, 8:56:24 AM8/7/11
to
On 07.08.2011 09:10, Markus wrote:

> plot "/var/log/fhem/KS300-2011.log" using 1:4 title 'Aussentemperatur'
> smooth unique with lines 1, "/var/log/fhem/KS300-2011.log" using 1:6
> title 'Luftfeuchtigkeit' smooth unique with lines 3
>
> ^
> "KS300_plot", line 19: ';' expected
>
>
> It says that behind "lines 1" it expects a semicolon...

Actually no. It expects one between "lines" and "1", because current
gnuplot doesn't allow a "1" in that place.

That syntax (linetype specification with just a number, but no keyword)
has been deprecated for several years now. It had never been an
officially documented feature anyway, and was removed ages ago. Have a
look at "help plot style" to see how it's done.

James Waldby

unread,
Aug 7, 2011, 11:24:15 AM8/7/11
to

Perhaps when Markus' script formerly worked, 'lines' was accepted
as an abbreviation of 'linestyle', and now is being taken as the
<style>-designator keyword 'lines'. Markus, do you know the version
numbers of gnuplot that you formerly used, and are using now?

Anyhow, changing lines to ls in the script may fix the problem.

--
jiw

Hans-Bernhard Bröker

unread,
Aug 7, 2011, 11:42:13 AM8/7/11
to
On 07.08.2011 17:24, James Waldby wrote:

> Perhaps when Markus' script formerly worked, 'lines' was accepted
> as an abbreviation of 'linestyle',

Quite definitely not. That "lines" is the required argument to "with".
It won't fulfill another role.

Markus

unread,
Aug 8, 2011, 12:58:10 PM8/8/11
to
Hello,

changing "with lines 1" to simply "with lines" has solved the problem.

Thanks for your help!

In the moment I am using gnuplot 4.4.0 on the dreamplug.

The previous version of gnuplot on my sheeva plug (where the same script
worked without problems) isn't reproducable any more...

But now it works.

Thanks!

Regards,

Markus

varu...@gmail.com

unread,
Apr 10, 2014, 6:17:22 AM4/10/14
to
Hi Folks,
I am facing a similar issue with the gnuplot.
When i am executing the following code in a file :
set key reverse Left outside
set grid
set xtics font "Arial, 10"
set style data linespoint
set boxwidth 2
set style fill transparent pattern 2 noborder


I am getting the following error :
gnuplot> set style fill transparent pattern 2 noborder
^
"./clusterload_all.pg", line 16: ';' expected

And when i had commented this line, i was getting some other error related to this only:
gnuplot> plot "cpu.dat" using 1:2 with lines title "CPU% total" lw 5 lc 1, '' using 1:3 with lines title "MEM% total" lw 5 lc 2, '' using 1:4 with lines title "CPU% for clmServer" lw 5 lc 6, '' using 1:5 with lines title "MEM% for clmServer" lw 5 lc 10, '' using 1:8 with boxes fill transparent pattern 2 title "1: Uninstall Licenses" lw 2 lc 5, '' using 1:9 with boxes fill transparent pattern 2 title "2: Install Licenses" lw 2 lc 6, '' using 1:10 with boxes fill transparent pattern 2 title "3: Query Installed Licenses" lw 2 lc 7, '' using 1:11 with boxes fill transparent pattern 2 title "4: Creating Feature Codes" lw 2 lc 11, '' using 1:12 with boxes fill transparent pattern 2 title "5: Register Feature Codes" lw 2 lc 3, '' using 1:13 with boxes fill transparent pattern 2 title "6: Query Feature Codes" lw 2 lc 1, '' using 1:14 with boxes fill transparent pattern 2 title "7: Unregister Feature Codes" lw 2 lc 21
^
"./clusterload_all.pg", line 29: ';' expected


Could you please help. As this scripts were working perfect with the same version earlier and now they are not.

Regards,
Varun

Christoph Bersch

unread,
Apr 10, 2014, 6:47:04 AM4/10/14
to
On 10.04.2014 12:17, varu...@gmail.com wrote:
>
> set style fill transparent pattern 2 noborder
>
>
> I am getting the following error :
> gnuplot> set style fill transparent pattern 2 noborder
> ^
> "./clusterload_all.pg", line 16: ';' expected

Your gnuplot version is too old. I checked this command to work at least
since version 4.4.4. I guess its the same problem with the rest of your
commands.

Christoph
Reply all
Reply to author
Forward
0 new messages