Skybuck Flying's Corona Game !

4 views
Skip to first unread message

skybu...@hotmail.com

unread,
Feb 28, 2020, 1:13:26 AM2/28/20
to
Hello,

Today, 28 february 2020, I just created a Corona Game !

http://www.skybuck.org/Games/CoronaGame/

You can download the executable from the link above.

Direct link to executable:

http://www.skybuck.org/Games/CoronaGame/CoronaGame.exe

Direct link to zip file:

http://www.skybuck.org/Games/CoronaGame/CoronaGame.zip

There is also a Game Manual.txt that you might want to read in case you have troubles figuring it out ! ;)

There is also a zip file which you can download which contains the exe and the manual.

Only the exe is necessary to play !

The intention of this game is to teach you the danger of the Corona Virus ! ;) =D

The objective for you is to save humanity and survive as long as possible ! LOL.

GOOD LUCK !

Bye,
Skybuck ;) =D

WOOOOOEHHHHOOEEE MY VERY FIRST GAME RELEASE ! YESSSS


skybu...@hotmail.com

unread,
Mar 3, 2020, 9:36:35 PM3/3/20
to
Strangely enough version 0.07 hangs on startup on toshiba laptop.

Itried remote debugging it but then the issue goes away.

As far as I know the application/game only uses on thread, however opengl might be using a thread internally.

There were some left overs of critical sections from when the game was threaded, but since threads were removed this should not be causing an issue.

As far as I know thread can read enter critical sections if they already acquired it.

So this has me mystified currently.

The game currently uses OnMessage and OnDone from TApplicationEvents to get the main thread under control.

Done is set to False to keep the application running.

So there are two entry points as where the main thread starts entering my code and potentially these critical sections.

Perhaps somehow Tapplication and the Tform are running two threads ?

Maybe one from openglcontrol, is this even possible ? Weird ?

I could be wrong maybe critical sections can not be entered twice, in that case maybe OnDone or OnMessage or OnPaint is called while still in the other event handler.

That could explain the lock up.

Previous versions were removed, should have left them up so people could try out those versions.

Anyway I want to know exactly what is going on so I will try some tools to automatically add log files or I myself will re-enable the console and output writeln messages to hopefully see in real time where the lockup on the toshiba occurs.

Could also be a faulty AMD/ATI driver. I did manipulate the driver versions to make it believe it's higher to be able to run star wars battlefront 2 which then still crashes. But for now I don't believe this is part of the cause. Driver could maybe be at fault as well though, seen it crash an application before.

Maybe my own TOpenGLControl contains some kind of bug at nc create and nc destroy or so.

The toshiba laptop is hyper threaded not sure if this is causing some kind of bug.

Anyway this is a very strange bug that is timing dependent. There is also a throttle in there which keeps the application running at 60 hertz, in case some of you run the game on higher frequency monitors.

In future my new games will use a more modern approach which will support higher frequencies. For now I also wonder if this throttle might be the cause of lock up somehow. Maybe higher performance timer/frequency is not yet initialized or somehow fails.

Anyway let me know if this game runs on your system or not. I would like to know how many systems are affected by this current weird bug.

Bye for now,
Skybuck.

skybu...@hotmail.com

unread,
Mar 5, 2020, 2:05:21 AM3/5/20
to
Good news: Problem solved by removing critical sections.

Bad news: I didn't find the core of the problem, it is probably critical section related somehow, console wouldn't come up, so writelns useless anyway and I am a bit lazy at moment, only did a few writelns :)

Future: I might try a logfile or so maybe later if I ever want to find this bug, but for now it's solved by simply removing unnecessary critical sections, still kinda interesting to know what went wrong. It only seems to hang on game startup right after laptop boots and logs into windows so that is kinda strange.

Current version is 0.10 and can be found here in case you missed it ! ;):

http://www.skybuck.org/Games/CoronaGame/

Bye,
Skybuck.

skybuck2000

unread,
May 19, 2021, 5:27:13 AM5/19/21
to
I now believe the cause of this "temporarely" freeze is loading of the opengl driver, apperently it takes a long time.

Will start a new thread about this.

Bye,
Skybuck.
Reply all
Reply to author
Forward
0 new messages