Error upgrading to SQL Server 2000

0 views
Skip to first unread message

Cstyle

unread,
Jul 12, 2002, 1:45:41 PM7/12/02
to
I'm trying to upgrade to SQL Server 2000 from SQL Server 7.00.1028 (on
Windows 2000 5.00.2195 SP 2), and I'm getting the following Setup
error:

Error running script: message.sql(1)

Anyone know what this is all about and what I can do about it? Any
help you could give would be great!

Luc

unread,
Jul 12, 2002, 6:24:19 PM7/12/02
to
Look at message.log in mssql\install directory and see if you can find an
specific error in that file. Or look at %WINDIR%\sqlstp.log.

"Cstyle" <toled...@hotmail.com> wrote in message
news:21ea6d1e.0207...@posting.google.com...

Cstyle

unread,
Jul 15, 2002, 4:40:31 PM7/15/02
to
Below is the error I'm getting in the sqlstp.log file. Anyone know
what this is all about?

13:48:05 Upgrading databases on instance 'MSSQLSERVER'
13:48:05 C:\WINNT\TEMP\SqlSetup\Bin\scm.exe -Silent 1 -Action 6
-Service MSSQLSERVER
13:48:05 Process Exit Code: (0)
13:48:05 C:\WINNT\TEMP\SqlSetup\Bin\scm.exe -Silent 1 -Action 1
-Service MSSQLSERVER -StartupOptions \-f \-m \-T4010
13:48:21 Process Exit Code: (0)
13:48:21 D:\x86\BINN\osql.exe -S MAS200TEST -b -n -d master -o
"C:\MSSQL7\install\upgrade.out" -i "C:\MSSQL7\install\upgrade.sql" -E
13:48:51 Process Exit Code: (6006) There are no EFS keys defined for
the user.

13:48:51 C:\WINNT\TEMP\SqlSetup\Bin\scm.exe -Silent 1 -Action 6
-Service MSSQLSERVER
13:48:52 Process Exit Code: (0)
13:48:52 C:\WINNT\TEMP\SqlSetup\Bin\scm.exe -Silent 1 -Action 1
-Service MSSQLSERVER -StartupOptions \-T4022 \-T4010 \-m
13:48:52 Process Exit Code: (0)
13:48:52 D:\x86\BINN\osql.exe -S MAS200TEST -b -n -d master -o
"C:\MSSQL7\install\messages.out" -i "C:\MSSQL7\install\messages.sql"
-E
13:49:01 Process Exit Code: (1)
13:49:09 Error running script: messages.sql (1)
13:49:09 C:\WINNT\TEMP\SqlSetup\Bin\scm.exe -Silent 1 -Action 6
-Service MSSQLSERVER
13:49:09 Process Exit Code: (0)
13:49:09 Action CleanUpInstall:
13:49:09 StatsGenerate returned: 2
13:49:09 StatsGenerate (0x0,0x0,0xf00,0x200,1033,303,0xc,0x0,0,0,0
13:49:09 StatsGenerate 1,cstefanick)
13:49:09 Installation Failed.

Luc

unread,
Jul 15, 2002, 7:25:06 PM7/15/02
to
Can you try to upgrade to 8.0 SP2? I believe this is a known bug fixed in
that service pack.

"Cstyle" <toled...@hotmail.com> wrote in message

news:21ea6d1e.02071...@posting.google.com...

Cstyle

unread,
Jul 16, 2002, 4:17:06 PM7/16/02
to
OK. I tried to upgrade to SP2, and it gave me the following error
message:

MSSQLSERVER has a newer version of Service pack installed. Setup will
now exit.

At this point I'm getting pretty frustrated, so I decided to just
start up the MSSQLServer service and just see what happens. And it
started just fine! I looked at the properties through Enterprise
manager and the product version is 8.00.194. I'm skeptical that all
is well since the installation never appeared to complete
successfully. What else can I do or look at?

Thanks for your help!

Luc

unread,
Jul 16, 2002, 7:45:07 PM7/16/02
to
That's strange since SP2 should install especially since you have build
8.00.0194.
I believe the original problem you're experiencing is a timing issue and
happens very rarely on some machines (and is fixed in SP2 upgrade). So the
installation seems to be sound but it didn't run all the upgrade scripts.
You may want to contact technical support to report these 2 issues.

"Cstyle" <toled...@hotmail.com> wrote in message
news:21ea6d1e.02071...@posting.google.com...

Reply all
Reply to author
Forward
0 new messages