Google Groups no longer supports new Usenet posts or subscriptions. Historical content remains viewable.

ODBC Error - Database not Found or no system permission. sqlerrm(systables)

Skip to first unread message

Gustavo Airasca

Aug 19, 2021, 12:22:42 PM8/19/21
Hi everyone, I can't test connection with ODBC.
In the server (debian 5 lenny - Informix 7.24UC5), with informix user, I can connect with database without problem (dbaccess ; connection ; connect ; demo_se ; USER NAME: I don't introduce anything, just press ENTER ; I select the database "prueba", and the connection is made)
But, when I try to connect with ODBC (Windows 10), it doesn't connect. A windows pop up and says "Test connection was NOT successfull.[Informix][Informix ODBC Driver][Informix] Database not found or no system permission. sqlerrm(systables).

Extra information:

Client Side
Windows 10
Informix user (I created one - desesperated action)
Connection tab:
Server Name: demo_se
Host Name: IP of the server
Service: 1526
Protocol: (tried with sesoctcp and onsoctcp)
Option: blank (also tried s=2)
Database Name: Prueba
User ID: blank
Password: blank

Server side
Debian 5 lenny
Informix 7.24.UC5
/home/informix/etc/sqlhost file: demo_ sesoctcp "IP of client" sqlexecd s=2
/etc/services add: sqlexecd 1526/tcp
/etc/hosts add: "IP of client" Dispenser (I give it a name)
/home/.rhosts add: Dispenser informix (I copied this file also in /home/informix/ and /home/informix/etc/)

After the failure in connection, the /var/log/sqlexecd said:
"date" "time" sqlexecd Dispenser informix -dprueba

Anyone have any clue??

0 new messages