Google Groups no longer supports new Usenet posts or subscriptions. Historical content remains viewable.
Dismiss

Backup (Version 10.5.9) image restore on Version 11.5.4

55 views
Skip to first unread message

Shashi Shekhar

unread,
Nov 3, 2023, 2:04:09 AM11/3/23
to
Hello All,

I was recently trying to restore an offline backup (taken on Db2 10.5.9) on DB2 version 11.5.4 . the DB size is 110 GB, compressed size 16 GB, the DB and backup are encrypted.

after triggering redirect restore, was monitoring using db2top utility. As per db2top, the restore was done in 25 minutes, post that db2 triggered upgrade of database which took some 15 minutes and ended up with SQL2555, which says DB2 restore successful with upgrade to version I ran restore from.

After that I still performed upgrade database command , followed update of archive log path and run binds.

But after that, when I tried to connect to DB or deactivating of DB, all commands were hanging. didn't see anything running on db2top.

and roughly after 80 minutes, the DB started responding to my above commands.


I tried above exercise twice, and same response in both case.
Server is RHEL.
Log primary and secondary both as 80 in numbers

What is possibly causing this delay even after restore, upgrade.


Regards

Jeremy Rickard

unread,
Nov 6, 2023, 4:57:25 AM11/6/23
to
Hi Shashi,

Sounds interesting but I think it's quite hard to guess what might be going on. Does the db2diag log not give some idea what is happening during activation (and therefore what is slow)?

You could raise a support case with IBM if the answer does not become clear.

Regards,

Jeremy Rickard
0 new messages