Problem viewing the layout contents of the instances

Skip to first unread message


Jul 4, 2009, 1:53:24 PM7/4/09
I can see the transistors layouts when designing the layout of a
transistor level design. But at the top-level layout design, when i
come to connect the designed layouts, i only see empty boxes.

Please, can you tell me how can i view the layout contents of the
instances instead of empty boxes?

1) I tried pressing SHIFT-F, but it did not work.
2) I tried All visible (AV) option in LSW, but it did not work.
3) I tried loading the techfile again from LSW and then using the AV
option, but it did not work.

Loading the techfile gives me the following error in the icfb window:
*Error* eval: undefined function - controls
*Error* load: error while loading file - "/usr/local/tools/work_umc130/"

It seems my techfile contains functions as 'controls' and other much
more that cadence does not understand.

Some user told me that Cadence didn't find the necessary functions
definitions (file), but he couldn't help me more than that. He advised
me to post my topic on this group.

This problem is driving me CRAZY. PLEASE, help me solve it.

btw, i am using Cadence 5.1.41

Andrew Pye

Jul 5, 2009, 10:00:15 AM7/5/09
A couple of thoughts:
1. Perhaps the number of display levels is too small. Go into
Display Options (Options -> Display) and set the "Start" level to 0
and the "Stop" level to 99 (or some other large number).
2. I'm not an expert with Cadence's configuration (it continues to
baffle me in new ways every day), but perhaps you need to load a
"context" file, which defines these functions it's looking for. With
the kits that I've used, I've done this with "loadContext" functions
in the .cdsinit file. Try looking for an example .cdsinit in your
design kit directory for the best way to do this.

Hope this helps!

Andrew Pye


Jul 6, 2009, 12:33:17 AM7/6/09
Thanks Andrew,

Option one worked for me. In the nunber of display levels, 'stop' was
set to zero by default!

Thanks again :)


Jul 6, 2009, 4:52:02 AM7/6/09
In your home directory, there should be a .cdsenv file.
If possible, change the stop & start levels as the line below:
layout startLevel int 0
layout stopLevel int 32

This enables the depth for viewing levels to be from 0 to 32 by
default for all design you work on.
But if this happens only in certain directories, check in the current
working directory for this .cdsenv file.
BTW, this feature is not foundry dependent. Nothing in the techfile
(.tf) should affect this behaviour.

When pressing some keys don't work, it might be because your bindkeys
aren't loaded.
You might want to check out in the help files what they do... :-)

Best regards,

Andrew Beckett

Jul 6, 2009, 5:35:53 AM7/6/09
hassaneldib wrote, on 07/06/09 05:33:

presumably you didn't have any bindkeys loaded, which is why the shift F didn't
work. Either that or you have some bindkeys which don't define shift F as this.

Adding this to your .cdsinit should load the "standard" bindkeys (I use the term
"standard" in quotes because they're not standard - they're just a sample set
that we ship):





Jul 6, 2009, 3:27:31 PM7/6/09
You really are of a great help.
Thank you :)

Feb 2, 2017, 3:06:09 AM2/2/17
On Monday, July 6, 2009 at 11:27:31 PM UTC+4, hassaneldib wrote:
> You really are of a great help.
> Thank you :)

Hi, I am facing same problem. I dont know hoe to load .tf file . How I make sure that .tf file is there in case if not there then how we load ? there is no option in LWS. please help in this regard. Thnaks
Reply all
Reply to author
0 new messages