Paperclip version supported needs to be updated

Skip to first unread message

Dan Coutu

Sep 27, 2013, 1:54:53 PM9/27/13
I have found that the acceptable range of versions of paperclip that are supported by community engine include a code defect that is really blocking me.

CE currently specifies the paperclip version as: paperclip (~> 2.4.3)

I'm able to use 2.4.5, which is the latest in the 2.4.x series but it has defective code.

The defect prevents the use of paperclip's validates_attachment_presence validator with a conditional :if or :unless 

Given that I have a model that only requires an image if a textual field is empty this is a bit of a show-stopper for me.

I'm not sure of which version of paperclip received the fix to this problem but the github page that shows the checkin for the fix can be found at

Paperclip has evolved a lot since 2.4. Perhaps a newer version with better Rails 3 support would be a good choice?


Reply all
Reply to author
0 new messages