problem running manage.py while isntalling a server

142 views
Skip to first unread message

Dante Castiglione

unread,
Jun 15, 2016, 10:04:25 PM6/15/16
to CommCare Developers

Hi

I am new to this list.
Trying to set-up a commcare-hq server for a client.

1.
I have installed commcare-hq and can run the server using the following:
./dockerhq.sh bootstrap

2.
Then if I point to localhost:8000
CommCareHQ server will display.

3.
We did not have an email system set up so it was trying to send the confirmation to the commcarehq.org web site........which it cannot.
I used pgadmin to go into the users table and set my new user to active.
 This allowed me to start a project and begin building a form.

4.
Now, the problem:
The Cloud care application is a big part of this load.
The two application menus (CloudCare and Messaging) do not show up on the initial load
I understand that to make them run I need to run the back-end and the front-end for CloudCare in two separate processes.

5.
I can run the CloudCare back-end like this:
cd /home/demo/Downloads/commcare-hq/submodules/touchforms-src/touchforms/backend
jython xformserver.py 4444

6.
I understand that, to run the CloudCare front-end I need to run manage.py
When I try to run it, it gives me an error:

cd /home/demo/Downloads/commcare-hq

./manage.py celeryd --settings=settings

corehq.util.log.HqAdminEmailHandler logger is being changed to logging.StreamHandler
corehq.util.log.NotifyExceptionEmailer logger is being changed to logging.StreamHandler
/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py:129: RemovedInDjango110Warning: Session verification will become mandatory in Django 1.10. Please add 'django.contrib.auth.middleware.SessionAuthenticationMiddleware' to your MIDDLEWARE_CLASSES setting when you are ready to opt-in after reading the upgrade considerations in the 1.8 release notes.
  RemovedInDjango110Warning
Traceback (most recent call last):
  File "./manage.py", line 96, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 353, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 327, in execute
    django.setup()
  File "/usr/local/lib/python2.7/dist-packages/django/__init__.py", line 17, in setup
    configure_logging(settings.LOGGING_CONFIG, settings.LOGGING)
  File "/usr/local/lib/python2.7/dist-packages/django/utils/log.py", line 71, in configure_logging
    logging_config_func(logging_settings)
  File "/usr/lib/python2.7/logging/config.py", line 794, in dictConfig
    dictConfigClass(config).configure()
  File "/usr/lib/python2.7/logging/config.py", line 559, in configure
    'filter %r: %s' % (name, e))
ValueError: Unable to configure filter 'hqcontext': Cannot resolve 'corehq.util.log.HQRequestFilter': cannot import name DatadogException
demo@demo:~/Downloads/commcare-hq$

7.
Any experience doing this or any help will be greatly appreciated.

Best,
Dante


Cory Zue

unread,
Jun 16, 2016, 3:40:33 AM6/16/16
to commcare-developers
Hi Dante,

Can you confirm you've installed all the requirements from pip?

pip install -r requirements/requirements.txt

--

---
You received this message because you are subscribed to the Google Groups "CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to commcare-develo...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Dante Castiglione M.

unread,
Jun 16, 2016, 9:10:12 AM6/16/16
to commcare-...@googlegroups.com
Thank you for your kind answer.

Yes, I did installl the requierements, and got no problems while doing it.
Not that I know at least.
Will run it again just in case.




---------------------------------------------

Dante Castiglione Maldonado

https://uy.linkedin.com/in/dantecastiglione
---------------------------------------------


--

---
You received this message because you are subscribed to a topic in the Google Groups "CommCare Developers" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/commcare-developers/xDcVqO8LuZQ/unsubscribe.
To unsubscribe from this group and all its topics, send an email to commcare-develo...@googlegroups.com.

Cory Zue

unread,
Jun 16, 2016, 9:28:46 AM6/16/16
to commcare-developers
Cool, good luck!

Just to elaborate more - that error looks to me like the "datadog" dependency is not properly installed, which would imply that not all the requirements were installed successfully.

Dante Castiglione M.

unread,
Jun 16, 2016, 9:05:58 PM6/16/16
to commcare-...@googlegroups.com
I understand your point.
System output says the following:
( I have marked "*** datadog ***" the point where it tries to install datadog and system says that requirement is already satisfied )
Not sure what to do.
manage.py just won't run.

demo@demo:~$ cd Downloads
demo@demo:~/Downloads$ cd commcare-hq
demo@demo:~/Downloads/commcare-hq$ sudo -H pip install -r requirements/requirements.txt
[sudo] password for demo:
Collecting https://github.com/dimagi/files/raw/master/python-requirements/pygooglechart-0.3.0.tar.gz (from -r requirements/requirements.txt (line 37))
exi  Using cached https://github.com/dimagi/files/raw/master/python-requirements/pygooglechart-0.3.0.tar.gz
t  Requirement already satisfied (use --upgrade to upgrade): pygooglechart==0.3.0 from https://github.com/dimagi/files/raw/master/python-requirements/pygooglechart-0.3.0.tar.gz in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 37))
Collecting git+git://github.com/smartfile/django-transfer.git@6e0dc94c3341c358fca8eb2bf74e23aee3983ec4 (from -r requirements/requirements.txt (line 71))
  Cloning git://github.com/smartfile/django-transfer.git (to 6e0dc94c3341c358fca8eb2bf74e23aee3983ec4) to /tmp/pip-PcuJbo-build
  Could not find a tag or branch '6e0dc94c3341c358fca8eb2bf74e23aee3983ec4', assuming commit.
  Requirement already satisfied (use --upgrade to upgrade): django-transfer==0.2.post2 from git+git://github.com/smartfile/django-transfer.git@6e0dc94c3341c358fca8eb2bf74e23aee3983ec4 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 71))
Requirement already satisfied (use --upgrade to upgrade): cython==0.23.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 2))
Requirement already satisfied (use --upgrade to upgrade): restkit==4.2.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 3))
Requirement already satisfied (use --upgrade to upgrade): iso8601==0.1.10 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 4))
Requirement already satisfied (use --upgrade to upgrade): jsonobject==0.7.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 5))
Requirement already satisfied (use --upgrade to upgrade): jsonobject-couchdbkit==0.7.4.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 6))
Requirement already satisfied (use --upgrade to upgrade): celery==3.1.18 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 7))
Requirement already satisfied (use --upgrade to upgrade): decorator==4.0.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 9))
Requirement already satisfied (use --upgrade to upgrade): django==1.7.11 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 10))
Requirement already satisfied (use --upgrade to upgrade): django-braces==1.8.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 11))
Requirement already satisfied (use --upgrade to upgrade): django-celery==3.1.16 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 12))
Requirement already satisfied (use --upgrade to upgrade): jsonfield==1.0.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 13))
Requirement already satisfied (use --upgrade to upgrade): dropbox==2.2.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 14))
Requirement already satisfied (use --upgrade to upgrade): defusedxml==0.4.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 15))
Requirement already satisfied (use --upgrade to upgrade): diff-match-patch==20120106 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 16))
Requirement already satisfied (use --upgrade to upgrade): django-tastypie==0.13.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 17))
Requirement already satisfied (use --upgrade to upgrade): djangorestframework==3.3.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 18))
Requirement already satisfied (use --upgrade to upgrade): djtables==0.1.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 19))
Requirement already satisfied (use --upgrade to upgrade): elasticsearch==1.9.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 20))
Requirement already satisfied (use --upgrade to upgrade): eulxml==0.18.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 22))
Requirement already satisfied (use --upgrade to upgrade): feedparser==5.1.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 23))
Requirement already satisfied (use --upgrade to upgrade): ghdiff==0.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 24))
Requirement already satisfied (use --upgrade to upgrade): gunicorn==19.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 25))
Requirement already satisfied (use --upgrade to upgrade): lxml==3.4.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 26))
Requirement already satisfied (use --upgrade to upgrade): kafka-python==0.9.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 27))
Requirement already satisfied (use --upgrade to upgrade): mock==0.8.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 28))
Requirement already satisfied (use --upgrade to upgrade): openpyxl==2.2.5 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 29))
Requirement already satisfied (use --upgrade to upgrade): Pillow==2.7.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 30))
Requirement already satisfied (use --upgrade to upgrade): phonenumberslite==7.1.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 31))
Requirement already satisfied (use --upgrade to upgrade): poster==0.8.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 32))
Requirement already satisfied (use --upgrade to upgrade): psycopg2==2.6.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 33))
Requirement already satisfied (use --upgrade to upgrade): psycogreen==1.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 34))
Requirement already satisfied (use --upgrade to upgrade): pycrypto==2.6.1 in /usr/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 35))
Requirement already satisfied (use --upgrade to upgrade): py-KISSmetrics==1.0.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 36))
Requirement already satisfied (use --upgrade to upgrade): python-dateutil==1.5 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 38))
Requirement already satisfied (use --upgrade to upgrade): python-magic==0.4.10 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 39))
Requirement already satisfied (use --upgrade to upgrade): pytz==2015.6 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 40))
Requirement already satisfied (use --upgrade to upgrade): PyYAML==3.11 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 41))
Requirement already satisfied (use --upgrade to upgrade): requests==2.10.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 42))
Requirement already satisfied (use --upgrade to upgrade): tropo-webapi-python==0.1.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 43))
Requirement already satisfied (use --upgrade to upgrade): xlutils==1.4.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 44))
Requirement already satisfied (use --upgrade to upgrade): Unidecode==0.04.18 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 45))
Requirement already satisfied (use --upgrade to upgrade): xlrd==0.7.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 46))
Requirement already satisfied (use --upgrade to upgrade): simplejson==2.6.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 47))
Requirement already satisfied (use --upgrade to upgrade): sh==1.09 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 48))
Requirement already satisfied (use --upgrade to upgrade): gevent==1.0.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 49))
Requirement already satisfied (use --upgrade to upgrade): greenlet==0.4.9 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 50))
Requirement already satisfied (use --upgrade to upgrade): numpy==1.7.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 51))
Requirement already satisfied (use --upgrade to upgrade): six==1.10.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 52))
Requirement already satisfied (use --upgrade to upgrade): socketpool==0.5.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 53))
Requirement already satisfied (use --upgrade to upgrade): markdown==2.2.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 54))
Requirement already satisfied (use --upgrade to upgrade): amqp==1.4.7 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 55))
Requirement already satisfied (use --upgrade to upgrade): amqplib==1.0.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 56))
Requirement already satisfied (use --upgrade to upgrade): sqlagg==0.7.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 57))
Requirement already satisfied (use --upgrade to upgrade): django-redis==4.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 58))
Requirement already satisfied (use --upgrade to upgrade): redis==2.10.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 59))
Requirement already satisfied (use --upgrade to upgrade): twilio==3.6.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 61))
Requirement already satisfied (use --upgrade to upgrade): django-countries==3.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 62))
Requirement already satisfied (use --upgrade to upgrade): reportlab==3.0 in /usr/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 63))
Requirement already satisfied (use --upgrade to upgrade): stripe==1.12.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 64))
Requirement already satisfied (use --upgrade to upgrade): django-compressor==1.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 65))
Requirement already satisfied (use --upgrade to upgrade): django-angular==0.7.8 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 66))
Requirement already satisfied (use --upgrade to upgrade): Pycco==0.3.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 67))
Requirement already satisfied (use --upgrade to upgrade): django-mptt==0.7.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 68))
Requirement already satisfied (use --upgrade to upgrade): jsonpath-rw==1.4.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 69))
Requirement already satisfied (use --upgrade to upgrade): pip>=6.1.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 70))
Requirement already satisfied (use --upgrade to upgrade): Pygments==2.0.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 72))
Requirement already satisfied (use --upgrade to upgrade): tinys3==0.1.11 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 73))
Requirement already satisfied (use --upgrade to upgrade): django-two-factor-auth==1.2.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 74))

*** datadog ***

Requirement already satisfied (use --upgrade to upgrade): datadog==0.10.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 75))

*** datadog ***

Requirement already satisfied (use --upgrade to upgrade): django-websocket-redis==0.4.6 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 76))
Requirement already satisfied (use --upgrade to upgrade): django-redis-sessions==0.5.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 77))
Requirement already satisfied (use --upgrade to upgrade): django-uuidfield==0.5.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 78))
Requirement already satisfied (use --upgrade to upgrade): SQLAlchemy==1.0.9 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 80))
Requirement already satisfied (use --upgrade to upgrade): alembic==0.6.4 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 81))
Requirement already satisfied (use --upgrade to upgrade): pyzxcvbn from git+git://github.com/dimagi/pyzxcvbn.git#egg=pyzxcvbn in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 82))
Requirement already satisfied (use --upgrade to upgrade): django-statici18n==1.1.5 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 83))
Requirement already satisfied (use --upgrade to upgrade): django-simple-captcha==0.5.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 84))
Requirement already satisfied (use --upgrade to upgrade): httpagentparser==1.7.8 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 85))
Requirement already satisfied (use --upgrade to upgrade): boto3==1.2.3 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 86))
Requirement already satisfied (use --upgrade to upgrade): simpleeval==0.8.7 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 87))
Requirement already satisfied (use --upgrade to upgrade): laboratory==0.2.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 88))
Requirement already satisfied (use --upgrade to upgrade): ConcurrentLogHandler==0.9.1 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 89))
Requirement already satisfied (use --upgrade to upgrade): github3.py==1.0.0a4 in /usr/local/lib/python2.7/dist-packages (from -r requirements/requirements.txt (line 90))
Requirement already satisfied (use --upgrade to upgrade): http-parser>=0.8.3 in /usr/local/lib/python2.7/dist-packages (from restkit==4.2.2->-r requirements/requirements.txt (line 3))
Requirement already satisfied (use --upgrade to upgrade): kombu<3.1,>=3.0.25 in /usr/local/lib/python2.7/dist-packages (from celery==3.1.18->-r requirements/requirements.txt (line 7))
Requirement already satisfied (use --upgrade to upgrade): billiard<3.4,>=3.3.0.20 in /usr/local/lib/python2.7/dist-packages (from celery==3.1.18->-r requirements/requirements.txt (line 7))
Requirement already satisfied (use --upgrade to upgrade): urllib3 in /usr/lib/python2.7/dist-packages (from dropbox==2.2.0->-r requirements/requirements.txt (line 14))
Requirement already satisfied (use --upgrade to upgrade): python-mimeparse!=1.5,>=0.1.4 in /usr/local/lib/python2.7/dist-packages (from django-tastypie==0.13.3->-r requirements/requirements.txt (line 17))
Requirement already satisfied (use --upgrade to upgrade): ply in /usr/local/lib/python2.7/dist-packages (from eulxml==0.18.0->-r requirements/requirements.txt (line 22))
Requirement already satisfied (use --upgrade to upgrade): chardet in /usr/lib/python2.7/dist-packages (from ghdiff==0.4->-r requirements/requirements.txt (line 24))
Requirement already satisfied (use --upgrade to upgrade): jdcal in /usr/local/lib/python2.7/dist-packages (from openpyxl==2.2.5->-r requirements/requirements.txt (line 29))
Requirement already satisfied (use --upgrade to upgrade): xlwt>=0.7.2 in /usr/local/lib/python2.7/dist-packages (from xlutils==1.4.1->-r requirements/requirements.txt (line 44))
Requirement already satisfied (use --upgrade to upgrade): errorhandler in /usr/local/lib/python2.7/dist-packages (from xlutils==1.4.1->-r requirements/requirements.txt (line 44))
Requirement already satisfied (use --upgrade to upgrade): msgpack-python>=0.4.6 in /usr/local/lib/python2.7/dist-packages (from django-redis==4.2->-r requirements/requirements.txt (line 58))
Requirement already satisfied (use --upgrade to upgrade): httplib2>=0.7 in /usr/local/lib/python2.7/dist-packages (from twilio==3.6.4->-r requirements/requirements.txt (line 61))
Requirement already satisfied (use --upgrade to upgrade): unittest2 in /usr/local/lib/python2.7/dist-packages (from twilio==3.6.4->-r requirements/requirements.txt (line 61))
Requirement already satisfied (use --upgrade to upgrade): django-appconf>=0.4 in /usr/local/lib/python2.7/dist-packages (from django-compressor==1.4->-r requirements/requirements.txt (line 65))
Requirement already satisfied (use --upgrade to upgrade): smartypants in /usr/local/lib/python2.7/dist-packages (from Pycco==0.3.0->-r requirements/requirements.txt (line 67))
Requirement already satisfied (use --upgrade to upgrade): pystache in /usr/local/lib/python2.7/dist-packages (from Pycco==0.3.0->-r requirements/requirements.txt (line 67))
Requirement already satisfied (use --upgrade to upgrade): futures>=2.1.3 in /usr/local/lib/python2.7/dist-packages (from tinys3==0.1.11->-r requirements/requirements.txt (line 73))
Requirement already satisfied (use --upgrade to upgrade): django-otp<0.3.99,>=0.2.0 in /usr/local/lib/python2.7/dist-packages (from django-two-factor-auth==1.2.2->-r requirements/requirements.txt (line 74))
Requirement already satisfied (use --upgrade to upgrade): qrcode<4.99,>=4.0.0 in /usr/local/lib/python2.7/dist-packages (from django-two-factor-auth==1.2.2->-r requirements/requirements.txt (line 74))
Requirement already satisfied (use --upgrade to upgrade): setuptools in /usr/local/lib/python2.7/dist-packages (from django-websocket-redis==0.4.6->-r requirements/requirements.txt (line 76))
Requirement already satisfied (use --upgrade to upgrade): Mako in /usr/local/lib/python2.7/dist-packages (from alembic==0.6.4->-r requirements/requirements.txt (line 81))
Requirement already satisfied (use --upgrade to upgrade): jmespath<1.0.0,>=0.7.1 in /usr/local/lib/python2.7/dist-packages (from boto3==1.2.3->-r requirements/requirements.txt (line 86))
Requirement already satisfied (use --upgrade to upgrade): botocore<1.4.0,>=1.3.0 in /usr/local/lib/python2.7/dist-packages (from boto3==1.2.3->-r requirements/requirements.txt (line 86))
Requirement already satisfied (use --upgrade to upgrade): pyasn1; python_version <= "2.7" in /usr/local/lib/python2.7/dist-packages (from github3.py==1.0.0a4->-r requirements/requirements.txt (line 90))
Requirement already satisfied (use --upgrade to upgrade): uritemplate.py>=0.2.0 in /usr/local/lib/python2.7/dist-packages (from github3.py==1.0.0a4->-r requirements/requirements.txt (line 90))
Requirement already satisfied (use --upgrade to upgrade): ndg-httpsclient; python_version <= "2.7" in /usr/local/lib/python2.7/dist-packages (from github3.py==1.0.0a4->-r requirements/requirements.txt (line 90))
Requirement already satisfied (use --upgrade to upgrade): pyOpenSSL>=0.13; python_version <= "2.7" in /usr/local/lib/python2.7/dist-packages (from github3.py==1.0.0a4->-r requirements/requirements.txt (line 90))
Requirement already satisfied (use --upgrade to upgrade): anyjson>=0.3.3 in /usr/local/lib/python2.7/dist-packages (from kombu<3.1,>=3.0.25->celery==3.1.18->-r requirements/requirements.txt (line 7))
Requirement already satisfied (use --upgrade to upgrade): argparse in /usr/lib/python2.7 (from unittest2->twilio==3.6.4->-r requirements/requirements.txt (line 61))
Requirement already satisfied (use --upgrade to upgrade): traceback2 in /usr/local/lib/python2.7/dist-packages (from unittest2->twilio==3.6.4->-r requirements/requirements.txt (line 61))
Requirement already satisfied (use --upgrade to upgrade): MarkupSafe>=0.9.2 in /usr/local/lib/python2.7/dist-packages (from Mako->alembic==0.6.4->-r requirements/requirements.txt (line 81))
Requirement already satisfied (use --upgrade to upgrade): docutils>=0.10 in /usr/local/lib/python2.7/dist-packages (from botocore<1.4.0,>=1.3.0->boto3==1.2.3->-r requirements/requirements.txt (line 86))
Requirement already satisfied (use --upgrade to upgrade): cryptography>=1.3 in /usr/local/lib/python2.7/dist-packages (from pyOpenSSL>=0.13; python_version <= "2.7"->github3.py==1.0.0a4->-r requirements/requirements.txt (line 90))
Requirement already satisfied (use --upgrade to upgrade): linecache2 in /usr/local/lib/python2.7/dist-packages (from traceback2->unittest2->twilio==3.6.4->-r requirements/requirements.txt (line 61))
Requirement already satisfied (use --upgrade to upgrade): idna>=2.0 in /usr/local/lib/python2.7/dist-packages (from cryptography>=1.3->pyOpenSSL>=0.13; python_version <= "2.7"->github3.py==1.0.0a4->-r requirements/requirements.txt (line 90))
Requirement already satisfied (use --upgrade to upgrade): enum34 in /usr/local/lib/python2.7/dist-packages (from cryptography>=1.3->pyOpenSSL>=0.13; python_version <= "2.7"->github3.py==1.0.0a4->-r requirements/requirements.txt (line 90))
Requirement already satisfied (use --upgrade to upgrade): ipaddress in /usr/local/lib/python2.7/dist-packages (from cryptography>=1.3->pyOpenSSL>=0.13; python_version <= "2.7"->github3.py==1.0.0a4->-r requirements/requirements.txt (line 90))
Requirement already satisfied (use --upgrade to upgrade): cffi>=1.4.1 in /usr/local/lib/python2.7/dist-packages (from cryptography>=1.3->pyOpenSSL>=0.13; python_version <= "2.7"->github3.py==1.0.0a4->-r requirements/requirements.txt (line 90))
Requirement already satisfied (use --upgrade to upgrade): pycparser in /usr/local/lib/python2.7/dist-packages (from cffi>=1.4.1->cryptography>=1.3->pyOpenSSL>=0.13; python_version <= "2.7"->github3.py==1.0.0a4->-r requirements/requirements.txt (line 90))
Building wheels for collected packages: pygooglechart
  Running setup.py bdist_wheel for pygooglechart ... done
  Stored in directory: /root/.cache/pip/wheels/42/d2/3a/9f942ec0bf976ebacb0dfd3c91684a61bd94ea9ff84caeb037
Successfully built pygooglechart
demo@demo:~/Downloads/commcare-hq$



---------------------------------------------

Dante Castiglione Maldonado

https://uy.linkedin.com/in/dantecastiglione
---------------------------------------------


William Pride

unread,
Jun 17, 2016, 12:01:38 AM6/17/16
to commcare-...@googlegroups.com
Dante,

Have you tried installing the dependencies inside a virtualenv? This might resolve your issue and has the added benefit of not needing to run pip install as root.

-Will

Dante Castiglione M.

unread,
Jun 17, 2016, 9:10:21 AM6/17/16
to commcare-...@googlegroups.com
Yes, I did, but in any case, I was *not* using python in this machine. I just installed it for running commcare-hq, and as a matter of fact, I have never used datadog before.

So, if there are any conflicts, they are all caused by commcare-hq dependencies, not by any other things I do, which I do none with python.




---------------------------------------------

Dante Castiglione Maldonado

https://uy.linkedin.com/in/dantecastiglione
---------------------------------------------


Dante Castiglione M.

unread,
Jun 17, 2016, 10:17:12 PM6/17/16
to commcare-...@googlegroups.com
ipython says datadog is installed... and has no problem importing it... but manage.py won't run because it cannot import it.


In [1]: import datadog

In [2]: print datadog
<module 'datadog' from '/usr/local/lib/python2.7/dist-packages/datadog/__init__.pyc'>

In [3]: exit
demo@demo:~/Downloads/commcare-hq$ ./manage.py celeryd --settings=settings

corehq.util.log.HqAdminEmailHandler logger is being changed to logging.StreamHandler
corehq.util.log.NotifyExceptionEmailer logger is being changed to logging.StreamHandler
Traceback (most recent call last):
  File "./manage.py", line 96, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 385, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 354, in execute
    django.setup()
  File "/usr/local/lib/python2.7/dist-packages/django/__init__.py", line 20, in setup
    configure_logging(settings.LOGGING_CONFIG, settings.LOGGING)
  File "/usr/local/lib/python2.7/dist-packages/django/utils/log.py", line 87, in configure_logging

    logging_config_func(logging_settings)
  File "/usr/lib/python2.7/logging/config.py", line 794, in dictConfig
    dictConfigClass(config).configure()
  File "/usr/lib/python2.7/logging/config.py", line 559, in configure
    'filter %r: %s' % (name, e))
ValueError: Unable to configure filter 'hqcontext': Cannot resolve 'corehq.util.log.HQRequestFilter': cannot import name DatadogException



---------------------------------------------

Dante Castiglione Maldonado

https://uy.linkedin.com/in/dantecastiglione
---------------------------------------------


Cory Zue

unread,
Jun 18, 2016, 6:36:48 AM6/18/16
to commcare-developers
Hey Dante,

Just a guess but you might have a different python interpreter setup. You can put "python" or "ipython" before the manage.py to be consistent with however you're loading it where you are able to successfully import it.

Also, just a quick note that CommCare HQ is quite a complex and difficult project to setup and maintain. I'm not sure what you're doing with it, but if you don't have a lot of experience with python you might want to consider looking into our hosted options which also have a completely free tier.

thanks,
Cory

Dante Castiglione M.

unread,
Jun 18, 2016, 9:14:52 AM6/18/16
to commcare-...@googlegroups.com
This is my environment:

demo@demo:~$ cd Downloads
demo@demo:~/Downloads$ cd commcare-hq

demo@demo:~/Downloads/commcare-hq$ python --version
Python 2.7.6

demo@demo:~/Downloads/commcare-hq$ ipython --version
/usr/lib/python2.7/dist-packages/IPython/utils/path.py:297: UserWarning: IPython dir '/home/demo/.config/ipython' is not a writable location, using a temp directory.
  " using a temp directory."%ipdir)
1.2.1

-----------------------------------------------

Running as before:

demo@demo:~/Downloads/commcare-hq$ ./manage.py celeryd --settings=settings
corehq.util.log.HqAdminEmailHandler logger is being changed to logging.StreamHandler
corehq.util.log.NotifyExceptionEmailer logger is being changed to logging.StreamHandler
Traceback (most recent call last):
  File "./manage.py", line 96, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 385, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 354, in execute
    django.setup()
  File "/usr/local/lib/python2.7/dist-packages/django/__init__.py", line 20, in setup
    configure_logging(settings.LOGGING_CONFIG, settings.LOGGING)
  File "/usr/local/lib/python2.7/dist-packages/django/utils/log.py", line 87, in configure_logging
    logging_config_func(logging_settings)
  File "/usr/lib/python2.7/logging/config.py", line 794, in dictConfig
    dictConfigClass(config).configure()
  File "/usr/lib/python2.7/logging/config.py", line 559, in configure
    'filter %r: %s' % (name, e))
ValueError: Unable to configure filter 'hqcontext': Cannot resolve 'corehq.util.log.HQRequestFilter': cannot import name DatadogException

-----------------------------------------------

Running with python:

demo@demo:~/Downloads/commcare-hq$ python ./manage.py celeryd --settings=settings

corehq.util.log.HqAdminEmailHandler logger is being changed to logging.StreamHandler
corehq.util.log.NotifyExceptionEmailer logger is being changed to logging.StreamHandler
Traceback (most recent call last):
  File "./manage.py", line 96, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 385, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 354, in execute
    django.setup()
  File "/usr/local/lib/python2.7/dist-packages/django/__init__.py", line 20, in setup
    configure_logging(settings.LOGGING_CONFIG, settings.LOGGING)
  File "/usr/local/lib/python2.7/dist-packages/django/utils/log.py", line 87, in configure_logging
    logging_config_func(logging_settings)
  File "/usr/lib/python2.7/logging/config.py", line 794, in dictConfig
    dictConfigClass(config).configure()
  File "/usr/lib/python2.7/logging/config.py", line 559, in configure
    'filter %r: %s' % (name, e))
ValueError: Unable to configure filter 'hqcontext': Cannot resolve 'corehq.util.log.HQRequestFilter': cannot import name DatadogException

-----------------------------------------------

Running with ipython:

demo@demo:~/Downloads/commcare-hq$ ipython ./manage.py celeryd --settings=settings
/usr/lib/python2.7/dist-packages/IPython/utils/path.py:297: UserWarning: IPython dir '/home/demo/.config/ipython' is not a writable location, using a temp directory.
  " using a temp directory."%ipdir)

WARNING: Unrecognized alias: 'settings', it will probably have no effect.


corehq.util.log.HqAdminEmailHandler logger is being changed to logging.StreamHandler
corehq.util.log.NotifyExceptionEmailer logger is being changed to logging.StreamHandler

ValueError                                Traceback (most recent call last)
/usr/lib/python2.7/dist-packages/IPython/utils/py3compat.pyc in execfile(fname, *where)
    202             else:
    203                 filename = fname
--> 204             __builtin__.execfile(filename, *where)

/home/demo/Downloads/commcare-hq/manage.py in <module>()
     94     set_default_settings_path(sys.argv)
     95     from django.core.management import execute_from_command_line
---> 96     execute_from_command_line(sys.argv)

/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.pyc in execute_from_command_line(argv)
    383     """
    384     utility = ManagementUtility(argv)
--> 385     utility.execute()

/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.pyc in execute(self)
    352
    353         if settings.configured:
--> 354             django.setup()
    355
    356         self.autocomplete()

/usr/local/lib/python2.7/dist-packages/django/__init__.pyc in setup()
     18     from django.utils.log import configure_logging
     19
---> 20     configure_logging(settings.LOGGING_CONFIG, settings.LOGGING)
     21     apps.populate(settings.INSTALLED_APPS)

/usr/local/lib/python2.7/dist-packages/django/utils/log.pyc in configure_logging(logging_config, logging_settings)
     85         # ... then invoke it with the logging settings
     86         if logging_settings:
---> 87             logging_config_func(logging_settings)
     88
     89

/usr/lib/python2.7/logging/config.pyc in dictConfig(config)
    792 def dictConfig(config):
    793     """Configure logging using a dictionary."""
--> 794     dictConfigClass(config).configure()
    795
    796

/usr/lib/python2.7/logging/config.pyc in configure(self)
    557                     except StandardError as e:
    558                         raise ValueError('Unable to configure '
--> 559                                          'filter %r: %s' % (name, e))
    560
    561                 # Next, do handlers - they refer to formatters and filters


ValueError: Unable to configure filter 'hqcontext': Cannot resolve 'corehq.util.log.HQRequestFilter': cannot import name DatadogException


It does exactly the same.
The only difference is this warning:

WARNING: Unrecognized alias: 'settings', it will probably have no effect.

While not an expert, I got some python experience.
My client wants to run his own server, so am just doing that.





---------------------------------------------

Dante Castiglione Maldonado

https://uy.linkedin.com/in/dantecastiglione
---------------------------------------------


Dante Castiglione

unread,
Jun 24, 2016, 10:46:29 PM6/24/16
to CommCare Developers

Well, I found the problem after some trying.
My client had asked me to use Lubuntu 14.04 and I innocently did.
But when I asked him why, he could give no reason.
So I tried setting up a new VM using Lubuntu 16.04, it worked fine.
Problem was python version, as someone had kindly pointed (just cannot find the post to name you now but thank you anyway).
Now that is solved and I could run manage.py decently.

But while following with installation I got some new error:


1. while bootstraping a project, I got the following error:

root@demo:~/commcare-hq# ./manage.py bootstrap demo john...@some-site.com demo

corehq.util.log.HqAdminEmailHandler logger is being changed to logging.StreamHandler
corehq.util.log.NotifyExceptionEmailer logger is being changed to logging.StreamHandler
2016-06-24 01:43:36,967 INFO Starting new HTTP connection (1): trk.kissmetrics.com
2016-06-24 01:43:39,006 INFO Starting new HTTP connection (1): localhost
2016-06-24 01:43:39,314 INFO Starting new HTTP connection (1): localhost
Notify Exception: Error occured while syncing user john...@some-site.com: HTTPError(u'401 Client Error: Unauthorized for url: https://api.hubapi.com/contacts/v1/contact/email/john.doe%40some-site.com/profile?hapikey=%2A%2A%2A%2A%2A',)
None
2016-06-24 01:43:42,294 ERROR Notify Exception: Error occured while syncing user john...@some-site.com: HTTPError(u'401 Client Error: Unauthorized for url: https://api.hubapi.com/contacts/v1/contact/email/john.doe%some-site.com/profile?hapikey=%2A%2A%2A%2A%2A',)
None
user john...@some-site.com created and added to domain demo
root@demo:~/commcare-hq#


Not sure how important this is, but my client created an account in that site, then I created a contact using curl and an example from the site. The API responded with a user ID so it does look as it has worked ok.
If I try to run bootstrap again it serves the same error.


2.

When trying to create the elasticsearch indexes I got two errors.
Not sure what they mean.
Am using 1.7.4 because the instructions I got said to do so (are they too old?)

Thanks in advance for any help.



This is the first error:

demo@demo:~/commcare-hq$ ./manage.py run_ptop --pillow-key=core

corehq.util.log.HqAdminEmailHandler logger is being changed to logging.StreamHandler
corehq.util.log.NotifyExceptionEmailer logger is being changed to logging.StreamHandler
2016-06-24 01:00:21,685 INFO Starting new HTTP connection (1): localhost
2016-06-24 01:00:21,718 INFO Starting new HTTP connection (2): localhost
2016-06-24 01:00:21,719 INFO Starting new HTTP connection (3): localhost
2016-06-24 01:00:21,720 INFO Starting new HTTP connection (4): localhost

Traceback (most recent call last):
  File "./manage.py", line 96, in <module>
    execute_from_command_line(sys.argv)
  File "/home/demo/.local/lib/python2.7/site-packages/django/core/management/__init__.py", line 385, in execute_from_command_line
    utility.execute()
  File "/home/demo/.local/lib/python2.7/site-packages/django/core/management/__init__.py", line 377, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/home/demo/.local/lib/python2.7/site-packages/django/core/management/base.py", line 288, in run_from_argv
    self.execute(*args, **options.__dict__)
  File "/home/demo/.local/lib/python2.7/site-packages/django/core/management/base.py", line 338, in execute
    output = self.handle(*args, **options)
  File "/home/demo/.local/lib/python2.7/site-packages/django/core/management/base.py", line 533, in handle
    return self.handle_noargs(**options)
  File "./corehq/ex-submodules/pillowtop/management/commands/run_ptop.py", line 80, in handle_noargs
    start_pillows(pillows=[pillow_config.get_instance() for pillow_config in pillows_to_run])
  File "./corehq/ex-submodules/pillowtop/utils.py", line 63, in get_instance
    return get_pillow_instance(self.class_name)
  File "./corehq/ex-submodules/pillowtop/utils.py", line 22, in get_pillow_instance
    return pillow_class()
  File "./corehq/ex-submodules/pillowtop/listener.py", line 416, in __init__
    completely_initialize_pillow_index(self)
  File "./corehq/ex-submodules/pillowtop/es_utils.py", line 68, in completely_initialize_pillow_index
    return initialize_index_and_mapping(pillow.get_es_new(), get_index_info_from_pillow(pillow))
  File "./corehq/ex-submodules/pillowtop/es_utils.py", line 72, in initialize_index_and_mapping
    index_exists = es.indices.exists(index_info.index)
  File "/home/demo/.local/lib/python2.7/site-packages/elasticsearch/client/utils.py", line 69, in _wrapped
    return func(*args, params=params, **kwargs)
  File "/home/demo/.local/lib/python2.7/site-packages/elasticsearch/client/indices.py", line 224, in exists
    params=params)
  File "/home/demo/.local/lib/python2.7/site-packages/elasticsearch/transport.py", line 307, in perform_request
    status, headers, data = connection.perform_request(method, url, params, body, ignore=ignore, timeout=timeout)
  File "/home/demo/.local/lib/python2.7/site-packages/elasticsearch/connection/http_urllib3.py", line 89, in perform_request
    raise ConnectionError('N/A', str(e), e)
elasticsearch.exceptions.ConnectionError: ConnectionError(<urllib3.connection.HTTPConnection object at 0x7fe780bef3d0>: Failed to establish a new connection: [Errno 111] Connection refused) caused by: NewConnectionError(<urllib3.connection.HTTPConnection object at 0x7fe780bef3d0>: Failed to establish a new connection: [Errno 111] Connection refused)


And this is the second error:

demo@demo:~/commcare-hq$ ./manage.py ptop_es_manage --flip_all_aliases

corehq.util.log.HqAdminEmailHandler logger is being changed to logging.StreamHandler
corehq.util.log.NotifyExceptionEmailer logger is being changed to logging.StreamHandler
2016-06-25 02:27:52,261 INFO Starting new HTTP connection (1): localhost
2016-06-25 02:27:52,321 INFO Starting new HTTP connection (2): localhost
2016-06-25 02:27:52,322 INFO Starting new HTTP connection (3): localhost
2016-06-25 02:27:52,322 INFO Starting new HTTP connection (4): localhost

Traceback (most recent call last):
  File "./manage.py", line 96, in <module>
    execute_from_command_line(sys.argv)
  File "/home/demo/.local/lib/python2.7/site-packages/django/core/management/__init__.py", line 385, in execute_from_command_line
    utility.execute()
  File "/home/demo/.local/lib/python2.7/site-packages/django/core/management/__init__.py", line 377, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/home/demo/.local/lib/python2.7/site-packages/django/core/management/base.py", line 288, in run_from_argv
    self.execute(*args, **options.__dict__)
  File "/home/demo/.local/lib/python2.7/site-packages/django/core/management/base.py", line 338, in execute
    output = self.handle(*args, **options)
  File "./corehq/ex-submodules/pillowtop/management/commands/ptop_es_manage.py", line 57, in handle
    assume_alias(es, index_info.index, index_info.alias)
  File "./corehq/ex-submodules/pillowtop/es_utils.py", line 119, in assume_alias
    if es.indices.exists_alias(None, alias):
  File "/home/demo/.local/lib/python2.7/site-packages/elasticsearch/client/utils.py", line 69, in _wrapped
    return func(*args, params=params, **kwargs)
  File "/home/demo/.local/lib/python2.7/site-packages/elasticsearch/client/indices.py", line 407, in exists_alias
    name), params=params)
  File "/home/demo/.local/lib/python2.7/site-packages/elasticsearch/transport.py", line 307, in perform_request
    status, headers, data = connection.perform_request(method, url, params, body, ignore=ignore, timeout=timeout)
  File "/home/demo/.local/lib/python2.7/site-packages/elasticsearch/connection/http_urllib3.py", line 89, in perform_request
    raise ConnectionError('N/A', str(e), e)
elasticsearch.exceptions.ConnectionError: ConnectionError(<urllib3.connection.HTTPConnection object at 0x7f84dd49e5d0>: Failed to establish a new connection: [Errno 111] Connection refused) caused by: NewConnectionError(<urllib3.connection.HTTPConnection object at 0x7f84dd49e5d0>: Failed to establish a new connection: [Errno 111] Connection refused)
demo@demo:~/commcare-hq$


*** end of post ***

Message has been deleted

Cory Zue

unread,
Jun 27, 2016, 1:06:01 PM6/27/16
to commcare-developers
Hey,

At first glance it looks like maybe your authentication for Elasticsearch isn't setup correctly. I would check those settings, make sure elasticsearch is running, and make sure that you can read/write to it from the app.

thanks,
Cory

Dante Castiglione M.

unread,
Jun 27, 2016, 10:15:49 PM6/27/16
to commcare-...@googlegroups.com
Thanks for your kind answer Cory.

I know how to configure elasticsearch, but I cannot find *almost any information about how it should be configured for commcare-hq.

I have checked on-line, read-the-docs, and the documentation folder. All I have found are a couple comments about changing some defaults, but nothing about which users is commcare-hq using and which users should be created in elasticsearch.

Would you (or anybody else) be some kind as to provide me or point me to some info about this?

Thanks in advance.


 


---------------------------------------------

Dante Castiglione Maldonado

https://uy.linkedin.com/in/dantecastiglione
---------------------------------------------


--

---
You received this message because you are subscribed to a topic in the Google Groups "CommCare Developers" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/commcare-developers/xDcVqO8LuZQ/unsubscribe.
To unsubscribe from this group and all its topics, send an email to commcare-develo...@googlegroups.com.

Dante Castiglione M.

unread,
Jun 27, 2016, 10:43:30 PM6/27/16
to commcare-...@googlegroups.com
Further information:

1. health

root@demo:~/commcare-hq# curl -XGET localhost:9200/_cluster/health

{"cluster_name":"elasticsearch","status":"yellow","timed_out":false,
"number_of_nodes":1,"number_of_data_nodes":1,"active_primary_shards":20,
"active_shards":20,"relocating_shards":0,"initializing_shards":0,
"unassigned_shards":5,"delayed_unassigned_shards":0,
"number_of_pending_tasks":0,"number_of_in_flight_fetch":0}

Health is yellow, but this is only one machine, so not sure if gotta do something about.

I also took some screenshots of my elasticsearch-head



---------------------------------------------

Dante Castiglione Maldonado

https://uy.linkedin.com/in/dantecastiglione
---------------------------------------------


Screenshot from 2016-06-27 23-34-25.png
Screenshot from 2016-06-27 23-34-34.png
Screenshot from 2016-06-27 23-35-07.png
Reply all
Reply to author
Forward
0 new messages