CometD 5.0.0 Released

22 views
Skip to first unread message

Simone Bordet

unread,
Apr 16, 2020, 7:56:28 AM4/16/20
to cometd-users, cometd-dev
Hi,

CometD 5.0.0 has been released.

CometD 5 requires Java 8 and Jetty 9.4.x.

CometD 5 restructured a number of artifacts for better compatibility with JPMS.
Furthermore, it implements a HTTP client transport based on OkHttp,
which allows for better support in Android and provides an alternative
to the Jetty HttpClient transport (and possibly other transports based
on other HTTP client libraries).

A number of deprecated classes and methods have been removed, so it
may be possible that your applications need a bit of work to compile
again with CometD 5, but we don't expect to be much work, especially
if you were already using CometD 4.

To fix the breaking changes, please follow the migration guide:
https://docs.cometd.org/current/reference/#_migration_40_to_50

For commercial support, please see:
https://docs.cometd.org/current/reference/#_support

Enjoy!

--
Simone Bordet
----
http://cometd.org
http://webtide.com
Developer advice, training, services and support
from the Jetty & CometD experts.
Reply all
Reply to author
Forward
0 new messages