[CommandBox 5.2.0+00280][Lucee 5.3.7.47] Datasource not being persisted on server restart

6 views
Skip to first unread message

Harkirat

unread,
Dec 5, 2020, 5:21:13 PM12/5/20
to ColdBox Platform
I am having an issue where after I restart the lucee server via commandbox my datasources get deleted. All other settings e.g. mail etc  appear to be persisted.

I also seem to have a rogue datasource 'Other - JDBC Driver (deprecated)' listed there which I did not add and can not delete either.


Any suggestions on whats going on here?

Brad Wood

unread,
Dec 5, 2020, 5:50:27 PM12/5/20
to col...@googlegroups.com
I'd guess you have a .cfconfig json file that's getting auto-imported on every start.

--
--
You received this message because you are subscribed to the Google Groups "ColdBox Platform" group.
For News, visit http://blog.coldbox.org
For Documentation, visit http://wiki.coldbox.org
For Bug Reports, visit https://ortussolutions.atlassian.net/browse/COLDBOX
---
You received this message because you are subscribed to the Google Groups "ColdBox Platform" group.
To unsubscribe from this group and stop receiving emails from it, send an email to coldbox+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/coldbox/b62ae8c2-024f-4bd5-b923-959a4f8ed1bcn%40googlegroups.com.

Harkirat Singh

unread,
Dec 5, 2020, 7:03:03 PM12/5/20
to col...@googlegroups.com
Looks like the issue originated after I installed the CFConfig addon for Commandbox. Didn't realize it would override the web UI and fore everything via command line. I uninstalled it and it works fine now.


You received this message because you are subscribed to a topic in the Google Groups "ColdBox Platform" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/coldbox/zXKF60I2DaI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to coldbox+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/coldbox/CALbQ1omhHK-gBhHa_69Rrs-eKpfB0NFgApbjaL8rOG0L9yctuA%40mail.gmail.com.

Brad Wood

unread,
Dec 5, 2020, 7:18:11 PM12/5/20
to col...@googlegroups.com
You don't need to uninstall it. Just remove the cfconfig.json that has the settings you don't want.

Harkirat Singh

unread,
Dec 5, 2020, 7:27:22 PM12/5/20
to col...@googlegroups.com
I can't find that file anywhere on my Mac system including the webroot. Where is it located? 

Brad Wood

unread,
Dec 5, 2020, 7:33:24 PM12/5/20
to col...@googlegroups.com
It would be in the web root by default. Easy to tell. Just do a --debug start and look for "Config Transferred" in the logs.  That's the message when CFConfig auto imports a config file.

Harkirat Singh

unread,
Dec 5, 2020, 8:34:21 PM12/5/20
to col...@googlegroups.com
Thanks that helped. Turns out it was in the webroot as a hidden file. Deleting it fixed the issue.

Reply all
Reply to author
Forward
0 new messages