Install CDT not working for me

73 views
Skip to first unread message

cente...@gmail.com

unread,
Oct 22, 2016, 9:47:51 PM10/22/16
to Cocotron Developers

I'm on el crapitan, with gcc49 installed w/homebrew, everything stops when compiling GMP with the following error:

gcc `test -f 'gen-bases.c' || echo '/Developer/Cocotron/1.0/Source/gmp-4.2.3/'`gen-bases.c -o gen-bases 

/var/folders/0d/t1lhmbq51gdb0mtjjnjjglt40000gn/T//cczLGFC1.s:2769:suffix or operands invalid for `movq'

/var/folders/0d/t1lhmbq51gdb0mtjjnjjglt40000gn/T//cczLGFC1.s:2770:suffix or operands invalid for `movq'

/var/folders/0d/t1lhmbq51gdb0mtjjnjjglt40000gn/T//cczLGFC1.s:2772:suffix or operands invalid for `movq'

/var/folders/0d/t1lhmbq51gdb0mtjjnjjglt40000gn/T//cczLGFC1.s:2774:suffix or operands invalid for `movq'

/var/folders/0d/t1lhmbq51gdb0mtjjnjjglt40000gn/T//cczLGFC1.s:2775:suffix or operands invalid for `movq'

/var/folders/0d/t1lhmbq51gdb0mtjjnjjglt40000gn/T//cczLGFC1.s:2777:suffix or operands invalid for `movq'

/var/folders/0d/t1lhmbq51gdb0mtjjnjjglt40000gn/T//cczLGFC1.s:3049:suffix or operands invalid for `movq'

/var/folders/0d/t1lhmbq51gdb0mtjjnjjglt40000gn/T//cczLGFC1.s:3060:suffix or operands invalid for `movq'

make: *** [gen-bases] Error 1


Any ideas where/how to fix?

Any information would be much appreciated..

Thanks,

Rand


Sebosac Scott

unread,
Oct 27, 2016, 10:03:26 AM10/27/16
to Cocotron Developers, cente...@gmail.com

Hi, someone working on this to purpose a more reliable InstallCDT and patches on github, cause more peoples encounter problems and more underlaying troubles with new system versus COCOTRON old URLs

Seems more pull request in standby and this is prometing... More graphical and stable solution in progress ...

Stay tuned and See Nigthly Build (just progress stuff you can leave comments on ) on github :  https://github.com/genose/genose-port-contrib-cocotron

Regards

cente...@gmail.com

unread,
Oct 27, 2016, 4:40:00 PM10/27/16
to Cocotron Developers, cente...@gmail.com

This is awesome!  I'm planning on using it quite a bit, if all goes well.

cente...@gmail.com

unread,
Oct 30, 2016, 5:18:55 PM10/30/16
to Cocotron Developers, cente...@gmail.com

I'm getting the same error with the new installer, except I don't seem to be able to find the binutils it is asking for, which I assume is a patched binutils.  I'm specifically looking for binutils-2.21-20111025, which isn't on the google code site.  Any ideas where I can find the beast or a patch?

Sebosac Scott

unread,
Nov 1, 2016, 3:55:25 PM11/1/16
to Cocotron Developers, cente...@gmail.com
That's already on nigthly build ...

but is not enougth to compile cause more problem still unsolved

Stay tuned on genose 's Github ...

Centesimiae LLC

unread,
Nov 1, 2016, 4:03:55 PM11/1/16
to Sebosac Scott, Cocotron Developers
Thanks.
Reply all
Reply to author
Forward
0 new messages