Xcode 5/6 support

237 views
Skip to first unread message

Christopher Lloyd

unread,
Mar 22, 2015, 10:46:10 PM3/22/15
to cocotr...@googlegroups.com
Attached is a new pbcompspec which works with Xcode 6.1, this goes in 

/Library/Application Support/Developer/Shared/Xcode/Specifications/Cocotron-1.0-Windows-i386-gcc-4.3.1.pbcompspec

I have updated/fixed the master branch for the appropriate build settings too. If you have the existing tools installed this should now work with Xcode 5 and 6. Let me know if you have any problems.



Cocotron-1.0-Windows-i386-gcc-4.3.1.pbcompspec

arix...@gmail.com

unread,
Mar 24, 2015, 7:57:23 AM3/24/15
to cocotr...@googlegroups.com
Awesome! Great to see this stuff active again.

Please let me know if there's a PayPal address we can use to support the project (the donate button on the website only allows donating $5 at a time!)

And please keep us updated on any developments around clang/newer Objective-C runtime stuff (auto-property synthesis/ARC/blocks). I got Apple's runtime to compile for Windows a few months ago but got distracted with other projects before I could try to put it to use. Would love to be able to delve back into it at some point.

Ari

Christopher Lloyd

unread,
Mar 24, 2015, 5:56:57 PM3/24/15
to cocotr...@googlegroups.com, arix...@gmail.com
Ah ha, that amount used to be editable :) The PayPal address is cocotron at gmail.com 

I'll be updating more often and keep people updated here.

Thanks!
Chris

Max C

unread,
May 29, 2015, 4:03:27 PM5/29/15
to cocotr...@googlegroups.com
On Monday, 23 March 2015 02:46:10 UTC, Christopher Lloyd wrote:
Attached is a new pbcompspec which works with Xcode 6.1, this goes in 

/Library/Application Support/Developer/Shared/Xcode/Specifications/Cocotron-1.0-Windows-i386-gcc-4.3.1.pbcompspec



I've created the corresponding version for Linux builds, attached (works for me at least, on Xcode 6.3.1). I had to add a couple of extra warning options at the end to get it to work.

Max
 
Cocotron-1.0-Linux-i386-gcc-4.3.1.pbcompspec

m...@max.tc

unread,
Sep 20, 2017, 8:07:59 AM9/20/17
to Cocotron Developers
And here it is updated for Xcode 9...
Cocotron-1.0-Linux-i386-gcc-4.3.1.pbcompspec
Reply all
Reply to author
Forward
0 new messages