Why do I get a ld:framework not found <frameworkName> during pod repo push?

26 views
Skip to first unread message

Jacob Varghese

unread,
May 17, 2021, 11:29:39 PM5/17/21
to CocoaPods
Hi,

I have a framework that I've built for iOS, dynamic framework with a Universal binary for x86_64 (iosSimulator), arm64 and arm64e.

The framework works fine when I drag it to an app and use it.

Pod repo push works fine when I using a repo on my machine that holds the framework and another specs repo that's on my machine. I created the repos with git init --bare

When I use github and point the spec to the github repo instead of my local repo it fails with `ld:framework not found <frameworkName>` . When I skip validation and push and and finally use it in an app using the pod file I get the same error, `ld:framework not found <frameworkName>`.

The only difference is I've moved from my local git repo that holds the framework to one on Github.

Would appreciate any help.

Thanks and Regards,
Jacob Varghese

agrawal...@gmail.com

unread,
May 18, 2021, 12:55:16 AM5/18/21
to CocoaPods
Did you try uploading it to any other cloud and using that link? Check if you getting the same error or is it with git only. 
Reply all
Reply to author
Forward
0 new messages