Install cmtk on Mac, version of libraries

33 views
Skip to first unread message

maryam tayebi

unread,
Mar 23, 2020, 5:14:57 PM3/23/20
to cmtk-users
Hi,

Does anyone know the version of python libraries that we need to have (i.e.traits, traitsui, pyface, nibabel, numpy, networkx, scipy)? 
Because I am trying to install this software but I get the error and the GUI does not show up properly, seems there is a problem with different versions of libraries I am using atm.

Thanks,
Mary


Sebastien Tourbier

unread,
Mar 24, 2020, 4:41:15 AM3/24/20
to cmtk-...@googlegroups.com
Hi Mary,

I do not know which version of CMP you are trying to install but it seems you are not trying to install the latest version of CMP (CMP3), which relies on a conda environment for the installation of all python dependencies (with fixed version) and on Docker container image technology which encapsulates the processing pipelines with all softwares (FSL, FreeSurfer,..) installed. CMP1 and CMP2 are now deprecated and no more maintained and supported.

Installation instructions are available here: https://connectome-mapper-3.readthedocs.io/en/latest/

Please note that I am suspecting that the latest released version (v3.0.0-beta-20200227) might have a bug in launching the docker image from the graphical user interface.
I am working on making a new version release with bug fixes in the very coming days so I would suggest you to wait for it.

Let you know as soon as the new version is released.

Best,
Sebastien

--
You received this message because you are subscribed to the Google Groups "cmtk-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cmtk-users+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/cmtk-users/b89f788e-ec62-4dc7-b94c-8859bdc8c936%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages