invalid BIDS dataset

14 views
Skip to first unread message

Isotta Rigoni

unread,
Apr 8, 2021, 1:23:36 PMApr 8
to cmtk-users
Hi everyone!
I am working in Linux and have installed the cmp3 and the installation seemed to work fine.
I created a dataset with only 3 subjects (anatomical and dwi) to test the software but, when using the GUI, it says that the dataset is invalid. However, I have tested it with the BIDS validator and it did not give any error.
Do you have any idea about why it would give me such error even fi the dataset is actually in bids?
Thanks a lot in advance!
Isotta

Sebastien Tourbier

unread,
Apr 9, 2021, 6:34:43 AMApr 9
to cmtk-...@googlegroups.com
Hi Isotta!

Sorry but to fully understand what could go wrong, I would need more details such as a copy of the complete output in the terminal and your version of CMP.

But what I can tell you for the moment is that the GUI depends on pybids (a python library to query BIDS dataset) and I suspect the error comes from there. What happens if you do in a terminal the following:

$ conda activate py37cmp-gui
(py37cmp-gui)$ python
>>from bids import BIDSLayout
>>layout = BIDSLayout('/path/to/your/bids/dataset')

Best,
Sebastien





--
You received this message because you are subscribed to the Google Groups "cmtk-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cmtk-users+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/cmtk-users/5e7fe469-0a7d-4f16-8312-64c9875c738bn%40googlegroups.com.

Isotta Rigoni

unread,
Apr 10, 2021, 10:22:10 AMApr 10
to cmtk-...@googlegroups.com
Hi Sebastien,
I am using the Connectome Mapper v3.0.0-RC4. I tried to import the BIDSLayout with the line you suggested and it worked.
As you suspected, the main problem was given by the GUI. Although I used the environment file you provided, tt did not manage to update the version of some of the derivatives that were already installed (for example, the installed version of pydicom was 2.1.2, while the required one is 2.0.0). After re-installing these packages one-by-one, the GUI works!
Thanks for the help!
Isotta

Reply all
Reply to author
Forward
0 new messages