Installation CmisSync on OpenSuse 13.1. fails

97 views
Skip to first unread message

gronny1

unread,
May 3, 2015, 6:40:58 PM5/3/15
to cmis...@googlegroups.com
Hi,
I'm trying hard to install the client on Opensuse 13.1. . Having installed all required packages, I thought my installation meets all dependencies :
gtk-sharp2 mono-core mono-devel monodevelop \
  ndesk-dbus-glib-devel nant desktop-file-utils \
  notify-sharp-devel webkit-sharp libwebkitgtk-devel libtool intltool make log4net
- git
- mono 4.0 , monodevelop 5
- nunit, nuget
- newtonsoft.json
even all corresponding devel-packages are installed ... I followed the Linux Installation Guide.

Makefile is successful, BUT " ./configure --with-dotcmis=Extras/DotCMIS.dll " fails, because he is missing newtonsoft-json .

gronny@notebook:~/bin/cmissync> ./configure --with-dotcmis=Extras/DotCMIS.dll
configure: loading site script /usr/share/site/x86_64-unknown-linux-gnu
checking build system type... x86_64-suse-linux-gnu
checking host system type... x86_64-suse-linux-gnu
checking target system type... x86_64-suse-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for MONO_MODULE... yes
checking for mono... /usr/bin/mono
checking for dmcs... /usr/bin/dmcs
checking for Mono 4.0 GAC for System.dll... found
checking for Mono 4.0 GAC for System.Security.dll... found
checking for Mono 4.0 GAC for System.Windows.Forms.dll... found
checking for Mono 4.0 GAC for Mono.Posix.dll... found
checking for NUNIT... yes
checking for JSON... no
configure: error: "newtonsoft-json is a required dependency: you need to install the appropriate devel package before you can compile"

"Newtonsoft.Json" is installed via nuget, and I think its also already included in monodevelop packages.

Does anyone have a clue how I can solve this problem ?

Greets, Kai

myii...@gmail.com

unread,
May 23, 2015, 10:29:00 PM5/23/15
to cmis...@googlegroups.com, gronn...@googlemail.com
Apologies if this ends up being a double post but I have issues when using this site with Firefox.

I was able to get it to work, albeit on Ubuntu 14.04, by following the instructions at: https://github.com/aegif/CmisSync/blob/master/CmisSync/Linux/README.md

Hazarding a guess based on your error, perhaps you missed the section:

$ git submodule init
$ git submodule update

Nicolas Raoul

unread,
May 23, 2015, 10:55:18 PM5/23/15
to cmis...@googlegroups.com
Well spot Myliqbal!
Indeed it was most probably the problem.

Gronny1, does it work better with that?

Cheers!
Nicolas Raoul
CmisSync team
Aegif
> --
> You received this message because you are subscribed to the Google Groups
> "CmisSync" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to cmissync+u...@googlegroups.com.
> For more options, visit https://groups.google.com/d/optout.
>

myii...@gmail.com

unread,
May 25, 2015, 3:15:48 PM5/25/15
to cmis...@googlegroups.com
Nicolas,

Sorry to hijack this thread but I've worked out why the application + indicator icons are not working, at least with the .deb package in Ubuntu.  I've seen that there are at least two open issues about this:
It's also clear that the code hosted on GitHub is for version 2.2.3, the .deb file is version 2.3.3 and there are binaries available for 2.4.0!  I'm not sure where the best place is to give feedback.  So would you rather I:
  1. Make a new post in these Google forums?
  2. Respond to one of those GitHub issues above?
  3. Make a new GitHub issue?
  4. Reverse engineer the 2.4.0 Windows binary...?!
  5. [Insert your favourite method here!]
By the way, from looking at the source code that's available, the changes will need to be made in the tree below `CmisSync/Linux/Pixmaps/icons`, both to the icon paths and the Makefiles, in order to fix this so it works with ANY desktop theme that is being used, since it only currently works if the theme is based on `ubuntu-mono-dark` or `ubuntu-mono-light`.  Of course, I could be totally, utterly wrong - at the very least, I've rebuilt the .deb (based on your method at https://github.com/aegif/CmisSync/wiki/Packaging) so that at least the icons work when installed...

Nicolas Raoul

unread,
May 25, 2015, 10:38:46 PM5/25/15
to cmis...@googlegroups.com
Hi Myiiqbal,

Thanks a lot for the investigation!

The best is to comment on the Github issues, and don't hesitate to create new issues for any problem you find.

I don't think there is any need to reverse-engineer as all of the source code is available on Github.

It is wonderful that you have found how to fix these problems! Could you please send a Github pull request? (if you are familiar with Git, otherwise just sending the source code is OK too)
I will release a new version after merging.

Thanks again!
Nicolas Raoul
CmisSync team
Aegif

myii...@gmail.com

unread,
May 26, 2015, 12:42:43 AM5/26/15
to cmis...@googlegroups.com
OK, hopefully I'll get some free moments to put it all together in next day or two and send through a PR.  After that, the .deb instructions can be updated to include the paths to the icons.

I was only teasing you about reverse engineering!  What I was really saying is that the code on GitHub is for an older version, so one feels a bit more concerned when doing work on a PR, that it might not be worth investing the energy.  That's why I wanted to get your feedback first, to find out how effort can be best spent.

I'll catch you up on GitHub soon.

Apologies to @gronny1 for this thread hijack!  I hope your original problem was resolved.  Thanks for letting us use "your space" for our discussions - you've been a wonderful host!

Nicolas Raoul

unread,
May 26, 2015, 2:44:49 AM5/26/15
to cmis...@googlegroups.com
"for an older version"
Oh really? What is missing?
I think I have pushed everything, but maybe I forgot to push something?
If yes please let me know what is missing and I will push it :-) My local Git repo says "up-to-date".

Cheers!
Nicolas Raoul
CmisSync team
Aegif

myii...@gmail.com

unread,
May 26, 2015, 1:30:44 PM5/26/15
to cmis...@googlegroups.com
A challenge... interesting!

So I clone a fresh copy of the GitHub repo, install and run.  Hit About:

  • So I think: "Hah, 2.2.3.0 - what do you think about that, Nicolas?" - 1-0 to me...

Then I check the git log and what's the last entry?

Bumped version 2.4
  • So I think: "Hmmph, Nicolas was right, it is version 2.4.0 - no reverse engineering the Windows binary after all...!" - so now it's 1-1...

So I think, "let's work out where this 2.2.3 is coming from..."

$ rgrep -I "2\.2\.3"
configure
.ac:m4_define([cmissync_version], [2.2.3])
  • Only one match, interesting...

Changed that line to 2.4.0, rebuilt, reinstalled and ran.  Hit About:

  • So there it is!  You tricked me!  But I found you out and so it's 2-1 to me - I win!
Hope you're not a sore loser, Nicolas!

Nicolas Raoul

unread,
May 26, 2015, 9:52:32 PM5/26/15
to cmis...@googlegroups.com
Hi Myiiqbal,

Great find!!! You win the Internet today :-D

It is indeed my fault, my own instructions for the .deb build were erroneous, as they did not include the "modify configure.ac" part.
I fixed the instructions, so this mistake should not happen again ;-)

Cheers!
Nicolas Raoul
CmisSync team
Aegif

dany

unread,
Mar 23, 2016, 10:22:59 PM3/23/16
to CmisSync, gronn...@googlemail.com
Hi everybody,

I was starting a new thread but I've seen there's this one already open so here I am.

I'm on Opensuse 13.1 and I've installed all the required packages. After doing the make I get this problem:

error CS0006: Metadata file `%{_monodir}/newtonsoft-json/Newtonsoft.Json.dll' could not be found

The fact is that I've already installed that package:

    zypper addrepo http://download.opensuse.org/repositories/home:tpokorra:mono/openSUSE_13.1/home:tpokorra:mono.repo
    zypper refresh
    zypper install newtonsoft-json-opt newtonsoft-json-devel newtonsoft-json

When doing the ./configure --with-dotcmis=Extras/DotCMIS.dll  in fact I haven't problems:

...
checking for Mono 4.0 GAC for Mono.Posix.dll... found
checking for NUNIT... yes
checking for JSON... yes
checking for NOTIFY_SHARP... yes
...


Any hint? I've done the git init etc thing as you suggested, and also tried to clone again the repository but nothing seems working..
 

Nicolas Raoul

unread,
Mar 23, 2016, 10:58:57 PM3/23/16
to cmis...@googlegroups.com
Hello Dan,

Thank you for reporting the problem!
Would you mind posting it as a new issue to https://github.com/aegif/CmisSync/issues ?

Thank you!
Nicolas Raoul
CmisSync team
Aegif

Reply all
Reply to author
Forward
0 new messages