cmis spaces with hosted Alfresco 0.62 cmis implementation

60 views
Skip to first unread message

sreiner

unread,
Aug 13, 2009, 2:03:41 AM8/13/09
to CMIS Interoperability
After changing things in cmis spaces for 0.62:

(atompub rest only)

Alfresco hosted 0.62 implementation:

1. Tree and folder navigation works
2. Delete works
3. Upload works
4. Create folder sort of works (creates document) (I think just need
to update the xml syntax)
5. View properties works
6. Have problems with basic search ( posting query xml doc doesn't
respond )
SELECT * FROM document WHERE contains ('searchText')
(Tried changing xml to match example in the spec 0.62 doc and and
the example file in the schema dir of the spec)
(Note: hosted alfresco web page REST API Binding Test Harness
testQuery also doesn't respond / times out)
*** Test started: testQuery (remote: true)
*** Error: testQuery
java.net.ConnectException: Connection timed out: connect
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:
195)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)

David Caruana

unread,
Aug 13, 2009, 4:18:56 PM8/13/09
to CMIS Interoperability
Hi Steve,

The server is stuck in the javascript debugger - there's something
unexpected about the query request.

If you could post your query request, that'll help me tighten up the
error checking.

I've switched off the javascript debugger and am restarting the hosted
server.

For reference, here are a couple of example requests (one for create
folder, and one for query)...

<?xml version="1.0" encoding="utf-8"?>
<entry xmlns="http://www.w3.org/2005/Atom" xmlns:cmisra="http://
docs.oasis-open.org/ns/cmis/restatom/200901" xmlns:cmis="http://
docs.oasis-open.org/ns/cmis/core/200901">
<title>title</title>
<summary>summary</summary>
<cmisra:object>
<cmis:properties>
<cmis:propertyId
pdid="cmis:ObjectTypeId"><cmis:value>cmis:folder</cmis:value></
cmis:propertyId>
</cmis:properties>
</cmisra:object>
</entry>

<cmis:query xmlns:cmis="http://docs.oasis-open.org/ns/cmis/core/
200901" >
<cmis:statement>select * from ...</cmis:statement>
<cmis:skipCount>0</cmis:skipCount>
<cmis:maxItems>10</cmis:maxItems>
</cmis:query>

Hope that helps,
Dave


On Aug 13, 7:03 am, sreiner <steverei...@integratedsemantics.com>
wrote:

Steve Reiner

unread,
Aug 13, 2009, 6:03:02 PM8/13/09
to cmis-i...@googlegroups.com
Thanks Dave.

1. Create folder now works once I updated from .61 to .62 xml syntax
(Like your example)

2. search query: server responsds now, must have just been in a bad state
stuck in the js debugger
<cmis:statement>SELECT * FROM document WHERE contains
('alfresco')</cmis:statement>
<cmis:skipCount>0</cmis:skipCount>
<cmis:maxItems>100</cmis:maxItems>
</cmis:query>

repsonds now and gave nice error msg
<tr><td><b>Exception:</b></td><td>org.alfresco.cmis.CMISQueryException -
07130006 Type is unsupported in query: document</td></tr>

Changed to
SELECT * FROM cmis:document WHERE contains ('alfresco')
And it worked returning the result set

Also adding back in this seemed still to work
<cmis:searchAllVersions>true</cmis:searchAllVersions>


Don't know if some variations got query into a not responding state:
Having these elements
<cmis:pageSize>100</cmis:pageSize>
<cmis:returnAllowableActions>false</cmis:returnAllowableActions>


Using this namespace that was in the draft 62f spec:
xmlns=”http://www.cmis.org/CMIS/1.0


(PS: Also noticed the nightly bld from august 11 still was 0.61 cmis)

Steve
Reply all
Reply to author
Forward
0 new messages