ClusterHat issue after reboot again

42 views
Skip to first unread message

capnrob97

unread,
May 27, 2021, 10:18:31 AMMay 27
to ClusterHAT
Clusterhat 2.5, the CNAT image on the controller, and the p1,p2,p3,p4 images downloaded from the software site.

Is there a certain sequence of 'clusterctrl on, hub on, etc' I need to do after a reboot?

I am back to the situation of after a reboot:

pi@cnat:/var/log $ ping p1.local
ping: p1.local: Name or service not known

none of the p#.local are accessible, can't ping them, can't ssh into them.

I posted same issue a few days agao and it magically started working after some time.

The reboot was half hour ago and still no luck connecting to the zeros. 

I feel I am just not starting up the hat properly or something after the controller reboots.

These are all booting off a shared ssd, if that matters.

Peter Cross

unread,
May 27, 2021, 10:45:43 AMMay 27
to clust...@googlegroups.com
This is what worked for me. If you edit the crontab they can start automatically on boot/reboot.

Create a cron job to start when the Pi start up by running "crontab -e" to create the job and just paste in "@reboot /sbin/clusterhat on" at the end.

Cheers!

Peter J. Cross
San Antonio, TX

"Experience has taught mankind the necessity of auxiliary precautions"
-James Madison, Federalist Paper No. 51

Please consider the environment before printing this email


--
You received this message because you are subscribed to the Google Groups "ClusterHAT" group.
To unsubscribe from this group and stop receiving emails from it, send an email to clusterhat+...@googlegroups.com.
To view this discussion on the web, visit https://groups.google.com/d/msgid/clusterhat/0e86c561-777b-41ae-a9d4-770dc4758395n%40googlegroups.com.

capnrob97

unread,
May 27, 2021, 10:51:22 AMMay 27
to ClusterHAT
Seems like this is what I need to do.

1) ssh into each zero and shutdown
2) clusterctrl off
3) clusterctrl hub off
4) reboot controller pi
5) after controller reboot:
   a) clusterctrl hub on
   b) clusterctrl on p1
        wait until p1 boots up, then clusterctrl on p2, wait, clusterctrl on p3, wait, clusterctrl on p4

Now all zeros are accessible.

I will follow this procedure for shutdown, startup going forward.

capnrob97

unread,
May 27, 2021, 10:57:04 AMMay 27
to ClusterHAT
Thanks Peter. It seems when I do just clusterctrl on they fail to boot, but if I stagger booting each one, then it works fine

Chris Burton

unread,
May 29, 2021, 4:44:35 AMMay 29
to ClusterHAT
Hi,
 If the Pi Zeros are powered on when you're rebooting the controller you really shouldn't be running that set of commands as it will corrupt your Pi Zero SD cards if they were already powered on.

Please explain your setup and how to replicate the problem from initial power up.

Do you know which version of CNAT image you're using?
What changes have you made to the images if any?
Have you updated the software and if so how?
If P1 is on and accessible try pinging "p1.local" from the controller before rebooting it, does it ping 172.19.181.1 as I'd expect?
What does "clusterctrl status" look like before rebooting the controller?
After the reboot wait a couple of minutes then what does "clusterctrl status" look like?
Can you "ping p1.local" after it has been up a few minutes, can you "ping 172.19.181.1" ?

Chris. 
Reply all
Reply to author
Forward
0 new messages