FYI: OpenStack Nova on Unbuntu 10.10

9 views
Skip to first unread message

李柏鋒 (Pofeng Lee)

unread,
Dec 3, 2010, 12:21:29 PM12/3/10
to cloudtw
FYI: OpenStack Nova on Unbuntu 10.10

http://fnords.wordpress.com/2010/12/02/bleeding-edge-openstack-nova-on-maverick/

--
Pofeng "informer" Lee, 李柏鋒, pofeng at gmail dot com

cclien

unread,
Dec 4, 2010, 12:06:58 PM12/4/10
to clo...@googlegroups.com
Hi Pofeng

Have you tried this already? :D

Best Regards,
cclien

Hugo

unread,
Dec 5, 2010, 4:08:56 AM12/5/10
to CloudTW
HI guys...
I tried OpenStack before
在一台機器上跑NOVA
另一臺機器上跑SWIFT

分開作業都正常,從nova開instance沒問題,或是用swift tool 把東西丟進去swift都沒問題
目前openstack Austin Release 還不能從NOVA把image bundle 到SWIFT, 這是一個叫做Glance的
Project
Glance 有實驗用的可是需要working code...

從user角度 我認為目前還不能用來production

雖然有聽說目前有個人使用者 有在使用nova

swift的部份是已經production 了 包含RackSapce有在使用

沒有Web-Console

Volume storage可以用Sheepdog....but I never try it

一點小小心得

IRC channel freenode.net #openstack
ID: hugokuo


On 12月5日, 上午1時06分, cclien <ccl...@gmail.com> wrote:
> Hi Pofeng
>
> Have you tried this already? :D
>
> Best Regards,
> cclien
>
> On Sat, Dec 4, 2010 at 1:21 AM, 李柏鋒 (Pofeng Lee) <pof...@gmail.com> wrote:
>
> > FYI: OpenStack Nova on Unbuntu 10.10
>

> >http://fnords.wordpress.com/2010/12/02/bleeding-edge-openstack-nova-o...

李柏鋒 (Pofeng Lee)

unread,
Dec 5, 2010, 5:17:33 AM12/5/10
to clo...@googlegroups.com
我剛剛試過, 沒問題

不過原本說明所用的 uec 的 image 我弄不起來
( ubuntu enterprise clound 只有兩個 image : kernel root )

我是改用 eucalyptus 的 image
自己上傳 ( 三個 image : kernel ram root )

目前還沒空 try EBS

2010/12/5 cclien <ccl...@gmail.com>:

Hugo

unread,
Dec 5, 2010, 6:59:11 AM12/5/10
to CloudTW
EBS is working..... no problem
MySQL................. is working

EBS 的部份 GroupVolume 需要有一個叫做 nova-volume 因為nova在運行 volume manager 的時候會去
check /dev下面的 nova-volume 資料夾 也許是個bug 吧

http://www.openstack.org/
https://answers.launchpad.net/openstack

Images...測試後可用
http://wiki.openstack.org/GettingImages


RackSpace CDN small image 無法使用EBS , 原因可能是busybox

On 12月5日, 下午6時17分, 李柏鋒 (Pofeng Lee) <pof...@gmail.com> wrote:
> 我剛剛試過, 沒問題
>
> 不過原本說明所用的 uec 的 image 我弄不起來
> ( ubuntu enterprise clound 只有兩個 image : kernel root )
>
> 我是改用 eucalyptus 的 image
> 自己上傳 ( 三個 image : kernel ram root )
>
> 目前還沒空 try EBS
>
> 2010/12/5 cclien <ccl...@gmail.com>:
>
>
>
> > Hi Pofeng
>
> > Have you tried this already? :D
>
> > Best Regards,
> > cclien
>
> > On Sat, Dec 4, 2010 at 1:21 AM, 李柏鋒 (Pofeng Lee) <pof...@gmail.com> wrote:
> >> FYI: OpenStack Nova on Unbuntu 10.10
>

> >>http://fnords.wordpress.com/2010/12/02/bleeding-edge-openstack-nova-o...

Pofeng Lee

unread,
Dec 10, 2010, 1:21:38 PM12/10/10
to CloudTW
Hi, Hugo

( sorry in English, no input method in this machine )

I can not connect to my EBS volume, do you have any idea ?

pofeng@thinkpad:/$ euca-describe-volumes
VOLUME vol-jr0i0vjj 5 nova creating (ttx, None, None, None)
2010-12-10 17:08:04.140495

pofeng@thinkpad:/$ euca-attach-volume -i i-68czpe -d /dev/sdb vol-
jr0i0vjj
Unknown: Volume status must be available

I had 2 kinds of image, one is ttylinux-uec-amd64 ( from
http://smoser.brickies.net/ubuntu/ttylinux-uec/ )
the other one is centos.5-3.x86.img ( from eucalyptus )

Should I try following commands ? ( described in
http://nova.openstack.org/getting.started.html )

# This creates a 1GB file to create volumes out of
dd if=/dev/zero of=MY_FILE_PATH bs=100M count=10
losetup --show -f MY_FILE_PATH
# replace /dev/loop0 below with whatever losetup returns
# nova-volumes is the default for the --volume_group flag
vgcreate nova-volumes /dev/loop0

I agree with you that Eucalyptus is more stable and productive.

But I found that OpenStack support UML ( user mode linux ) so that we
can run/test Open Stack in the
Virtual Machine. I think it would be very convenient for us if we want
to hold another installfest.

On Dec 5, 7:59 pm, Hugo <tonyt...@gmail.com> wrote:
> EBS is working..... no problem
> MySQL................. is working
>
> EBS 的部份 GroupVolume 需要有一個叫做 nova-volume  因為nova在運行 volume manager 的時候會去
> check /dev下面的 nova-volume 資料夾  也許是個bug 吧
>
> http://www.openstack.org/https://answers.launchpad.net/openstack
>
> Images...測試後可用http://wiki.openstack.org/GettingImages

Hugo

unread,
Dec 10, 2010, 9:42:15 PM12/10/10
to CloudTW
hello pofeng~
could you plz check the volum-manager message for me?
In my case , I use EBS through volume-group

1. echo "ISCSITARGET_ENABLE=true" | sudo tee /etc/default/iscsitarget
2. sudo /etc/init.d/iscsitarget restart
(or get Vish's new novascript 2010-11-15 updated)

3.dd if=/dev/zero of=<you named a loopback device as your will>
bs=<size ex.1G> count=<bs counts>

4.losetup -f --show <your loopback device file name>
>/dev/loopX

5. apt-get -y install lvm2

6. vgcreate nova-volumes /dev/loopX

7. vgdisplay
(to make sure how many PE do I have)

8. lvcreate -L 1G -n test nova-volumes

9. ls /dev/nova*
(if there is a floder named nova-volumes , success!)

My issue records
https://answers.launchpad.net/nova/+question/134020
Reply all
Reply to author
Forward
0 new messages