Possible bug: VM does not release resources when shutdown

0 views
Skip to first unread message

Fazirul Hanafe

unread,
Feb 25, 2022, 8:49:52 PMFeb 25
to CloudSim Plus: Cloud Simulation Framework
I am currently trying out a simple simulation by assigning a single CloudletSimple with the default UtilizationModelNull for ram and bandwidth. After the cloudlet has finished execution on the allocated VM (VmSimple) and the VM has shutdown, I noticed that the VM does not release ram and bandwidth resources on the host. A quick solution is to use UtilizationModelFull instead for ram and bandwidth.

I want to know is this the expected behaviour? Shouldn't the host release all resources used by the VM even if the VM utilization is not 100%?

Seems like the logic is done in HostSimple.deallocateResourcesOfVm(final Vm vm). You can set a breakpoint on line 673 when debugging to verify the bug.

Thank you!

Prof. Manoel Campos

unread,
Mar 8, 2022, 12:48:35 PMMar 8
to clouds...@googlegroups.com
Hello Fazirul,
Your message went straight to my spam folder.
This may occur because, by default, the broker just finishes VMs it's shutdown.
I don't know if that is the case, but try calling broker.setVmDestructionDelay(1);

That indicates all VMs must be destroyed 1 second after becoming idle.

Manoel Campos da Silva Filho Software Engineer

Computer Science and Engineering Ph.D. Student at University of Beira Interior (Portugal)

Professor at Federal Institute of Education, Science and Technology of Tocantins (Brazil)

http://manoelcampos.com


 about.me


--
If you received an answer that worked for you, please be kind and reply to let everybody knows it worked.
http://cloudsimplus.org
---
You received this message because you are subscribed to the Google Groups "CloudSim Plus: Cloud Simulation Framework" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cloudsim-plu...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/cloudsim-plus/8f0ffa64-8bde-41f2-81f1-29e1ec81af40n%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages